LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-09-2012, 05:16 PM   #1
nepalnt21
LQ Newbie
 
Registered: Apr 2012
Distribution: debian
Posts: 26

Rep: Reputation: Disabled
boot into command line debian squeeze


ok so ive reinstalled squeeze, this time with the gui installed.

but now i want to set it up so that instead of booting into the gui login screen, i boot into the command line and do everything from there.

so far ive tried

update-rc.d -f gdm remove
update-rc.d -f kdm remove
update-rc.d -f xdm remove


no errors,

but it still boots up into the log in screen. is this an old method that doesnt work for squeeze?

thanks for any help
 
Old 04-09-2012, 05:34 PM   #2
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,054

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
First off what DE did you install and what dm?

Why not just "apt-get remove <somedm>"?

There really should not be more than one installed.
 
Old 04-10-2012, 12:48 PM   #3
nepalnt21
LQ Newbie
 
Registered: Apr 2012
Distribution: debian
Posts: 26

Original Poster
Rep: Reputation: Disabled
it came with gnome, i added lxde and i3. if i delete them all and reinstall the one or two i want, will it solve the problem?
 
Old 04-10-2012, 01:58 PM   #4
fatmac
Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey-Hants Border
Distribution: Debian & Debian based distros
Posts: 228

Rep: Reputation: Disabled
One way that I have done it; as root, go into '/etc/rc2.d', 'mv S21gdm oldS21gdm', save the file.
Next time you boot up, it should start with all services, except gdm will not be started.

Hope that helps you do what you want.
 
Old 04-10-2012, 02:05 PM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Edit
Code:
/etc/inittab
and set the runlevel to 3
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
reboot

Kind regards
 
Old 04-10-2012, 05:01 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Cool

Quote:
Originally Posted by repo View Post
Edit
Code:
/etc/inittab
and set the runlevel to 3
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
reboot

Kind regards
Will not work as runlevels 2-5 are the same on Debian.

Debian and Ubuntu Linux Run Levels - http://www.debianadmin.com/debian-an...un-levels.html

Howto Boot debian in text mode instead of graphical mode (GUI) - http://www.debianadmin.com/howto-boo...-mode-gui.html

How to disable X or GUI on boot in Debian - http://www.debianadmin.com/how-to-di...in-debian.html
 
1 members found this post helpful.
Old 04-11-2012, 11:03 AM   #7
nepalnt21
LQ Newbie
 
Registered: Apr 2012
Distribution: debian
Posts: 26

Original Poster
Rep: Reputation: Disabled
thanks for all of the responses

i ended up trying:

update-rc.d -f gdm3 remove
update-rc.d -f wdm remove

this solved it

Last edited by nepalnt21; 04-11-2012 at 11:09 AM.
 
Old 04-11-2012, 09:40 PM   #8
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,878

Rep: Reputation: 1267Reputation: 1267Reputation: 1267Reputation: 1267Reputation: 1267Reputation: 1267Reputation: 1267Reputation: 1267Reputation: 1267
For others who might light on this thread, installing sysv-rc-conf allows you to turn services on and off for various runlevels. It's in the repos.

That was what I used to be able to boot to the CLI without removing the GDM in Debian.
 
Old 09-10-2013, 04:50 PM   #9
slackergeek
LQ Newbie
 
Registered: Feb 2004
Posts: 16

Rep: Reputation: 0
Thumbs up Edit your grub.cfg in /boot/grub/grun.cfg

Just add "text" at the end of the line "### BEGIN /etc/grub.d/10_linux ###" of your grub.cfg

mine read:

/vmlinuz-3.2.0-4-686-pae root=/dev/mapper/idebian-root ro quiet text
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moved /etc/ Debian squeeze won't boot up now Oapples Linux - Newbie 7 12-21-2011 06:48 PM
Debian Squeeze(6.0.2) First Boot Kernel panic. WhateverLinux Linux - Software 3 10-06-2011 12:36 PM
Various segmentation faults Debian Squeeze Virtualbox running on Debian Squeeze host fordwrench Debian 1 07-21-2011 03:55 AM
Debian 6 - Run Level - Boot to Command LIne jv2112 Linux - Newbie 3 03-20-2011 06:00 AM
Debian Squeeze Udev not working - won't boot spoovy Linux - General 2 11-12-2010 06:16 AM


All times are GMT -5. The time now is 08:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration