-   Debian (
-   -   Bluetooth with BCM4313 not working? (

carlos_debian 08-19-2011 02:00 PM

Bluetooth with BCM4313 not working?
Hi everybody,

I have a 2.6.32-5-686, a Debian/squeeze (6.0) distro, and kde4 in my Lenovo G460 notebook.
The wireless chip in this PC is BCM4313:


lspci -vv | grep -i wireless
05:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

WiFi is working, but Bluetooth is not. I installed broadcom-sta from squeeze repos.

The funny thing is that I tried this notebook with a live cd (knoppix 6.7.0), and Bluetooth IS working !!!
When running Knoppix, lsusb showed (among other usb devices):
0489:e00d Foxconn / Hon Hai as the Bluetooth controller.

When I try lsusb with my Debian, it shows:

Bus 002 Device 003: ID 090c:37b3 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.)
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Seems like 0489:e00d is not found by the kernel? (dmesg doesn't show anything weird in Debian, but it DOES show the device in Knoppix).

BTW, btusb is not inserted. I had to manually modprobe it in Debian (it appears in Knoppix, no need to load anything).
This is

lsmod | grep bluetooth
in Debian

bluetooth 36251 7 btusb,sco,rfcomm,bnep,l2cap
rfkill 10196 2 bluetooth

Also, 'rfkill list all' shows NOTHING. It does show WiFi and BT in Knoppix.

I also tried to upgrade to wheezy, all I got is 'rfkill list all' to show something similar to knoppix (but BT does not work with wheezy).
Anyways, I'm back with squeeze.

Did anybody have a similar problem with this controller and BT ???

Thanks is advance for the help!

carlos_debian 08-20-2011 12:36 PM

Any clue? I will really appreciate some help here.... let me know if I need to post more info!

cynwulf 08-20-2011 03:17 PM

No idea really... but try the non-free driver:

carlos_debian 08-20-2011 05:00 PM

Thanks Caravel for your reply.

Following your suggestion, I installed brcm80211 (removed wl driver, changed /etc/modprobe.d/blacklist.conf and broadcom-sta-common.conf, modprobe brcm80211, /etc/init.d/bluetooth restart), and now rfkill shows WiFi, but still no Bluetooth.


rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

lsmod doesn't show btusb (have to load it manually, and lsusb doesn't show any bluetooth driver.....

After loading btusb:


lsmod | grep bluetooth
bluetooth              36251  7 btusb,sco,bnep,rfcomm,l2cap
rfkill                10196  3 cfg80211,bluetooth



lsmod | grep brcm
brcm80211            574593  0
mac80211              122866  1 brcm80211
cfg80211              86977  2 brcm80211,mac80211



lsmod | grep usb
btusb                  8097  0
bluetooth              36251  7 btusb,sco,bnep,rfcomm,l2cap
usb_storage            30797  0
usbcore                98613  5 btusb,uvcvideo,usb_storage,ehci_hcd
nls_base                4541  1 usbcore
scsi_mod              104593  5 sg,usb_storage,sr_mod,sd_mod,libata

Seems like the kernel is not loading the driver or bluetooth firmware for the BCM4313 (I'm comparing Knoppix kernel output and my debian kernel output)... is this possible? I think I read somewhere that this is an hybrid chip.. this means that BT and WiFi need different firmware?

Thanks again, any help is welcome!

tix 08-26-2011 03:17 AM

Here's a page with helpful tutorials including Bluetooth but mainly for Slackware:


carlos_debian 08-26-2011 09:07 AM

Thanks tix for pointing out that tutorial. I will give it a try tonight, and let you know!

I tried to install the same kernel and same .config, from Knoppix... but it didn't work. Rfkill shows both WiFi and BT, but lsusb doesn't show Bluetooth.

One thing that calls my attention is that my actual kernel uses ehci_hcd and ahci (that's what a dmesg | grep -i hci shows). Of course, dmesg | grep -i blue shows NOTHING.

In the tutorial (and knoppix running from the liveCD), I can see HCI ....... and dmesg | grep -i throws a couple of lines.

What's the difference between ehci, ahci, hci, etc..???

All times are GMT -5. The time now is 12:37 PM.