Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 04-26-2014, 04:28 AM   #1
LQ Newbie
Registered: Apr 2014
Posts: 5

Rep: Reputation: Disabled
block cursor at terminal login


using debian wheezy

the idea is to get a block cursor for login at e.g. tty1.
after inserting
PROMPT_COMMAND='echo -e "\e[?6;0;0c"'
in /etc/bash.bashrc every user gets a nice block cursor after login which makes me already a bit happy.
but there is still the underscore cursor for the first login.

adding same code in
/etc/rc.local or
/etc/init.d/rc.local or
is already tried but didn't give the wanted result.

a solution is apreciated, but a hint (or two) would help a newbie like me to get a feeling for runlevels etc.

fair day

Last edited by bluebarnstormer; 04-26-2014 at 08:37 PM. Reason: signature added
Old 04-30-2014, 01:07 AM   #2
LQ Newbie
Registered: Apr 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled
hi community,

if anybody is interested in solving this problem, please leave a note. there are so many features involved... therefor i could need some help.

the background for the block cursor (the interested member might want to know) is as followed:

a classroom full of unix-noobs like me want to learn basics on console. the teacher is working with a beamer, and the cursor is not really visible.
of course one could add apropriate code lines in the related user files to get a nice block cursor after login, then logout, and now there is a block cursor at login.
but that isn't cool i think.

trying to figure this problem out, i learned already a bit about vi, grep, find, insserv, runlevels, startscript, interpretation of the bash, escape sequences and a lot more i forgot already lol.

and it worked tonight, but only for tty2-6. but i messed up files after removing all comment i made in the process, and now i start again.

by the way, in suse sles (versin 11.something) it worked after a short time, but there is a default empty startscript...

i am a bit disapointed because noone likes to help, but i let you know when and how it worked 100%.

fair day to all of you
Old 04-30-2014, 09:13 AM   #3
LQ Newbie
Registered: Apr 2014
Posts: 5

Original Poster
Rep: Reputation: Disabled

the line
echo -e "\e[?81;0;112c" > /dev/tty1
in a new startscript (hint: update-rc.d) gives a white non-blinking and "transparent" block cursor at tty1 login.

though i didn't try it with wheezy but squeeze! that is ok by me, and i hope it's ok for the interested member aswell.

i'll have, and for all of you a

fair day



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
The last character covered by the cursor in a terminal sheller Slackware 1 06-22-2010 01:29 AM
adjust the speed of the cursor in terminal wucheng Linux - Server 2 02-14-2009 04:01 PM
Changing the default (block) cursor major.tom Slackware 3 07-15-2005 07:28 PM
Linux console mono-color, blinking block cursor introuble Linux - General 1 06-24-2005 06:08 PM
Mouse cursor has become HUGE block walterbyrd Debian 2 05-06-2004 10:21 AM > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration