-   Debian (
-   -   black screen/unresponsive system after boot messages (or after startx) (

ftdwffs 01-27-2011 11:15 PM

black screen/unresponsive system after boot messages (or after startx)
note: this is on a desktop.

Yesterday, I was updating about 60-70 packages on my debian squeeze system and after it was finished, it requested a reboot.

A few minutes later I attempted to reboot. Now usually, in the reboot process, my monitor would displays a bunch of console messages (sending all processes blablabla etc). This time, before seeing those messages, my screen just turned black (backlight still on).

I waited a few minutes but the computer was just frozen. Pressing num lock or caps lock didn't do anything to the keyboard LEDs. So... I decided to hold down the power button to force the computer down and then boot again.

I tried to boot into debian again. Everything was normal except the boot message showed some stuff about fsck and recovering from the journal (which i guess is the result of a forced shutdown)... and then after it says "starting gnome display manager" and another line after that, the black screen comes again so i do another forced shutdown

this is roughly what I've done after that:

backup some files with my knoppix live usb

umount / + fsck --- that didn't do anything.

look through dmesg and other files in /var/log --- haven't found anything interesting yet. the x log files are completely empty.

boot into debian's single-user mode --- that worked fine.

startx in single-user mode --- black screen again.

while in black screen, ctrl alt + f123456/backspace --- no response.

I changed the driver in xorg.conf from "fglrx" to "ati" and now the system's alive... which means fglrx is broken somehow.

Hangaber 01-28-2011 12:05 AM

Last week I had to rebuild the fglrx module due to an upgrade to x-server. After that it was peachy again.

All times are GMT -5. The time now is 09:05 AM.