LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-20-2005, 12:07 AM   #1
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Rep: Reputation: 30
bitorrent deb dpkg installation complaint about python


I'm trying to install the bittorrent deb on my stable (woody) system and this is what happens:
# dpkg -i bittorrent_3.4.2-3_all.deb
(Reading database ... 51439 files and directories currently installed.)
Preparing to replace bittorrent 3.4.2-3 (using .../bittorrent_3.4.2-3_all.deb) ...
Unpacking replacement bittorrent ...
dpkg: dependency problems prevent configuration of bittorrent:
bittorrent depends on python (>= 2.3); however:
Version of python on system is 2.1.3-3.
dpkg: error processing bittorrent (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
bittorrent

but I did install a new python from testing:

# dpkg -s python2.3
Package: python2.3
Status: install ok installed
Priority: standard
Section: python
Installed-Size: 9392
Maintainer: Matthias Klose <doko@debian.org>
Version: 2.3.5-1
Replaces: python2.3-xmlbase
Provides: python2.3-xmlbase
Depends: libbz2-1.0, libc6 (>= 2.3.2.ds1-4), libdb4.2, libncurses5 (>= 5.4-1), libreadline4 (>= 4.3-1), libssl0.9.7, zlib1g (>= 1:1.2.1)
Recommends: python2.3-iconvcodec | python2.3-cjkcodecs | python2.3-japanese-codecs, python2.3-iconvcodec | python2.3-cjkcodecs | python2.3-korean-codecs
Suggests: python2.3-doc, python2.3-profiler
Conflicts: python2.3-xmlbase, python2.3-csv, python2.3-dev (<< 2.3.4-15)
Conffiles:
/etc/python2.3/site.py 8eb9ffc159683a8f12d63c07335b745a
Description: An interactive high-level object-oriented language (version 2.3)
Version 2.3 of the high-level, interactive object oriented language,
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.

What's going on?

Update: I hadn't installed the 'python' package (although I did install 'python2.3' ). But trying to install that also doesn't work:

# dpkg -i python_2.3.5-1_all.deb
dpkg: regarding python_2.3.5-1_all.deb containing python:
reportbug conflicts with python (>> 2.3)
python (version 2.3.5-1) is to be installed.
dpkg: error processing python_2.3.5-1_all.deb (--install):
conflicting packages - not installing python
Errors were encountered while processing:
python_2.3.5-1_all.deb

Can anyone explain to me what all this means?

Last edited by celejar; 04-20-2005 at 11:40 AM.
 
Old 04-21-2005, 08:56 PM   #2
damienduff
Member
 
Registered: Feb 2004
Distribution: Etch
Posts: 117

Rep: Reputation: 15
looks like you are trying to upgrade your bittorrent.

woody does not haf bittorrent in its respository.
maybe you can try backports.
add this in sources.list
deb http://mirror.xaranet.de/debian-backports/debian stable all
 
Old 04-22-2005, 10:59 AM   #3
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Original Poster
Rep: Reputation: 30
Thanks. I know woody doesn't have bittorrent; I'm trying to install the sarge package. I installed whatever seemed to be its dependencies, but am running into trouble as above. I'm going to check out the site damienduff suggested.
 
Old 04-22-2005, 11:38 AM   #4
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Original Poster
Rep: Reputation: 30
Update: I got the backport but it won't install; it complains about libwx-python 2.3 being required and I don't know where to get that (woody has 2.2).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
APT/dpkg errors! /var/lib/dpkg/status bassclarinet Debian 16 12-01-2011 09:24 AM
dpkg is dead! error in /var/lib/dpkg/available dezert_fox Debian 4 11-22-2011 10:28 AM
dpkg -i .deb and apt-get, ok to mix? r3dhatter Debian 1 09-24-2005 10:13 PM
Is there any script to reverse the process of dpkg -i file-1.1.1.deb? sunzaifa Debian 2 08-03-2004 09:01 AM
PROBLEM with Qt library and KDE installation from .deb lipkaj Debian 4 10-31-2003 06:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration