LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-03-2006, 09:37 PM   #1
Crushing Belial
Member
 
Registered: Mar 2005
Location: University of Massachusetts - Lowell
Distribution: Ubuntu, Win 7 Pro, Win 7 Enterprise
Posts: 126

Rep: Reputation: 15
Best way to install ATI driver on Debian Etch?


I just installed Debian Etch on a ThinkPad R52 with a Radeon Mobility X300 gfx chip. I noticed the fglrx-driver is available in unstable, but it requires Xorg 7.0. What would be the best way to get the driver installed? Could I just simply alien the RPM from ATI's website, and install it, and have working 3D acceleration?
 
Old 05-04-2006, 02:35 AM   #2
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
Yes, you could. You'd just have to convert the ATI's rpm-package to Deb with "alien", or use the ATI graphical installer. Upon installation dpkg might complain about files been overwritten by the new .deb package; just take backups of those files, and use force options in dpkg to get the package installed (--force-all might do it, see man dpkg).
 
Old 05-04-2006, 07:45 AM   #3
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Rep: Reputation: 15
Read my post: http://www.linuxquestions.org/questi...d.php?t=441507
 
Old 05-04-2006, 10:20 AM   #4
mikethefrog
LQ Newbie
 
Registered: May 2006
Location: London
Distribution: Debian Etch
Posts: 5

Rep: Reputation: 0
My Recommendation

How I installed Debian Testing on a PC with a ATI Radeon X550 PCI Express card. Using the proprietary ATI driver with 3D Acceleration.

Using the latest network install CD.
Choosing Basic system.

Then loading gnome, menu, x-window-system-core and gdm using apt-get install.

The automatic hardware recognition recognises an ati card so puts the ati driver in xorg.conf, X will not start.
To get an X session started all I did was to use the vesa driver instead of the ati driver in xorg.conf,
Section "Device"
Identifier "ATI Technologies, Inc. Radeon X600 (RV370)"
Driver "vesa"
# Option "UseInternalAGPGART" "no"
# Option "VideoOverlay" "on"
# Option "OpenGLOverlay" "off"
# Option "MonitorLayout" "AUTO, AUTO"
# BusID "PCI:1:0:0"
# Option "UseFBDev" "true"
EndSection
and commented out all the ati specific options.
The Debian Installer picks up the X550 as a X600.
I then set other packages on the PC as I wanted with Synaptic.
Then set about the task of getting 3D acceleration working on the X550 card.

After trying to use the debian fglrx-driver, which is currently in SID and getting lots of issues, I gave up and gave the ATI Installerīs package builder a try.
I downloaded it from the ati main site. This forum is stopping me from posting the url until I have made 3 posts but you can find it a wwwdotatidotcom and follow the downloads/linux links.

As Root
If you run:-
sh ati-driver-installer-8.24.8-x86.run --help
It lists all the available options for you. I chose the following.
sh ati-driver-installer-8.24.8-x86.run --buildpkg Debian/Testing

It creates 5 packages in whatever directory you put the orginal file.
fglrx-driver_8.24.8-1_i386.deb
fglrx-driver-dev_8.24.8-1_i386.deb
fglrx-kernel-src_8.24.8-1_i386.deb
fglrx-control-qt3_8.24.8-1_i386.deb
fglrx-sources_8.24.8-1_i386.deb

Then....
dpkg -i fglrx-driver_8.24.8-1_i386.deb
dpkg -i fglrx-kernel-src_8.24.8-1_i386.deb
dpkg -i fglrx-control-qt3_8.24.8-1_i386.deb

Then...

module-assistant prepare
module-assistant auto-install fglrx

To test whether it had worked....
I stopped X.
/etc/init.d/gdm stop
modprobe -v fglrx

Which displays info about fglrx if successful.

I then went into xorg.conf and made the following changes...

Section "Device"
Identifier "ATI Technologies, Inc. Radeon X600 (RV370)"
Driver "fglrx"
Option "UseInternalAGPGART" "no"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "MonitorLayout" "AUTO, AUTO"
BusID "PCI:1:0:0"
Screen 0
Option "UseFBDev" "true"
EndSection
Put back all the stuff I had commented out previously, changed the driver to fglrx and added <Screen 0> because I only had 1 screen attached to the card.

And that was it.....
3D acceleration now works

zoe@ZoePC:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X550 Generic
OpenGL version string: 2.0.5755 (8.24.8)

zoe@ZoePC:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
2587 frames in 5.0 seconds = 517.400 FPS
3222 frames in 5.0 seconds = 644.400 FPS
3190 frames in 5.0 seconds = 638.000 FPS
3223 frames in 5.0 seconds = 644.600 FPS
3237 frames in 5.0 seconds = 647.400 FPS
3208 frames in 5.0 seconds = 641.600 FPS
3200 frames in 5.0 seconds = 640.000 FPS

There was a problem with the Ati Control which got installed on my Gnome menu. The program was in the wrong directory, I simply found it and copied it to the correct directory.

The whole system now performs a whole lot better.

I can recommend using the ATI Installer Package builder and not trying to use the Debian fglrx-driver package.
 
Old 05-11-2006, 09:36 PM   #5
operator10001
Member
 
Registered: Mar 2006
Distribution: debian sarge
Posts: 222

Rep: Reputation: 30
i'm not familiar with etch, but, if its like sarge, try this:
apt-get update
apt-get upgrade
apt-get install <packname>
hope this helps
operator
 
Old 09-25-2006, 01:39 AM   #6
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Rep: Reputation: 15
Eventually I 'solved' this by purchasing an nvidia card. Works instantly without any problems.
 
Old 03-07-2007, 02:35 AM   #7
etusch
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Rep: Reputation: 2
Quote:
Originally Posted by mikethefrog
How I installed Debian Testing on a PC with a ATI Radeon X550 PCI Express card. Using the proprietary ATI driver with 3D Acceleration.

Using the latest network install CD.
Choosing Basic system.

Then loading gnome, menu, x-window-system-core and gdm using apt-get install.

The automatic hardware recognition recognises an ati card so puts the ati driver in xorg.conf, X will not start.
To get an X session started all I did was to use the vesa driver instead of the ati driver in xorg.conf,
Section "Device"
Identifier "ATI Technologies, Inc. Radeon X600 (RV370)"
Driver "vesa"
# Option "UseInternalAGPGART" "no"
# Option "VideoOverlay" "on"
# Option "OpenGLOverlay" "off"
# Option "MonitorLayout" "AUTO, AUTO"
# BusID "PCI:1:0:0"
# Option "UseFBDev" "true"
EndSection
and commented out all the ati specific options.
The Debian Installer picks up the X550 as a X600.
I then set other packages on the PC as I wanted with Synaptic.
Then set about the task of getting 3D acceleration working on the X550 card.

After trying to use the debian fglrx-driver, which is currently in SID and getting lots of issues, I gave up and gave the ATI Installerīs package builder a try.
I downloaded it from the ati main site. This forum is stopping me from posting the url until I have made 3 posts but you can find it a wwwdotatidotcom and follow the downloads/linux links.

As Root
If you run:-
sh ati-driver-installer-8.24.8-x86.run --help
It lists all the available options for you. I chose the following.
sh ati-driver-installer-8.24.8-x86.run --buildpkg Debian/Testing

It creates 5 packages in whatever directory you put the orginal file.
fglrx-driver_8.24.8-1_i386.deb
fglrx-driver-dev_8.24.8-1_i386.deb
fglrx-kernel-src_8.24.8-1_i386.deb
fglrx-control-qt3_8.24.8-1_i386.deb
fglrx-sources_8.24.8-1_i386.deb

Then....
dpkg -i fglrx-driver_8.24.8-1_i386.deb
dpkg -i fglrx-kernel-src_8.24.8-1_i386.deb
dpkg -i fglrx-control-qt3_8.24.8-1_i386.deb

Then...

module-assistant prepare
module-assistant auto-install fglrx

To test whether it had worked....
I stopped X.
/etc/init.d/gdm stop
modprobe -v fglrx

Which displays info about fglrx if successful.

I then went into xorg.conf and made the following changes...

Section "Device"
Identifier "ATI Technologies, Inc. Radeon X600 (RV370)"
Driver "fglrx"
Option "UseInternalAGPGART" "no"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "MonitorLayout" "AUTO, AUTO"
BusID "PCI:1:0:0"
Screen 0
Option "UseFBDev" "true"
EndSection
Put back all the stuff I had commented out previously, changed the driver to fglrx and added <Screen 0> because I only had 1 screen attached to the card.

And that was it.....
3D acceleration now works

zoe@ZoePC:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X550 Generic
OpenGL version string: 2.0.5755 (8.24.8)

zoe@ZoePC:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
2587 frames in 5.0 seconds = 517.400 FPS
3222 frames in 5.0 seconds = 644.400 FPS
3190 frames in 5.0 seconds = 638.000 FPS
3223 frames in 5.0 seconds = 644.600 FPS
3237 frames in 5.0 seconds = 647.400 FPS
3208 frames in 5.0 seconds = 641.600 FPS
3200 frames in 5.0 seconds = 640.000 FPS

There was a problem with the Ati Control which got installed on my Gnome menu. The program was in the wrong directory, I simply found it and copied it to the correct directory.

The whole system now performs a whole lot better.

I can recommend using the ATI Installer Package builder and not trying to use the Debian fglrx-driver package.
I have suffer with Ati driver installation I want to try your way. Everything is okey. Good telling. But please tell us which is the right directory you coppied file into it at following statment

Quote:
Originally Posted by mikethefrog
There was a problem with the Ati Control which got installed on my Gnome menu. The program was in the wrong directory, I simply found it and copied it to the correct directory.
 
Old 04-22-2008, 02:17 AM   #8
avw
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Smile

Following mikethefrog steps I've successfully installed ATI Radeon HD2400 on my system (look at the title).
No problems with ATI menus (using KDE).
Thanks Miki
 
Old 04-23-2008, 04:48 PM   #9
noxious
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: LinuxMint Gloria, Ubuntu 9.10
Posts: 299

Rep: Reputation: 30
Use "module assistant". Works every time!
 
Old 09-19-2008, 05:02 AM   #10
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Arch
Posts: 118

Rep: Reputation: 16
Although mikethefrog's "walkthrough" is dated 04-05-06, I'm writing since the last post is quite contemporary.

I followed mikethefrog's method for his ATI Radeon X550 PCI Express card to install ATI proprietary driver for my ATI X300 series card. But couldn't get all that mikethefrog said.

First, running the ATI installer ati-driver-installer-8-8-x86.x86_64.run I got four .deb packages:
fglrx-driver_8.522-1_i386.deb
fglrx-driver-dev_8.522-1_i386.deb
fglrx-kernel-src_8.522-1_i386.deb
fglrx-amdcccle_8.522-1_i386.deb

No
Quote:
fglrx-control-qt3_8.24.8-1_i386.deb
fglrx-sources_8.24.8-1_i386.deb
I found that the fglrx-amdcccle contains a folder named "control" so, I thought this would do me the control-qt3-thing.

My machine had the fglrx-driver from Debian repo. I opted for using the ATI driver, I don't know if that was a right decision. What I did before starting with mikethefrog's guide is uninstalled the fglrx-driver.

Then I ran the installer to produce these four packages. Then came the dpkg part where it went fine with the driver.deb. But I got some errors with the other packages: it seems I already have an upgraded kernel source but don't know where.

However, when I try
Quote:
dpkg -i fglrx-amdcccle_8.522-1_i386.deb
it said the fglrx-driver needs to be configured first.
Can anyone tell how to do that, please?

BTW, mine is Debian Lenny, if that matters at all.

Last edited by TristanDee; 09-19-2008 at 08:20 AM. Reason: additional info
 
Old 09-19-2008, 04:36 PM   #11
TristanDee
Member
 
Registered: Nov 2007
Location: Dhaka, Bangladesh
Distribution: Arch
Posts: 118

Rep: Reputation: 16
OK, I got it done. That is, fglrx-amdcccle got installed. Also, I changed settings in my xorg.conf file as you've shown here.

And Compiz-Fusion is running!

A bit slow though. I guess I've got to get some RAM now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9600 Driver Install in Debian coolbreeze7000 Debian 2 05-08-2006 01:52 PM
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 01:10 PM
unable to install proprietary driver for ati radeon 9250 on debian sarge (newbie) n00bie1 Linux - Hardware 1 01-27-2006 05:03 PM
HELP!! Install ATI Mobility RADEON 9000 driver on Debian Kernel 2.4.18-bf2.4?? herbu Linux - Laptop and Netbook 3 11-21-2004 03:37 AM
ATI Linux Debian Driver Install Issue pjpeter Debian 6 09-27-2004 06:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration