LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Autologin doesn't work for sddm (plasma) (https://www.linuxquestions.org/questions/debian-26/autologin-doesnt-work-for-sddm-plasma-4175653910/)

cstacy 05-14-2019 08:10 PM

Autologin doesn't work for sddm (plasma)
 
On Debian 4,9, plasmaashell 5.8.6, sddm (0.14.0 I guess?)...

I used the System Settings | Startup and Shutdown GUI
to turn on Autologin for my username. This resulted in an
/etc/sddm.conf file that looks correct.

The new section is:

[Autologin]
Relogin=true
Session=plasma.desktop
User=cstacy

Rebooted.
It seems to have no effect whatsoever; I just get the
normal login offering (I am the only login user that
I set up on the machine). I have to type in my correct
password like always. No effect at all.

I have always used sddm and this is my default session.

Maybe there is something else I have to do?

Drakeo 05-14-2019 11:28 PM

still have to select a user to auto login. set it from the system settings.

cstacy 05-15-2019 10:44 AM

Quote:

Originally Posted by Drakeo (Post 5995133)
still have to select a user to auto login. set it from the system settings.


"System Settings" is what created the file I showed you;
it added those lines when I selected the user to autologin..
It still shows the user. This is under "Startup and Shutdown".
Is there another place it needs to be done also?


All times are GMT -5. The time now is 01:08 AM.