LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-21-2004, 10:14 AM   #1
jbasement
LQ Newbie
 
Registered: Feb 2004
Location: LaCrosse, WI USA
Distribution: Debian
Posts: 15

Rep: Reputation: 0
Question auto logout from KDE 3.2


I have a fresh install of bf2.4. I installed X, WindowMaker and KDE 3.2. I configured for a kdm start. If I log into KDE and then switch to tty2, 3, etc, it logs me out to kdm in about 30-45 seconds. If I don't log in and leave the kdm start window open I can use tty2? How can I change this?

Thanks,
Jason
 
Old 02-22-2004, 03:18 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,591

Rep: Reputation: 96
About the only thing I could see doing it is the Automatic login in the Convenience tab in the Login Manager it is under the System Administration in the Control Center you may want to check the settings.
 
Old 02-22-2004, 06:08 PM   #3
jbasement
LQ Newbie
 
Registered: Feb 2004
Location: LaCrosse, WI USA
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
I checked the Login Manager and cannot find any settings for this. I installed Debain onto another machine with KDE 3.2 and the same problems exist. I tried to disable kdm and reboot, no luck. The problem is with 3.2 I think.

Thanks for the help HappyTux!

Jason
 
Old 02-23-2004, 01:43 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,591

Rep: Reputation: 96
Quote:
Originally posted by jbasement
I checked the Login Manager and cannot find any settings for this. I installed Debain onto another machine with KDE 3.2 and the same problems exist. I tried to disable kdm and reboot, no luck. The problem is with 3.2 I think.

Thanks for the help HappyTux!

Jason
I'm running 3.2 here and just went to the console with kde running and watched top for a couple of minutes and did a few commands and never seen a problem. Where are you getting the packages from how did you install? Have you checked into your /etc/kde3/kdm/Xservers and made sure their are not two X servers being started maybe even another instance of kdm running?
 
Old 02-23-2004, 07:04 PM   #5
jbasement
LQ Newbie
 
Registered: Feb 2004
Location: LaCrosse, WI USA
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
The packages came from "http://ftp.rutgers.edu/pub/kde/stable/3.2/Debian stable main", this is what I added to my sources.list and installed the whole package with apt-get. I checked my /etc/kde3/kdm/Xservers file.

:0 local@tty1 /usr/X11R6/bin/X :0 -dpi 100 -nolisten tcp vt7
:1 local reserve /usr/X11R6/bin/X :1 -dpi 100 -nolisten tcp vt8
:2 local reserve /usr/X11R6/bin/X :2 -dpi 100 -nolisten tcp vt9
:3 local reserve /usr/X11R6/bin/X :3 -dpi 100 -nolisten tcp vt10

This is all that is listed, this is new to me? These are for more X-sessions, right? Should I comment out vt8, vt9 and vt10?

Thanks again HappyTux!

Jason
 
Old 02-24-2004, 01:22 AM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,591

Rep: Reputation: 96
That looks like it is an official mirror and those settings are correct they would only be used if you started a new server yourself, I think I am out of ideas on this one. You may want to keep looking in the files the kdm directory there has to be a setting wrong somewhere that is causing kdm to respawn. One more thing now that I am thinking again do you have an .Xresources or .Xsession, anything with an .x???? in your home directory that may be starting kde when you login that could be causing it if it gets re-read again on the new login.
 
Old 02-27-2004, 10:39 AM   #7
jbasement
LQ Newbie
 
Registered: Feb 2004
Location: LaCrosse, WI USA
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
I have been through all my x files and cannot find anything that is respawing kde or X. I have tried changing my inittab file, nothing works. I have a new question, where is the file that contains my default window manager? i.e. kdm, xdm? I disabled kdm with rcconf and it doesn't like that.

Thanks again,
Jason
 
Old 02-27-2004, 04:47 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,591

Rep: Reputation: 96
Debian uses the update-alternatives to change the display managers and all kinds of other settings, the settings themselves are kept in the /etc/alternatives directory if you want to look at what is available.
Code:
HappyTux:/home/stephen# update-alternatives --display x-session-manager
x-session-manager - status is auto.
 link currently points to /usr/bin/kde3
/usr/bin/kde3 - priority 40
Current `best' version is /usr/bin/kde3.
You would need to have xdm or gdm installed if you want to use one of them and you would use --config in the line above it would then allow you to change it.
 
Old 02-28-2004, 05:45 PM   #9
jbasement
LQ Newbie
 
Registered: Feb 2004
Location: LaCrosse, WI USA
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
unstable:~# update-alternatives --config x-session-manager

There is only 1 program which provides x-session-manager
(/usr/bin/kde3). Nothing to configure.

How do I change to xdm, gdm, console?

This is trying to configure kde3 from the symbolic link right?

Thanks,
Jason
 
Old 02-28-2004, 08:42 PM   #10
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,591

Rep: Reputation: 96
If you want nothing but a console login then apt-get remove kdm then you have no window manager running and you have to use startx from the console to start kde. If you want a choice then install either gdm or xdm and you should be asked during the setup if you wish to make either of them the default if not then update-alternatives to change the symbolic link.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto-Logout of X-Windows Abnoba12 Linux - Newbie 8 11-08-2006 10:01 AM
auto logout ziox Linux - General 1 11-21-2004 06:31 PM
auto-logout in Dropline Vindane Slackware 2 06-12-2004 05:48 PM
Auto Logout with Gnome 1.4?!? bassclarinet Debian 1 04-24-2004 09:22 PM
Auto logout in Xsession nightoil Linux - Newbie 3 12-09-2003 05:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration