LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-09-2009, 09:52 AM   #1
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/AntiX/Arco/Sparky/Hexagon
Posts: 5,239

Rep: Reputation: 362Reputation: 362Reputation: 362Reputation: 362
auto-dhcp in grml/debian-based?


Can't seem to figure out how grml is stopping the auto-dhcp during boot
by default in grml network is disabled
I tried init.d, inittab, or whatever
I cannot seem to find anything??

I need eth0 to come up automatically at boot
grml, for some reason won't remember my net setup and must re-setup at every boot??!

How can I make it do that?
thanks
 
Old 08-09-2009, 02:51 PM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
Hey Linus,how ya doing?
If grml is the same as Debian you need to look at /etc/network/interfaces
Here's a sample from mine,running ethernet with dhcp:

Code:
ade@Pc1:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
How does this compare to yours?.
Some people say to change allow-hotplug for auto,but i found this slowed my connection at boot up.So i now leave it as it is.
Have a look,let us know how you get on.

Completely off topic,check this internet radio site:

http://www.chronixradio.com/

I think you may like it......
 
Old 08-10-2009, 07:33 AM   #3
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/AntiX/Arco/Sparky/Hexagon
Posts: 5,239

Original Poster
Rep: Reputation: 362Reputation: 362Reputation: 362Reputation: 362
Well
here's /etc/network/interfaces

Code:
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp
I added allow-hotplug eth0
as you said
this stil didn't work and I have to still start the network manually via grml-network

BUT, I found this in /etc/network it's called "interfaces.example"

Code:
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# Also check out /usr/share/doc/ifupdown/examples/network-interfaces.gz

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

# Sample entries:
# ===============

# static entry:
# auto eth1
# iface eth1 inet static
#        address 192.168.0.1
#        netmask 255.255.255.0
#        network 192.168.0.0
#        broadcast 192.168.0.255
#        gateway 192.168.0.1
#        dns-search foo.example
#        dns-nameservers 192.168.0.10 192.168.0.20
#
# vconfig:
# auto eth0.1
# iface eth0.1 inet manual
#        pre-up vconfig add eth0.1
#        up ifconfig eth0 0.0.0.0 promisc up
#        post-down vconfig rem eth0.1

# Ad-hoc WLAN Network:
# auto eth1
# iface eth1 inet static
#        address 192.168.0.1
#        netmask 255.255.255.0
#        wireless_mode ad-hoc
#        wireless_essid foobar
#        wireless_channel 11

# WLAN:
# auto eth1
# iface eth1 inet dhcp
#        wireless_essid   foo
#        wireless_nick    bar
#        wireless_key     11111111111111111111111111
#        wireless_keymode restricted
#        wireless_keymode open
#        wireless_mode managed

# DSL Interface
# allow-hotplug dsl
# iface dsl inet manual
#   up ip link set $IFACE up
#   up ip -6 addr flush dev $IFACE || true
#   down ip link set $IFACE down

# Mapping - bring up via e.g. 'ifup eth0=dhcp':
# iface dhcp inet dhcp

# Mapping - bring up via e.g.  'ifup -v eth0=home':
# auto eth1
# iface home inet dhcp
#        wireless_essid   foo
#        wireless_nick    bar
#        wireless_key     11111111111111111111111111
#        wireless_keymode restricted

# More complex mapping-setup:
# auto eth0
# mapping eth0
#	script /etc/network/ping-places.sh
#	map 192.168.0.90/24 192.168.0.42 home
#	map 129.27.140.238/24 129.27.140.241 spsc
#	map 192.168.0.90/24 192.168.0.100 sevian7
#	map 192.168.0.90/24 192.168.0.1 work
#	map 195.177.251.50/255.255.255.224 195.177.251.33 office
#
# iface home inet static
#	address 192.168.0.90
#	netmask 255.255.255.0
#	gateway 192.168.0.42
#	mtu 1400
#
#	up cp /etc/apt/sources.list.home /etc/apt/sources.list
#	up cp /etc/resolv.conf.home /etc/resolv.conf
#
# iface spsc inet static
#	address 129.27.140.238
#	netmask 255.255.255.0
#	gateway 129.27.140.1
#
#	up cp /etc/apt/sources.list.spsc /etc/apt/sources.list
#	up cp /etc/resolv.conf.spsc /etc/resolv.conf
#
# iface work inet static
#	address 192.168.0.90
#	netmask 255.255.255.0
#	gateway 192.168.0.1
#
#	up cp /etc/resolv.conf.work /etc/resolv.conf
#
# iface dhcp inet dhcp
#
# iface office inet dhcp
#	up cp /etc/apt/sources.list.office /etc/apt/sources.list
#
# iface realraum inet static
#      wireless_essid graz.funkfeuer.at
#      wireless_ap 08:CA:FF:EE:BA:BE
#      wireless-mode Ad-Hoc
#      address 10.13.0.13
#      netmask 255.255.255.224
#      gateway 10.13.0.1
#      dns-nameservers 83.64.208.23
#
## Madwifi - http://madwifi.org/wiki/UserDocs/Distro/Debian/ConfiguringtheMadWifidevice
# iface ath0 inet static
#      pre-up wlanconfig ath0 create wlandev wifi0 wlanmode ap
#      post-down wlanconfig ath0 destroy
#      wireless-essid my-essid
#
# iface home inet dhcp
#      wireless-mode Managed
#      wireless-essid secret
#      wpa-ssid secret
#      wpa-psk secret
#
# iface wpa inet dhcp
#      wpa-conf /etc/wpa_supplicant.conf
#
# iface nat inet static
#      address 10.23.42.1
#      netmask 255.255.255.0
#      up iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
#      up echo "1" > /proc/sys/net/ipv4/ip_forward
#
# iface oldwpa inet dhcp
#      wireless-mode Managed
#      wireless-essid mikaasus
#      pre-up wpa_supplicant -Dwext -iipw -c/etc/wpa_supplicant.conf -B
#      down killall wpa_supplicant
#
# EOF
So, which of those should I uncomment for auto-eth0?
this one
Code:
# iface dhcp inet dhcp
or this one
Code:
# Mapping - bring up via e.g. 'ifup eth0=dhcp':
# iface dhcp inet dhcp
or this one?
Code:
# More complex mapping-setup:
# auto eth0
# mapping eth0
#	script /etc/network/ping-places.sh
#	map 192.168.0.90/24 192.168.0.42 home
#	map 129.27.140.238/24 129.27.140.241 spsc
#	map 192.168.0.90/24 192.168.0.100 sevian7
#	map 192.168.0.90/24 192.168.0.1 work
#	map 195.177.251.50/255.255.255.224 195.177.251.33 office
I just want simple dhcp auto connect at boot
thanks for your help!@
 
Old 08-10-2009, 08:20 AM   #4
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
Code:
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp
You've got double entry's for eth0!.

Try it like mine:

Code:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
If that doesn't work,try changing allow-hotplug for auto
 
Old 08-10-2009, 08:53 AM   #5
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/AntiX/Arco/Sparky/Hexagon
Posts: 5,239

Original Poster
Rep: Reputation: 362Reputation: 362Reputation: 362Reputation: 362
Unfortunetly, there seems to be a script that runs at startup which somehow rewrites the "interfaces" file
even running persistent, if I change the file as root, it still reverts back to only loopback, and nno auto-eth0

I will now unsquashfs the grml.squashfs and edit stuff and mksquashfs that B#@$%!
LOL
 
Old 08-10-2009, 10:08 AM   #6
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/AntiX/Arco/Sparky/Hexagon
Posts: 5,239

Original Poster
Rep: Reputation: 362Reputation: 362Reputation: 362Reputation: 362
LOL
this ones gonna be fun

OK, so I attempted to unsquashfs the grml-medium.squashfs
@$%^%...dink

"no SQUASHFS superblock on grml-medium.squashfs"

what?
google is your friend

http://www.splitbrain.org/blog/2009-...b_without_a_cd

anyway, it says you need "unsquashfs-lzma", which I found out is
included in slax-6.1.2 /tools folder

so, I was in pmagic, so I downloaded unsquashfs-lzma and unsquashed it

Now, I changed the /etc/network/interfaces to what Trooper told me above
I then booted off USB(persistent) and edited bootline "nopersistent"
to get a fresh boot

OK, that worked great!

PROBLEM
I then rebooted "persistent" with my saved /etc/stuff and guess what?
No DHCP!

LOL
I'll edit that and see what's up
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
screenshot app for debian/grml? linus72 Debian 7 08-08-2009 10:50 AM
What about Grml distro frenchn00b Linux - Distributions 1 01-14-2008 03:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration