LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   asus_atk0110 problem, sensors, acpi_enforce_resources=lax (https://www.linuxquestions.org/questions/debian-26/asus_atk0110-problem-sensors-acpi_enforce_resources%3Dlax-907905/)

qrange 10-13-2011 03:27 AM

asus_atk0110 problem, sensors, acpi_enforce_resources=lax
 
I have added 'acpi_enforce_resources=lax' to grub kernel parameters in order to change fan RPM.
(using Asus P5LD2)
the 'sensors' command does indeed give more information now (but some are wrong). also, Debian seems to boot a bit faster (not sure).

but on boot, I get this message:
Code:

Oct 13 09:53:00 debian kernel: [    4.259296] asus_atk0110: Resources not safely usable due to acpi_enforce_resources kernel parameter
however lsmod does not list 'asus_atk0110'.

Should I disable asus_atk0110? if so, how?

thanks.

Willrandship 10-15-2011 04:17 PM

Well, it wouldn't show up in lsmod if it decides not to load the module when you boot. It's already disabling it for you, and telling you why during your boot cycle. By the way, if you didn't know a quick google tells me it's your fan speed control that's not loading there, so it's safe to ignore the message if your computer isn't having any temp problems. Are you trying to reduce fan speed or increase it?

Try modprobe asus_atk0110 and see if it gives the same error again. If it doesn't say anything, then it's just the module being a little wacko and thinking it can't load when it really can. If it shows that error you posted, then your kernel parameter is making it so you can't load that module, which may be the desired effect anyways.

In short: If it's doing what you want it to, you can pretty much leave it alone. The module is already disabled, so no worries there.

Edit: Oh, and the reason some of your sensors are wrong now are because that module isn't loading, if it bothers you.

qrange 10-16-2011 06:45 AM

I see, thanks.
forgot to mention one important thing. I had run a command 'sensors-detect' that told me what modules to add for my hardware.
if I understood right, those modules are doing the same thing as asus_atk0110.

there have been more sensor information after the modification. (but also that error message)

I'm trying to slow down a bit very noisy CPU fan. 'downclocking' the CPU would also be desirable to reduce the extra heat. but it seems not possible for this Intel CPU (Celeron 420)

Willrandship 10-17-2011 12:33 PM

Have you tried blowing into the vent holes? Seriously, in laptops that have been around for a while, that alone can help a lot on heat issues, which is what you're really dealing with.

For slwing down the CPU, try looking for options in your BIOS configuration tool. That's something generally dealt with at a lower level than Linux, unless the BIOS provides access to the OS.


All times are GMT -5. The time now is 06:17 PM.