-   Debian (
-   -   Aptitude UI corruption & misc. random weird things (

krnlg 01-04-2008 10:01 AM

Aptitude UI corruption & misc. random weird things
Hi. This is a bit strange, and I can't work out whats wrong (version info first):

orangery:/home/josh# aptitude --version
aptitude 0.4.4 compiled at Mar 14 2007 14:38:57
Compiler: g++ 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

NCurses version: 5.5
libsigc++ version: 2.0.17

Running Debian Etch, up-to-date, not a very long or populated sources.list - almost entirely Etch.

Generally when i run aptitude it works fine, but sometimes the interface is displayed in a messed-up way with random characters sprinkled around the screen. It does this both from the console and from an xterm or gnome-terminal.

All I can think of is some kind of either ncurses or locale issue - I say locale because I just ran it now and it managed to do this: (no interface display)


josh@orangery:~$ su
orangery:/home/josh# aptitude
orangery:/home/josh# aptitude䠠䠠䠠

If you cant see the text under the first "aptitude" command its because it is in chinese characters - I have chinese fonts installed and a chinese locale is available but is NOT the default.
After this happened everything was messed up in the terminal so that pressing Up to re-run aptitude displayed chinese characters instead of "aptitude" as the command, but aptitude still ran when I pressed enter (with a corrupted UI display but no instant-quit like I got the first time). Typing "reset" fixed it, and pressing Up then gave the proper "aptitude" as you can see.

This happened from a freshly opened gnome-terminal. I suspect that the chinese characters are actually a segmentation fault error (it is not actual chinese as far as I can see, but might be using chinese characters to display the normal english error - wrong encoding somehow?). Earlier I got a segmentation fault when I ran aptitude but it didn't mess up the terminal like this. Thing is, I then opened a new terminal, ran it as before, and it worked perfectly.

I very much doubt its a hardware issue because everything else seems alright and aptitude VERY OFTEN does weird things like this while nothing else does.
It also seems a bit unlikely that aptitude itself is corrupt somehow given that sometimes it works without any problems at all.

Any of you clever people have any ideas?

Dutch Master 01-05-2008 07:19 PM

I recognize your problem as it happens to me too occasionally. Although, as I don't have Asian fonts installed, it uses Unicode instead. Usually restarting aptitude solves the problem, but the underlying cause remains unsolved. No idea what makes this happen and how to resolve it.

krnlg 01-06-2008 05:47 AM

I found a Debian bug report that seems to cover this - no solution as of yet:

All times are GMT -5. The time now is 01:25 PM.