LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-16-2011, 08:19 AM   #1
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 222

Rep: Reputation: 46
Aptitude reporting 30000+ dependencies


I've installed Debian6 Testing KDE4 using a net-inst CD when it is recently released.

Today , I did a aptitude clean && aptitude update && aptitude upgrade and got a weird output

Quote:
aptitude clean && aptitude update
...
...
Current status: 62 updates [+61], 1561 new [+270].
There are 7 newly obsolete packages: librasqal2, libwpd8c2a, libwpg-0.1-1, libwps-0.1-1, openoffice.org-base-core, openoffice.org-core, openoffice.org-report-builder-bin



aptitude upgrade
Resolving dependencies...
open: 42543; closed: 32760; defer: 49; conflict: 8

the open/closed figures is still running (higher) after 10 minutes.

Believe I am not the only one using Debian Testing with KDE4.
Anyone can confirm what is happening?

Last edited by michalng; 03-16-2011 at 08:26 AM.
 
Old 03-16-2011, 08:45 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
That's not normal. Ctrl+C that. Try another "aptitude update" then "aptitude upgrade" to see if the problem is already resolved. Alternately try "apt-get upgrade" to see if apt-get can resolve the dependencies any better.
 
Old 03-16-2011, 08:57 AM   #3
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 222

Original Poster
Rep: Reputation: 46
Tried multiple aptitude update, reboot, change repositories/source.list, disable non-debian repository (e.g. google)

Still the same.

Probably will try apt-get when I am back.

If there are no clear reason, I may have to reformat the installation (hope not),
doesn't feel good about something unknown like this.

Last edited by michalng; 03-16-2011 at 05:01 PM.
 
Old 03-16-2011, 09:10 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Why would you reformat!?

It's most likely a problem with the lists on the Debian mirrors. I'd wait a few days to see if it resolves itself. Alternately, try filing a bug report or searching recent bugs or other Debian forums for people with similar problems recently.

Anecdotally, I'm running a Testing desktop system (w/XFCE) and successfully aptitude update'd & upgrade'd last night.
 
Old 03-16-2011, 10:51 AM   #5
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
No problems updating Testing here either.
What is in your sources.list currently?.

Last edited by the trooper; 03-16-2011 at 11:53 AM.
 
Old 03-16-2011, 05:00 PM   #6
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 222

Original Poster
Rep: Reputation: 46
Thanks for responding,

aptitude upgrade still gives the same problem.

however, apt-get upgrade somehow works normally.
will do a apt-get and see what happens.
 
Old 03-16-2011, 05:26 PM   #7
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 222

Original Poster
Rep: Reputation: 46
Seems like aptitude is having problem

To solve, I did the following

apt-get purge aptitude # only aptitude is removed
apt-get install aptitude # but this brings in many other packages

everything goes back to normal

Last edited by michalng; 03-16-2011 at 05:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
aptitude-gtk: Gui for aptitude Rasmus Linux - Software 1 12-19-2008 08:53 AM
Using Aptitude SBN Ubuntu 2 10-16-2007 05:18 PM
copying 30000 files supersucker Linux - Newbie 1 05-02-2005 12:26 PM
aptitude Metallic Debian 6 04-14-2005 04:47 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration