-   Debian (
-   -   aptitude and source list problems (

Draylath 03-29-2010 12:35 PM

aptitude and source list problems

I have just started out with debian and I'm having a few problems.

I installed my amd64 lenny using a network instalation cd. As I expected it didn't have a lot on there when installed so I started to try and get kde using aptitude. During the instal I was prompted to use the ftp from debian in the uk as my repository source.

The problem is that when I try to download, update or do anything in aptitude there is no network activity and the thing eventually times out. I have pinged websites and I get no problems there so I think it might be something to do with the package lists or something. I'm not very experienced at using command lines so I'm finding it all abit daunting, so any help would be appreiceated.

EDIT: in case it is relevent I am conecting to the internet using a netgear router through usb. I tried using aptitude with it conected to ether net as well but both didn't work


pljvaldez 03-29-2010 01:15 PM

If you can ping stuff, you should try using an http repository. Can you post your /etc/apt/sources.list file?

Draylath 03-29-2010 01:28 PM

I have to browse on a different pc so this might have typos in it but this is what I have from the initial instalation: (I missed the stuff with the CD out):

deb lenny main
deb-src lenny main

deb lenny/updates main
deb-src /lenny/updates main

#Line commented out by installer because it failed to initialse
#deb lenny/volatile main
#Line commented out by installer because it failed to initialse
deb-src lenny/volatile main

pljvaldez 03-29-2010 01:49 PM

Make sure you comment out the CD if it's still listed. I'd probably comment out volatile for now also.

You might want to try a different mirror for now. Here's a list of all the available mirrors.

Don't forget to run as root or sudo. Run sudo aptitude update and post the response.

Draylath 03-29-2010 02:22 PM


the volatile stuff was already commented out by the instaler so I left that alone.

I tried the last thing first (sudo aptitude update)

I get :

Connecting to ( the nothing happens for ages, no activity on the router light then a message about timing out.

I also think I need some help on how to add the repository entries in the sources.list file. Everything I try makes aptitude say that it is a malformed line and it can't read it

Thankyou for your time on this

pljvaldez 03-29-2010 03:11 PM

clearly there is a routing problem because should be

What happens when you ping google from the linux box?

Draylath 03-29-2010 03:14 PM

100% packages recived 0% lost, about 42ms delay
64 bytes from (

pljvaldez 03-29-2010 03:16 PM

Try pinging

Also, can you post the contents of /etc/resolv.conf?

Draylath 03-29-2010 03:22 PM

The ping was again succesfull 32ms average time

file etc/resolv.conf as follows:


Ah! now that is the ip number for my router. I have a feeling it should be something else but not sure what

Draylath 03-29-2010 03:29 PM

Fixed it,

Bloody thing just neede a proper DNS server to call its own. As soon as I put that in started gobbling up files from the repositories.

Many thanks for your help

pljvaldez 03-29-2010 03:31 PM

Correct, the /etc/resolv.conf file is basically your local DNS address book. The nameserver entry points your local machine to your local router. So if you can ping it, it's weird that aptitude is looking for which is a broken route.

Edit: Glad you got it working. I always like having a real nameserver in there just in case.

All times are GMT -5. The time now is 03:28 PM.