-   Debian (
-   -   apt-get unable to find packages (

dhoro 12-27-2004 10:32 AM

apt-get unable to find packages
Hi folks!

I'm really, really new to debian, so the first thing I've tried to do was to install some packages. It seems I've ran into a little problem with apt-get: I'm trying to install qmail. I can find the package using the package search, but apt-get keeps telling me it can't find the package. Here's what I've tried so far:


apt-get source qmail
apt-get source qmail-src
apt-get install qmail
apt-get install qmail-src

None of these work and apt-get fails with an "unable to find package" error. Why could this happen? Should I setup some additional sources in /ect/apt/sources.list? Right now, this file contains:


#deb *cdrom/ sarge main

deb ** testing main
deb-src ** testing main

deb ** testing/updates main

Note: It seems I cannot post an url so in the contents of the sources.list file, I've replaced the file protocol with a '*' and the http protocol with '**'.

I know the apt-get works for other packages because I've successfully installed tcpdump and I've simulated installation for apache and php.


SlackerLX 12-27-2004 10:34 AM

be sure before typing"apt-get install" make

apt-get update

dhoro 12-27-2004 10:58 AM

Nope, that wasn't it :(.

But thanks for the quick reply!

sls 12-27-2004 01:52 PM


qmail seems to be in non-free

You need to add the following deb-src ** testing main non-free contrib

Then you should be able to do apt-get update and then install it.

Hope that helps


SlackerLX 12-28-2004 09:40 AM

Just check it and I think SLS is right. qmail is commercial:mad:

All times are GMT -5. The time now is 09:17 AM.