LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-01-2005, 02:23 PM   #1
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 729

Rep: Reputation: 32
Apt-get problem


I have problems with apt-get here is what happens, any ideas ?

Code:
apt-get install lingoteach || apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Note, selecting lingoteach-ui instead of lingoteach
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  lingoteach-ui: Depends: liblingoteach4 but it is not going to be installed
  udev: Depends: initscripts (>= 2.85-16) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  initscripts
The following NEW packages will be installed:
  initscripts
0 upgraded, 1 newly installed, 0 to remove and 132 not upgraded.
191 not fully installed or removed.
Need to get 0B/30.5kB of archives.
After unpacking 246kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 129255 files and directories currently installed.)
Unpacking initscripts (from .../initscripts_2.86.ds1-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/initscripts_2.86.ds1-1_i386.deb (--unpack):
 trying to overwrite `/etc/init.d/checkroot.sh', which is also in package sysvinit
Errors were encountered while processing:
 /var/cache/apt/archives/initscripts_2.86.ds1-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 07-01-2005, 02:56 PM   #2
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 47
Quote:
any ideas?
Yes.

hth --Jonas
 
Old 07-01-2005, 02:59 PM   #3
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 47
By the way, I have something helpful for you:
google.search("smart questions", lucky=True)

It links to `Smart Bug Reports' and `yes-or-no-questions'. Read all three.

I sincerely hope *this* helps

--Jonas
 
Old 07-01-2005, 03:23 PM   #4
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 729

Original Poster
Rep: Reputation: 32
Apologies

Sorry for posting with too little details.

I have Knoppix 3.9 installed on my PC.
It was working fine and I have not changed anything to do with apt-get or anything else apart from time.

However I can not use apt-get at all. I get

Code:
The following packages have unmet dependencies:
  lingoteach-ui: Depends: liblingoteach4 but it is not going to be installed
  udev: Depends: initscripts (>= 2.85-16) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
If I try this I get
Code:
apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  initscripts
The following NEW packages will be installed:
  initscripts
0 upgraded, 1 newly installed, 0 to remove and 132 not upgraded.
191 not fully installed or removed.
Need to get 0B/30.5kB of archives.
After unpacking 246kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 129255 files and directories currently installed.)
Unpacking initscripts (from .../initscripts_2.86.ds1-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/initscripts_2.86.ds1-1_i386.deb (--unpack):
 trying to overwrite `/etc/init.d/checkroot.sh', which is also in package sysvinit
Errors were encountered while processing:
 /var/cache/apt/archives/initscripts_2.86.ds1-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Has anyone ever seen this before ? More importantly how do I fix it. I have searched on the internet but without success.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with apt efi360 Debian 18 12-24-2005 06:12 PM
apt problem filwhua SUSE / openSUSE 3 04-23-2005 08:22 AM
problem with apt-get himanshuabc Debian 1 10-21-2004 05:46 PM
Problem with apt-get scng Linux - General 2 09-16-2004 02:39 PM
rh9 xd2 apt apt-get problem fix and solution transeunt Red Hat 0 12-16-2003 10:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration