LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-23-2004, 02:40 PM   #1
h2gofast
Member
 
Registered: Dec 2002
Distribution: Debian
Posts: 154

Rep: Reputation: 30
apt-get is stuck


apt-get is stuck until I resolve this.
Any help is appreciated.

[CODE] Preconfiguring packages ...
(Reading database ... 106664 files and directories currently installed.)
Preparing to replace vim-gtk 6.1.048-1 (using .../vim-gtk_1%3a6.2-353+1_i386.deb) ...
dpkg (subprocess): unable to execute old pre-removal script: Exec format error
dpkg: warning - old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg: error processing /var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb (--unpack):
there is no script in the new version of the package - giving up
dpkg (subprocess): unable to execute post-installation script: Exec format error
dpkg: error while cleaning up:
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[CODE]
 
Old 03-23-2004, 04:28 PM   #2
bassclarinet
LQ Newbie
 
Registered: Jul 2003
Posts: 14

Rep: Reputation: 0
I dont know, but that package name looks like it may be corrupted. Have you tried deleting the package, running "apt-get update" the running "apt-get -f install" ?

Good luck.
 
Old 03-23-2004, 07:22 PM   #3
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 32
I'm in the same hell right now---It gives the same message no matter what options you choose in apt-get.

I've tried:

apt-get remove vim
apt-get remove vim-gtk
apt-get -f install

then

apt-get clean
apt-get auto-clean
apt-get update

Then repeat above.

(then tried dozens of apt-get this apt-get that)


The funny thing is that vim is on the box---I had to use it to change the source list. Very frustrating.



Last edited by flashingcurser; 03-23-2004 at 07:23 PM.
 
Old 03-23-2004, 08:42 PM   #4
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 52
*make a backup of your sources.list file and do
echo>/etc/apt/sources.list

*run apt-setup and choose other mirrors than the one you were using

*update your sources
apt-get update

*delete downloaded packages
apt-get clean

*try installing again
apt-get install vim-gtk
 
Old 03-24-2004, 10:20 AM   #5
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 32
mrcheeks--nope


Any one else?
 
Old 03-24-2004, 01:43 PM   #6
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 32
flashingcurser, what release are you using? (Woody, Sarge, Sid)

----
bassclarinet wrote:
Have you tried deleting the package,

Do you mean go into /var/cache/apt/archives and delete a file?
 
Old 03-24-2004, 07:59 PM   #7
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 32
Yes, I was going for bleeding edge--sid (woody was already installed)

Yes I tried:
apt-get remove (kde, vim-gtk, vim, etc....)

and

rm /var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb

no go--oh well---maybe debian is not for me
 
Old 03-24-2004, 09:04 PM   #8
Pr1musr3x
Member
 
Registered: Feb 2004
Location: /dev/null
Distribution: Debian Sid, Mepis, Slackware 9.1
Posts: 41

Rep: Reputation: 15
Quote:
Originally posted by flashingcurser
Yes, I was going for bleeding edge--sid (woody was already installed)

Yes I tried:
apt-get remove (kde, vim-gtk, vim, etc....)

and

rm /var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb

no go--oh well---maybe debian is not for me
Hmmm flashingcurser, what about this?

rm -rf /var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb

and then do an updatedb...see what happens...
 
Old 03-24-2004, 10:13 PM   #9
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 32
I went ahead and reinstalled, I'll stick with stable untill I rebuild a new kernel.

(though I'm not sure what force/recursive would have done--rm removed the file)


Thanks guys


 
Old 03-25-2004, 12:34 AM   #10
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 32
> (though I'm not sure what force/recursive would have done--rm removed the file)

But, you'd previously written:

Yes I tried:
apt-get remove (kde, vim-gtk, vim, etc....)

and

rm /var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb

no go


implying that the rm command may have failed. That's why Pr1musr3x suggested using the -rf flags. Though, since you're only deleting one file (and not a directory of them) the -r doesn't do anything.

Also, dunno why Pr1musr3x recommended the updatedb command -- that's only for updating your database that 'locate' uses. I don't think it has anything to do with apt-get,.. unless apt-get uses the locate command behind the scenes... :) Dunno.

Regarding sticking with 'stable'. Since Sid can give you some trouble once in a while, why not try "Testing"?
 
Old 03-25-2004, 01:38 AM   #11
titetanium
Member
 
Registered: Mar 2004
Distribution: debian testing/unstable, devuan, raspberrypi OS
Posts: 68

Rep: Reputation: 16
Hi,

If you get stuck on Apt-get installs, then you should try dpkg -purge brokenpackage and then run apt-get update afterwards. That should help you get unstuck.
 
Old 03-25-2004, 01:55 AM   #12
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 32
Thanks I'll try that with my current problem.


 
Old 03-25-2004, 02:07 AM   #13
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 32
Sorry man:

root@duron800:/home/dan# dpkg -purge brokenpackage
dpkg: unknown option -u

Type dpkg --help for help about installing and deinstalling packages[*];
Use dselect for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;
Type dpkg --licence for copyright licence and lack of warranty (GNU GPL)[*].

Options marked[*] produce a lot of output - pipe it through `less' or `more' !



Did you mean somethinig else?

If so please post.


Thanks
 
Old 03-25-2004, 07:54 AM   #14
Pr1musr3x
Member
 
Registered: Feb 2004
Location: /dev/null
Distribution: Debian Sid, Mepis, Slackware 9.1
Posts: 41

Rep: Reputation: 15
Quote:
Originally posted by johnMG
> (though I'm not sure what force/recursive would have done--rm removed the file)

But, you'd previously written:

Yes I tried:
apt-get remove (kde, vim-gtk, vim, etc....)

and

rm /var/cache/apt/archives/vim-gtk_1%3a6.2-353+1_i386.deb

no go


implying that the rm command may have failed. That's why Pr1musr3x suggested using the -rf flags. Though, since you're only deleting one file (and not a directory of them) the -r doesn't do anything.

Also, dunno why Pr1musr3x recommended the updatedb command -- that's only for updating your database that 'locate' uses. I don't think it has anything to do with apt-get,.. unless apt-get uses the locate command behind the scenes... Dunno.

Regarding sticking with 'stable'. Since Sid can give you some trouble once in a while, why not try "Testing"?
Oops! guess thta's the trouble with trying to do too many things at one go i.e. replying to threads at 2 forums and performing some housekeeping on the system ... leave the updatedb bit out...
 
Old 03-29-2004, 03:20 PM   #15
h2gofast
Member
 
Registered: Dec 2002
Distribution: Debian
Posts: 154

Original Poster
Rep: Reputation: 30
I tried a number of things using apt-get and dpkg,
finally I used a brute force method.
I located all files associated with vim-gtk, all the pre, post install removal scripts, docs, everything with vim-gtk in the name. And I deleted them.
then apt-get remove vim-gtk. It worked, and I was able use apt-get again.

I don't recomnend this method btw. Use at your own risk.,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get stuck at 0% sh4d0w13 Debian 1 07-31-2005 04:10 PM
apt-get update errors since Debian released ( bad /etc/apt/sources.list ?) forgox Debian 10 06-13-2005 01:28 PM
apt-get is stuck on 'scrollkeeper' package jon_k Debian 2 04-03-2005 07:51 PM
apt-get stuck in a rut irvken Debian 3 11-03-2004 12:55 PM
knoppix 3.4 and no apt-setup how to fix info install apt-file + base-config maximalred Debian 0 10-16-2004 07:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration