-   Debian (
-   -   apt-get install not working / apt-get update is ok (

remy215 10-01-2005 06:31 PM

apt-get install not working / apt-get update is ok
I am quite new to linux - i am on a debian (sarge) and i have recently upgraded my linux kernel to

i am trying to install some softwares through apt and i do not understand what's hapening.
Here is the situation:

i've some .debs file in /deb-packages/debs/
I ran:
- apt-ftparchive packages => I have a Packages.gz file in /deb_packages/debs/
- apt-ftparchive release => I have a Release file in /deb_packages/debs/
- modified /etc/apt/sources.list and added 'deb file:/deb_packages/ debs/'
(I disabled other entries to be sure to install the deb file I put in my /deb_packages/debs/ folder -- I created this .deb using alien and the latest rpm version of gaim I found)
- apt-get update => everything is ok
remy@rdesktop:~$ sudo apt-get update
Reading Package Lists... Done
- apt-cache policy gaim
remy@rdesktop:~$ apt-cache policy gaim
Installed: (none)
Candidate: 1.5.0-1
Version Table:
1.5.0-1 0
500 file: debs/ Packages
- apt-get check
remy@rdesktop:~$ sudo apt-get check
Reading Package Lists... Done
Building Dependency Tree... Done

when I try to install it I have an error:
remy@rdesktop:~$ sudo apt-get install gaim
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/4174kB of archives.
After unpacking 12.3MB of additional disk space will be used.
Err file: debs/ gaim 1.5.0-1
File not found
Failed to fetch file:/deb_packages//deb_packages/debs/gaim_1.5.0-1_i386.deb File not found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I don't know why it tries to find my .deb file in /deb_packages//deb_packages/debs/ and not simpy in /deb_packages/debs/ as stated in /etc/apt/sources.list

Here is the content of my Packages.gz file:
Package: gaim
Priority: extra
Section: alien
Installed-Size: 11972
Maintainer: remy <remy@localhost.localdomain>
Architecture: i386
Version: 1.5.0-1
Depends: libaspell15 (>= 0.60), libatk1.0-0 (>= 1.7.2), libaudiofile0 (>= 0.2.3-4), libc6 (>= 2.3.2.ds1-21), libglib2.0-0 (>= 2.6.0), libgtk2.0-0 (>= 2.6.0), libice6 | xlibs (>> 4.1.0), libpango1.0-0 (>= 1.8.1), libsm6 | xlibs (>> 4.1.0), libx11-6 | xlibs (>> 4.1.0), libxext6 | xlibs (>> 4.1.0)
Filename: /deb_packages/debs/gaim_1.5.0-1_i386.deb
Size: 4173908
MD5sum: ef80fa3686d22b28c5dc950e9e4c47d3
Description: A Gtk+ based multiprotocol instant messaging client
Gaim allows you to talk to anyone using a variety of messaging
protocols, including AIM, ICQ, IRC, Yahoo!, Novell Groupwise,
MSN Messenger, Jabber, Gadu-Gadu, Napster, and Zephyr. These
protocols are implemented using a modular, easy to use design.
To use a protocol, just add an account using the account editor.
Gaim supports many common features of other clients, as well as many
unique features, such as perl scripting, TCL scripting and C plugins.
Gaim is NOT affiliated with or endorsed by America Online, Inc.,
Microsoft Corporation, Yahoo! Inc., or ICQ Inc.
(Converted from a rpm package by alien version 8.52.)

Does anybody have the same problem? or better, a solution?

I've tried using Synaptic, but the result is exactly the same.
This is really annoying, if anybody could help me it would be kind.

Thanks and regards,
-- sorry for being a linux bully

HappyTux 10-01-2005 06:43 PM



deb file:/deb_packages/debs ./
For the line in the sources.list.

remy215 10-01-2005 07:02 PM

Thanks for your help Stephen
Your solution did not work but was of great help! :)

by doing what you said, my error message became:

Failed to fetch file:/deb_packages/debs//deb_packages/debs/gaim_1.5.0-1_i386.deb File not found
Therefore I tried some changes and finally it worked with:

deb file:// /deb_packages/debs/
Thanks a lot! :rolleyes: :)

All times are GMT -5. The time now is 01:35 AM.