LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-13-2007, 12:14 PM   #1
Slick666
Member
 
Registered: Feb 2006
Distribution: Ubuntu 8.04; Debian Etch
Posts: 167

Rep: Reputation: 33
apt-get install error, E: Broken packages


Hello Debian users,

I'm sure something similar to this has been covered but I can't seem to find it in the forum search.

I'm a recent Debian user but I am not a noob to Linux. I am a noob however when it comes to using apt get. I've recently tried to install sendmail but I'm getting an error on some of the dependencies.

Code:
apt-get install sendmail
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  sendmail: Depends: sendmail-bin (= 8.13.8-3) but it is not going to be installed
            Depends: rmail (= 8.13.8-3) but it is not going to be installed
E: Broken packages
From what I can tell it appears that sendmail-bin and rmail are not up to date on this repository.

Is this an error on my part or the repository's part?

Any help or links appreciated.
 
Old 07-13-2007, 12:53 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 62
Quote:
Originally Posted by Slick666
Hello Debian users,

I'm sure something similar to this has been covered but I can't seem to find it in the forum search.

I'm a recent Debian user but I am not a noob to Linux. I am a noob however when it comes to using apt get. I've recently tried to install sendmail but I'm getting an error on some of the dependencies.

Code:
apt-get install sendmail
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  sendmail: Depends: sendmail-bin (= 8.13.8-3) but it is not going to be installed
            Depends: rmail (= 8.13.8-3) but it is not going to be installed
E: Broken packages
From what I can tell it appears that sendmail-bin and rmail are not up to date on this repository.

Is this an error on my part or the repository's part?

Any help or links appreciated.
Your infomation on the side says you are running Etch but that sendmail-bin package is from Lenny/testing. Are you running some kind of mixed system with Etch as base with other sources in your /etc/apt/sources.list and can we see this file?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Continuing to upgrade and install new packages with broken dependencies in the system nautilus Debian 3 06-13-2007 06:59 AM
Unmet Dependancies/Broken Packages - Can't apt-get Build-Install??? Xenoman1 Ubuntu 3 08-07-2006 03:38 AM
apt broken? error with libexif-gtk5 bigtpumped Debian 1 09-18-2005 09:00 AM
apt-get + broken packages = death ulaoulao Linux - Software 2 09-19-2004 09:55 AM
need help again (kde broken after apt-get install) rafc Debian 5 06-09-2004 02:06 PM


All times are GMT -5. The time now is 07:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration