-   Debian (
-   -   apt-get gets stuck at vim-common (

PBSchmidt 01-08-2008 04:26 AM

apt-get gets stuck at vim-common
Hello folks,

after using my sarge home server long and happily, I now have an issue (for some weeks): every time I try to apt-get anything, I have the following error message:


# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  vim: Depends: vim-common (>= 1:6.3-071+1sarge3) but it is not installed
E: Unmet dependencies. Try using -f.

well then I used -f, for the system told me (and up to now, that always helped):


#apt-get -f install
Unpacking vim-common (from .../vim-common_1%3a6.3-071+1sarge3_all.deb) ...
dpkg: error processing /var/cache/apt/archives/vim-common_1%3a6.3-071+1sarge3_all.deb (--unpack):
 trying to overwrite `/usr/share/doc/vim-common', which is also in package vim-doc
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Umh :confused:. I am quite puzzled. No clue on the net :study:, neither. Today, I apt-get removed vim vim-full vim-common, but no change. Are my packages fouled up? apt database is always kept fresh and up to date ... Oh, by the way, vim works on the box :scratch: - although it is not properly installed?!?

Anyone who has a clue? Your help is much appreciated!

Kind Regards,


jens 01-08-2008 06:23 AM

If I remember correctly, the vim package was horribly broken in old-stable(aka sarge).

I would first try removing vim-doc, upgrade everything and reinstall(apt-get) it (if needed, it's just documentation).

If it keeps giving you this conflict you could consider a more brutal fix (at your own risk) by forcing it to install:

dpkg -i --force-all /var/cache/apt/archives/vim-common_1%3a6.3-071+1sarge3_all.deb
Using "force" on a productive server is usually a bad idea though...

PBSchmidt 01-08-2008 09:02 AM

Hello jens,

thanks for the quick reply

I would first try removing vim-doc, upgrade everything and reinstall(apt-get) it
actually, that is almost what I did. I even moved the files manually - no effect :cry: .

Anyone else who has an idea? I do not really want to switch the box to etch, as it does not run with the 2.6 kernel (P2-350).



PBSchmidt 01-08-2008 09:15 AM

Hello Jens,

after considering the risk, I tried your dpkg line - this took the cookie! I dimly remember having done something like that before (for a non-official .deb that was a little crude aka fouled up a bit), as I did not loose my dear Sarge then, I took the risk and it worked out fine. Hooray! :D I am saved!

So, again, all my ten thumbs up, debian is coooool :cool: ! Never had a box that required that little blood, sweat and tears to maintain. And whenever I reach my limit, it's you coolsters out here having the magic spell to make it work anyway.

Have a wonderful day!


All times are GMT -5. The time now is 03:33 AM.