-   Debian (
-   -   apt-get errors and kernel panic (

kdogksu 01-10-2005 09:08 PM

apt-get errors and kernel panic
I am putting Debian on an older (K7 700mhz) machine to use with MythTV, but am having some fundamental Debian problems. I am trying to upgrade debian to unstable, and replaced all instances of 'stable' in sources.conf with 'unstable', except for, which I commented out (it is my understanding that there is no such source for unstable). Now when I try to run any apt-get operation, it fails. Apt-get update connects and updates all the package lists, but then spits out:

Reading Package Lists... Error!
E: Problem parsing dependency Depends
E: Error occured while processing libuuid1 (NewVersion1)
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened

/var/lib/dpkg/status does exist, but appears corrupted. the Depends line of libuuid1 appears as follows:

Depends: libc6 (>= 2.^B~V^C@^R~V^C... etc ... just a bunch of corrupt garbage until ... v^U@sing a standard with is blessed by both Microsoft and DCE, ...

and the file seems uncorrupted from there on. In the same directory, I found status-old, which I used to replace the current status (backing up the original, of course). Apt-get update seemed to complete just fine, and I ran dist-upgrade. In the middle of the upgrade, I got a kernel panic and had to shut down the machine. Now whenever I run apt-get dist-upgrade, it does its thing for a while, then outputs many lines of hex numbers in brackets along with errors such as the following:

[<c0114530>] do_page_fault+0x0/0x50c

and finally ending with:

E: Sub-process /usr/bin/dpkg received a sementation fault.

I think it was a kernel panic that caused this whole corruption issue to start with (hard to remember, I got frustrated and gave up the battle for about a week). Any advice on how to fix apt-get or the kernel? I'll post the kernel panic info if it happens again, and in the meantime see if I can't sort out the kernel problem. Thanks!

kdogksu 01-10-2005 11:08 PM

I tried to recompile the kernel (2.6.6 from to leave out some of the more iffy componenets and hopefully resolve this instability. After updating the config, I tried to compile the kernel. It seems to get most of the way through, but segfaults near the end. I tried with both gcc-2.95 and gcc-3.3 with similar results. I even rebooted to the kernel installed by the debian CD with no luck. I am, of course, running make clean each time. The error is not always the same but seems to occur in about the same place. The most recent one is:

OBJCOPY arch/i386/boot/compressed/vmlinux.bin
/bin/sh: lin 1: 10014 Segmentation fault objcopy -O binary -R .note -R .comment -S vmlinux arch/i386/boot/compressed/vmlinux.bin
make[2]: *** [arch/i386/boot/compressed/vmlinux.bin] Error 139
make[1]: *** [arch/i386/boot/compressed/vmlinux] Error 2
make: *** [bzImage] Error 2

I thought installing Debian on this machine would be really easy as it has been in the past with other machines, but it has been uphill all the way with this junker. Any help would be appeciated. Thanks!

marcheikens 04-17-2005 11:31 AM

I don't know if you've resolved this or not, but I just had the same sort of problem, but mine was with portmap's Depends list. The original Depends: line was:

Depends: libc6 (>= 2.3.2.ds1)4), libwrap0

So I looked for another package with a similar Depends list, and found that it should read:

Depends: libc6 (>= 2.3.2.ds1-4), libwrap0

All I did was change that single parenthesis to a hyphen, and lo and behold, apt-get worked again! I'm wondering if this is some sort of typo from the package maintainer, but as long as it's as easy to fix as this, I guess I can't complain too much.

Obviously this probably won't help your kernel panic, but if you're still having problem with this part, that should help.

kdogksu 04-18-2005 08:39 PM

Thanks for your reply; I should have finished this post when I resolved it. My problem turned out to be bad RAM. I ran memtest on it, and it showed up right away. I removed that stick of RAM and everything went back to normal. I'm glad you got your problem solved as well. Thanks again!

marcheikens 04-18-2005 09:16 PM

What I helped with, I'm not sure, but ... you're welcome? Glad you fixed your problem as well.

All times are GMT -5. The time now is 05:49 AM.