LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   apt-get errors (https://www.linuxquestions.org/questions/debian-26/apt-get-errors-286603/)

doctorwebbox 02-05-2005 11:17 AM

apt-get errors
 
I have just set up debian on a brand new machine. I used the sarge net installer then when installation was complete made sure that I had stable, testing and unstable apt sources. I have done this many times before with no problem.

I have installed a lot of stuff with no problem using apt-get and synaptic, they seem to work but I get a lot of wierd error messages in the terminal output. I was wondering if anyone could explain what it means and what I should do to sort it:

String found where operator expected at /usr/sbin/dpkg-preconfigure line 96, near "die sprintf(gettext(""
(Might be a runaway multi-line "" string starting on line 94)
(Missing semicolon on previous line?)
Bareword found where operator expected at /usr/sbin/dpkg-preconfigure line 96, near "die sprintf(gettext("debconf"
(Do you need to predeclare die?)
Unquoted string "debconf" may clash with future reserved word at /usr/sbin/dpkg-preconfigure line 96.
String found where operator expected at /usr/sbin/dpkg-preconfigure line 103, near "gettext(""
(Might be a runaway multi-line "" string starting on line 96)
(Missing semicolon on previous line?)
Bareword found where operator expected at /usr/sbin/dpkg-preconfigure line 104, near "$package, $confmodule"
(Might be a runaway multi-line ff string starting on line 103)
(Missing operator before dule?)
Unquoted string "dule" may clash with future reserved word at /usr/sbin/dpkg-preconfigure line 104.
syntax error at /usr/sbin/dpkg-preconfigure line 96, near "die sprintf(gettext(""
Unmatched right curly bracket at /usr/sbin/dpkg-preconfigure line 108, at end of line
syntax error at /usr/sbin/dpkg-preconfigure line 108, near "}"
Execution of /usr/sbin/dpkg-preconfigure aborted due to compilation errors.

mrcheeks 02-05-2005 11:51 AM

install woody(mininum install) and upgrade to sarge if you still have problems.

darkleaf 02-05-2005 12:40 PM

I have the same in SID looks the be an error in apt. I got it since I downgraded from experimental to SID. It does nothing strange and you can still install stuff so I guess we just have to wait till an upgrade is available.


All times are GMT -5. The time now is 08:59 PM.