LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-15-2019, 11:54 AM   #1
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Rep: Reputation: Disabled
apt/aptitude package install error cause by squid-deb-proxy-client/apt-avahi-discover


Code:
Distributor ID:	Debian
Description:	Debian GNU/Linux buster/sid
Release:	stable-updates
Codename:	sid
Linux 4.19.0-2-amd64 #1 SMP Debian 4.19.16-1 (2019-01-17) x86_64 GNU/Linux
yesterday I started receiving various versions of this message when installing packages:

Code:
SyntaxError: invalid syntax
  File "/usr/share/squid-deb-proxy-client/apt-avahi-discover", line 130
    print "http://[%s]:%s/" % (ip, port)
                          ^

This https://bugs.debian.org/cgi-bin/bugr...cgi?bug=867682 was all I could find related to the issue but I am on buster/sid now and have not removed these packages so I am unable to discern a solution. Its not a super huge deal. Might as well call it a national emergency. Immediately after exiting the failed process I run the same command and all works fine. It's just annoying. Has anybody else experienced or started experiencing this?

thanks

**EDIT

I've recently added some ubuntu ppa's and some helper packages to handle them I'm wondering if this has anything to do with it.

Last edited by spenced; 02-15-2019 at 12:10 PM. Reason: more info
 
Old 02-15-2019, 10:01 PM   #2
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Original Poster
Rep: Reputation: Disabled
I removed apt-venv, avahi-discover and *both squid dependencies: squid-deb-proxy, squid-deb-proxy-client and purges the residual configs after removing. those packages aren't necessary for apt to function normally anyway.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No package 'x11' found No package 'xext' found No package 'xdamage' found No package 'xfixes' found No package 'x11-xcb' found Jigsaw Linux From Scratch 10 05-03-2016 11:33 AM
Can't get avahi to install (trying to get Netatalk and Avahi running) MarcusWebb1966 Gentoo 4 07-28-2011 03:55 AM
Is Aptitude capable of installing local .deb package and resolve dependency issue? Akhran Debian 3 07-06-2009 05:05 PM
update-initramfs is failing - how can I discover the cause? Mountain Linux - General 1 04-09-2009 05:44 PM
Will 'aptitude upgrade or dist-upgrade' downgrade manually installed deb package? Akhran Debian 3 03-14-2006 02:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration