-   Debian (
-   -   apache-modconf (

Cronjob 05-12-2006 10:11 PM

I've been using debian and apache for many years, but I've only now encountered apache-modconf, which is apparently necessary to add or remove DSO modules in Apache 1.3.33 on Debian.

It seems to be a Debian specific "tool" as I can find very little documentation on it and even the Apache site's documentation index yields zero results for a search on it.

According to the notes here at the url below, you should be able to query for a module and get a response if it exists and is enabled.

However, when I do apache-modconf apache query expires_module nothing shows up. No confirmation that it is enabled. No error. Just a fresh command prompt.

I know it is enabled, because it appears (uncommented-out) in modules.conf. I also tried disabling and enabling expires_module, but I didn't get any response on the command line from that either (no error, confirmation or anything else). And checking modules.conf doesn't show any change (it isn't commented out as one would expect if you disabled it).

I don't see anything peculiar with strace. It just shows it checking /usr/lib/apache/1.3 and does a read and a stat64 on /usr/lib/apache/1.3/mod_expires.*

Anyone run into this before? Would there be any problem with me simply deleting modules.conf and copying the contents into httpd.conf like it always was? It used to be so simple to add a DSO module. You just add a LoadModule line into your httpd.conf and do an apachectl graceful.

Your thoughts and insight are appreciated.

Cronjob 05-13-2006 02:15 AM

Okay, it appears that it was my fault (though the documentation was unclear). The documentation says to use "module_name". That is incorrect. You need to use the mod *.so filename (sans the .so part).

So, instead of:

apache-modconf apache query expires_module

You need to use:

apache modconf apache query mod_expires

It makes sense, but one is the *name* (as referenced in your LoadModule line) and the other is a *file*. Anyway, it works.

All times are GMT -5. The time now is 02:59 AM.