LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-08-2004, 11:27 AM   #1
b0rcked
LQ Newbie
 
Registered: Mar 2004
Posts: 28

Rep: Reputation: 15
alsa stops working


Hi guys,

Let me just thank all of you in advance for the help. Recently I tried to get wireless working on my computer. This caused to many problems to even list, so I got rid of all the wireless stuff I had done and have now fixed most of the problems. One thing that happened, though, was that alsa stopped working and I now have no audio. I ran alsaclt restore and it said that there was no soundcard even detected.

Any ideas? can you guys please help me trouble shoot?

Thanks much.

David
 
Old 05-08-2004, 11:31 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
What is the output of lsmod???
 
Old 05-08-2004, 02:00 PM   #3
b0rcked
LQ Newbie
 
Registered: Mar 2004
Posts: 28

Original Poster
Rep: Reputation: 15
localhost:/# lsmod
Module Size Used by Not tainted
lsmod: QM_MODULES: Function not implemented
 
Old 05-08-2004, 10:59 PM   #4
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Have you recompiled your kernel at any point, what kernel are you using? Does
cat /proc/modules come up with anything different to lsmod?
 
Old 05-09-2004, 11:42 AM   #5
b0rcked
LQ Newbie
 
Registered: Mar 2004
Posts: 28

Original Poster
Rep: Reputation: 15
I haven't recompiled my kernel...i'm using 2.6.4
 
Old 05-09-2004, 08:51 PM   #6
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
"- You need replacement module utilities from
http://www.kernel.org/pub/linux/kern...rusty/modules/"

http://www.codemonkey.org.uk/post-halloween-2.5.txt
 
Old 05-11-2004, 05:22 PM   #7
b0rcked
LQ Newbie
 
Registered: Mar 2004
Posts: 28

Original Poster
Rep: Reputation: 15
Ok...so i recompiled my kernel and instead of compiling it into the kernel I made it a module...new lsmod:

dlokshin@localhost:~$ lsmod
Module Size Used by
md5 3840 1
ipv6 241088 10
snd_maestro3 22724 3
snd_ac97_codec 57444 1 snd_maestro3
rtc 12504 0


So I was right...and the correct sound driver was compiled in. But sound still doesn't come out of the speakers. What should I do? what's wrong?
 
Old 05-11-2004, 10:24 PM   #8
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Have you turned up your sound channels and unmuted them?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa stops mplayer WilliamS Slackware 3 09-13-2005 03:35 PM
SiS on board sound stops working when upgrading alsa? + kernel question? mr.gizm0 Linux - Software 3 03-21-2005 10:46 AM
powerbook ALSA stops working after reinstalling OSX? fibbi Linux - Laptop and Netbook 2 12-26-2004 08:38 PM
xmms stops playing(alsa with dmix) kostian Slackware 8 07-30-2004 07:53 AM
kernel upgrade and alsa stops working seppe Linux - Hardware 1 10-02-2003 11:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration