LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-15-2004, 04:19 PM   #1
dun_noe
Member
 
Registered: Sep 2004
Location: Singapore
Distribution: Debian unstable
Posts: 31

Rep: Reputation: 15
Alsa driver in kernel 2.6.x?


Hi,

I use Debian Sarge, and I've installed the kernel 2.6.8-k7. For my sound card, now I use oss driver, I can hear the audio, but the problem is I can't get full duplex support for my sound card (enabling full duplex in KDE Control Center makes arts crash for a while), so I want to try to use alsa driver. But in the kernel modules configuration (alsa driver has been included in kernel 2.6.8, isn't it?), I can't find any modules for alsa driver, I only find modules for oss driver. I also have installed alsa-related packages from debian. And also, the alsa init script report error message:

#/etc/init.d/alsa restart
Storing ALSA mixer settings ... failed
Restoring ALSA mixer settings ... failed:
You may want to run 'alsactl restore' manually to view any errors.

And if I run 'alsactl restore':
# alsactl restore
alsactl: load_state:1134: No soundcards found...

Anybody know where I should go to configure the alsa driver?

Any suggestions will be appreciated...
And sorry for my english

Thank you.
 
Old 09-15-2004, 04:31 PM   #2
HansOlo
LQ Newbie
 
Registered: Aug 2004
Distribution: debian
Posts: 29

Rep: Reputation: 15
It may be that OSS has control of your soundcard. Maybe you need to remove OSS before you install ALSA? ALSA has OSS emulation, so all your applications that use OSS will still work.
 
Old 09-15-2004, 04:59 PM   #3
dun_noe
Member
 
Registered: Sep 2004
Location: Singapore
Distribution: Debian unstable
Posts: 31

Original Poster
Rep: Reputation: 15
Thank you for your suggestion, but I've tried to remove all oss-related modules using modconf, but I still can't make the alsa work, I got the same error messages when I try to restart the alsa init script and also when I try to rum the 'alsactl restore'.

And after I restart my computer, It seems that the oss driver modules are loaded again to the kernel tree (event though I've already removed it from modconf). Anyone can help me to solve the problem?

Sorry, I forgot to write down my configuration: I use nVidia nForce2 chipset mobo with sound card integrated (KMix shows that my sound card is ALC650), I also have tried to use nForce2 driver from nVidia, but it is even worse, it didn't work at all (I can insert the module, but it was reported that the program can't write to the device /dev/dsp).

Thank you.

Last edited by dun_noe; 09-15-2004 at 05:08 PM.
 
Old 09-16-2004, 02:33 PM   #4
moonloader
Member
 
Registered: Nov 2003
Location: linuxquestions.org
Distribution: Linux and BSD
Posts: 229

Rep: Reputation: 30
hi!
if you have installed alsa-utils,alsa-base next you should install alsa-source type apt-get install alsa-source and choose your sound card while dpkg configures and asks from you,then type as root /usr/share/alsa-base/snddevices,then type alsaconf and en choose your soundcard module hen as normal user type alsamixer fix your sound then as root type alsactl store.if OSS is enabled by default in Debian kernel-source and you compiled ALSA as module and enabled it then it won't work at the same time!you can not emulate together.

good luck
 
Old 09-16-2004, 10:06 PM   #5
Underhill
Member
 
Registered: Aug 2004
Location: Kuala Lumpur, Malaysia
Distribution: Debian Etch
Posts: 58

Rep: Reputation: 15
I've done that moonloader, doesn't work. The configuration running fine, but no sound. Whenever i try to increase the volume using the icon on gnome panel, it will kick back to 0.

Last edited by Underhill; 09-16-2004 at 10:08 PM.
 
Old 09-17-2004, 03:42 AM   #6
dun_noe
Member
 
Registered: Sep 2004
Location: Singapore
Distribution: Debian unstable
Posts: 31

Original Poster
Rep: Reputation: 15
I still get the same error message...no soundcards found. I've run the snddevices, and it reported that all the devices were successfully created. I also have remove all oss modules from kernel, but still doesn't work.
 
Old 09-27-2004, 05:37 PM   #7
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Rep: Reputation: 15
Quote:
Originally posted by Underhill
I've done that moonloader, doesn't work. The configuration running fine, but no sound. Whenever i try to increase the volume using the icon on gnome panel, it will kick back to 0.
The default Gnome volume control is for OSS drivers only. You'll need to run alsamixer to turn up the volume on an ASLA system. As for replacing the OSS volume control with one for ALSA, well, that's how I stumbled across this thread. Anyone know how?
 
Old 09-28-2004, 03:34 PM   #8
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Rep: Reputation: 30
alsa-mixer failed to load

I cant get Alsa to work and rather then make another alsa/debian post i'll just add on to this one:

I've installed the nForce drivers for my sound card, but it never loads the alsa-mixer. I run alsactl restore and it doesnt load, i do alsaconf and it shows me my sound card and everything but I select it and it says itll start alsa up, and again another alsa-mixer error. When i run gmix it says no mixer elements loaded. What can I do to get alsa-mixer working? thanks
 
Old 10-07-2004, 06:12 PM   #9
BradDaBug
LQ Newbie
 
Registered: May 2002
Posts: 29

Rep: Reputation: 15
Hey, I'm having the same problem. Same soundcard, same distro, same kernel. Has anyone gotten this to work yet?
 
Old 10-07-2004, 11:22 PM   #10
dun_noe
Member
 
Registered: Sep 2004
Location: Singapore
Distribution: Debian unstable
Posts: 31

Original Poster
Rep: Reputation: 15
Hi,

I think it's because after your system detecting your soundcard, your system just loading the OSS module for the sound card, so the ALSA driver won't be loaded.

Maybe you can try to prevent the OSS driver being loaded, so the system can load the ALSA driver. You can read this:

http://www.linuxquestions.org/questi...hreadid=228947

I also had the same problem, but after I skip the OSS, I can use my ALSA. About NVidia's driver, I have tried it, but it doesn't work in my machine. My problem now is just I still can't use my microphone even though the volume for the microphone I think is correct.
 
Old 10-12-2004, 06:17 AM   #11
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Rep: Reputation: 30
I finally got it to work just installing discovery, it pretty much set it up by itself, since it's a hardware detecting tool. I might have done something else, but I dont really remember.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel-source, alsa-driver and kernel compile jasone Linux - General 13 05-26-2005 01:15 AM
How to compile new ALSA driver into old kernel? sandin Slackware 4 05-14-2005 06:06 AM
SB 5.1 Live not working with emu10k1 alsa driver in 2.6 kernel taty Fedora 9 10-06-2004 12:37 PM
SB 5.1 Live not working with emu10k1 alsa driver in 2.6 kernel taty Linux - Newbie 2 10-04-2004 02:20 PM
alsa-driver-1.0.5.tar.gz or kernel alsa? shanenin Linux - Software 2 05-29-2004 02:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration