LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-05-2006, 01:37 AM   #1
CroweT
LQ Newbie
 
Registered: Sep 2005
Distribution: Gentoo
Posts: 5

Rep: Reputation: 0
After update, KDE crashes on startup, GNOME fine


Hi guys. I've been using various Linux distros on and off for a few years, but I'm new to Debian. Just to let you know that I can at least follow instructions if given!

Here's the basic: ksplash and konqueror both seem to lock up my system HARD after I did an update. CTRL+ALT+F[1-12], CTRL+ALT+BACKSPACE, and CTRL+ALT+DEL all do not seem to work once this occurs. I have to hard reboot the machine.

I've been running Sarge happily for several weeks now, but ran into trouble yesterday. I performed "apt-get update && apt-get upgrade" and low and behold, some new packages! My first post-install update!

I started KDE, which I'd been using almost exclusively, and starting browsing/messaging while the new .debs downloaded and upgraded. I flicked to my root console with CTRL+ALT+F4, saw it was done. Groovy.

A little while later, someone sends me a link in Kopete. I click on it, Konqueror starts up and BAM. Everything is frozen solid. After futilely pounding at the CTRL+ALT+... keys, I hard-reset.

My system came up fine (I do not use a graphical log-in), I log in, "startx", and everything froze at "Setting up inter-process communications". Hard freeze again.

I googled around for hours looking for a solution, but the only one that seemed to do anything was a guy who said that his KDE would freeze at this step, and he had to comment out ksplash in the "startkde" script. I did that, and KDE worked! ...sorta.

When I tried to use Konqueror to browse my local hard drive, it works. When I try to use it to browse the web, it hard-freezes the computer. The hard-freeze happens immediately if I'm in Fluxbox or Gnome and try to run "konqueror" from a terminal window. Immediately, as in "don't even get a chance to browse my HD".

Thus far, no problems in Fluxbox or Gnome. I haven't been brave enough to try any other KDE apps in these WM's since I found that at least Konqueror would cause the hard-freeze.

So far I've tried "apt-get --purge remove konqueror && apt-get install konqueror", as well as clearing out all files owned by my user in /var and /tmp. I've also moved all my ~/.kde* and ~/.qt* directories to a backup directory. All to no avail.

I tried running it as root and got the results. I'm pretty sure it's not a networking issue, as loopback (lo) seems to be up and fine, as the first thing my iptables rules do is ACCEPT all traffic on lo, and I can ping 127.0.0.1 without a hitch. Lastly, apt-get update && apt-get upgrade have not found any more updates, utp and including midnight tonight (Tues 4/5).

Any help would be greatly appreciated. I've been searching this page, Google, and the Debian bugs lists ever since and haven't found anything. Plus, even using ReiserFS, I don't think that hard resets are good for the file system!

The most pertient thing I can think of is the X error log. Note that I tried CTRL+ALT+BACKSPACE afterwards, which I think caused the shutdown messages. I didn't see anything particularly interesting. but here it is (URL in error log removed to get around a no-URLs until you post thrice filter on this site):
Code:
XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-14sarge1 20050901212727 fjp@localhost.localdomain)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.8-16.0508-2 i686 [ELF]
Build Date: 02 September 2005

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way.  Bugs should be reported to the Debian Bug Tracking System; see
<URL: CENSORED BY LINXQUESTIONS.ORG'S URL FILTER >.

We strongly encourage the use of the "reportbug" package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
       XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
  plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.6.8-2-k7 (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-13)) #1 Tue Aug 16 14:00:15 UTC 2005 T
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Apr  5 00:28:24 2006
(==) Using config file: "/etc/X11/XF86Config-4"
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o":  No symbols found
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
startkde: Starting up...
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
SetClientVersion: 0 9
QFont::setPointSize: Point size <= 0 (-3)
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x80ca018 ): KAccel object already contains an action name "del"
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  7
  Minor opcode:  0
  Resource id:  0x1400007
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  6
  Minor opcode:  0
  Resource id:  0x1400007
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  7
  Minor opcode:  0
  Resource id:  0x160000d
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  6
  Minor opcode:  0
  Resource id:  0x160000d
startkde: Shutting down...
klauncher: Exiting on signal 1
warning: leaving MCOP Dispatcher and still 13 object references alive.
  - Arts::SampleStorage
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_PLAY
  - Arts::StereoVolumeControl
  - Arts::StereoEffectStack
  - Arts::Synth_BUS_DOWNLINK
  - Arts::SoundServerV2
  - akodeXiphPlayObject
  - Arts::Synth_BUS_UPLINK
  - Arts::Synth_AMAN_PLAY
  - Arts::AudioManagerClient
  - Arts::MidiManager
warning: leaving MCOP Dispatcher and still 162 types alive.
KWrited - Listening on Device /dev/pts/0
startkde: Running shutdown scripts...
startkde: Done.

Last edited by CroweT; 04-05-2006 at 01:56 AM.
 
Old 04-05-2006, 05:08 PM   #2
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 848

Rep: Reputation: 45
It looks like you may have whole chunks missing out of the config file.

Before the log file starts muttering about fonts I would expect to see something like:

Quote:
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Delta"
(**) | |-->Device "CLE 266"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "uk"
(**) XKB: layout: "uk"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
Have you examined the config file?
 
Old 04-05-2006, 11:03 PM   #3
CroweT
LQ Newbie
 
Registered: Sep 2005
Distribution: Gentoo
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for taking the time to try and help!

Embarassingly enough, that was the wrong file I posted... I had saved both the standard XFree86 log file as well as the output from startx ("startx > err.txt 2>&1"), and got my wires crossed when posting.

Happily, though, someone showed me the solution. It turns out that there's a bug, at least with older versions, with Nvidia's accelerated drivers and KDE. Now, why it didn't rear it's ugly head before is beyond me, but I disabled 3D acceleration of X rendering (Option "RenderAccel" "false" in the Driver section of /etc/X11/XF86Config-4) and low and behold, no more hard-locks!

In case anyone else is having a similar problem: The 3 work arounds you can try is disabling RenderAccel, which is the surest. If that does the trick, you can try upgrading X (and maybe KDE?) and getting the latest drivers from nivida.com; hopefully you can re-enabled accleration after that. Lastly, there's a workaround posted here: http://www.thelinuxlink.net/myblog/?postid=309 --but it seems Sarge's version of X is too old to support the Composite extension.
 
Old 04-06-2006, 12:36 AM   #4
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 848

Rep: Reputation: 45
Very often, after an upgrade of X, and always after a kernel upgrade, you need to reinstall the nvidia driver.

Here is a cumulative fix for driver problems:

http://www.nvnews.net/vbulletin/showthread.php?t=62021

You HAVE to apply it for Kernel 2.16.
 
Old 04-06-2006, 08:43 PM   #5
CroweT
LQ Newbie
 
Registered: Sep 2005
Distribution: Gentoo
Posts: 5

Original Poster
Rep: Reputation: 0
Yeah, I appreciate that. Unfortunately, I have a GeForce 2 Ti, which is not supported on any Linux driver which Nvidia has released after NVIDIA-Linux-x86-1.0-7174-pkg1.run For the sake of posterity, I'd like to mention that I already had recompiled/reinstalled NVIDIA-Linux-x86-1.0-7174-pkg1.run and still got the same behavior with RenderAccel on.

Mercifully, everything seems to be fine with RenderAccel off, and according to glxinfo I still have direct rendering enabled for GL apps. You know, in case I want to play some Quake or Return to Wolfenstein. I think the RenderAccel is only for accelerating typical X stuff.

Maybe I'll finally decide what graphics card to replace the one in this old XP 2600 without wasting too much $$, and can use the newer drivers to boot!

Last edited by CroweT; 04-06-2006 at 08:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome Theme-manager crashes on startup distortedstar Linux - Software 1 04-11-2009 11:08 PM
suse 10 crashes on gnome startup cor_anglais1 SUSE / openSUSE 2 10-27-2005 09:56 PM
kde startup no sound, after alsaconf fine, but then no midi SonicGT Debian 1 10-16-2005 08:31 AM
KDE crashes on startup bobbens Linux - Software 4 11-22-2004 12:57 PM
KDE crashes at startup when it gets to peripherals Gar Linux - Newbie 0 12-23-2003 04:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration