LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-10-2009, 02:27 AM   #1
inspiron_Droid
Member
 
Registered: Dec 2006
Distribution: Debian (Wheeze)
Posts: 391

Rep: Reputation: Disabled
Exclamation adobe-flashplugin won't install on linux


I just installed lenny on my Lenovo N500, bdebian:/home/smitp/Desktop/Downloads# dpkg -i install_flash_player_10_linux.deb
(Reading database ... 112876 files and directories currently installed.)
Preparing to replace adobe-flashplugin 10.0.32.18-1 (using install_flash_player_10_linux.deb) ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: warning: old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error processing install_flash_player_10_linux.deb (--install):
subprocess new pre-removal script returned error exit status 2
postinst called with argument `abort-upgrade'
dpkg: error while cleaning up:
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
install_flash_player_10_linux.deb
debian:/home/smitp/Desktop/Downloads#
ut win i try to install the non free adobe flash plugin from a downloaded deb package I get the the following error messages.

any fixes would be greatly appreciated!
 
Old 08-10-2009, 03:13 AM   #2
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
If your using debian and x64 I'd suggest you use nspluginwrapper because the 64bit plugin is buggy. Other than that, if your using 32bit just install to ~/.mozilla/plugins.

If you choose nspluginwrapper then I'd install ia32-libs with sid and use the lenny package for nspluginwrapper.
 
Old 08-10-2009, 03:16 AM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
adobe-flashplugin is a Ubuntu package NOT a Debian package.

Take a look at [SOLVED] Can't open synaptic after trying install flash deb of ubuntu - LinuxQuestions.org - http://www.linuxquestions.org/questi...ubuntu-739384/
 
Old 08-10-2009, 09:21 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
apt-get install flashplugin-nonfree

works perfectly on x64 too
 
Old 08-11-2009, 05:27 AM   #5
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by craigevil View Post
adobe-flashplugin is a Ubuntu package NOT a Debian package.

Take a look at [SOLVED] Can't open synaptic after trying install flash deb of ubuntu - LinuxQuestions.org - http://www.linuxquestions.org/questi...ubuntu-739384/
If you know what your doing you can mix ubuntu and debian packages, since it's basically the same thing. I've done it for wine and flash, so really you can just get the repo's and mix and match. Just make sure you disable the different repo when you are doing updates. I usually just enable it for one package then once i get it working disable it and run my system normally. I use squeeze atm and hardy/jaunty or whatever has worked fine whenever i needed it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no flash-animation audio in Iceweasel; can't install flashplugin-nonfree-extrasound bezdomny Linux - Software 3 06-01-2010 07:38 AM
Install adobe suite on linux hassandit Linux - Desktop 13 08-10-2009 10:06 AM
flashplugin-nonfree vs adobe-flashplugin - which is the better Firefox plugin? brjoon1021 Ubuntu 11 01-04-2009 07:52 PM
LXer: Adobe releases Adobe Flash Player 10 beta for Linux LXer Syndicated Linux News 0 05-16-2008 07:30 AM
Sid, apt-get install flashplugin-nonfree Outabux Debian 10 04-15-2004 06:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration