LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-23-2009, 09:54 PM   #1
JanVYW
Member
 
Registered: Apr 2007
Posts: 45

Rep: Reputation: 16
Accessing that other system


I'm not certain that this is a specifically Debian problem but it does not exist on a CD Slax system and did not on my Etch installation.

I can't write to the XP partition. Except for root I can't even read it. I've set umark=000 in fstab and KDE comes up with all permissions flying (after I discovered that the bit switches are evidently reversed since 777 comes up with all off and intermediate like 0644 with strange results). But it still tells me I can't write to it , though I can at least now read.

I assume there's some over-riding control because I can't imagine it could read NTFS without being able to write it as well. I've looked for some script over-riding everything else but it's hard enough to find any reference to the overall startup script at all. All I've found so far are /etc/init.rd which I do not see should still be over-riding either command line and KDE mount from fstab. All I can say is that I'm glad I specified Dell to provide a floppy or else I'd have not way to transfer information except to write it down.

BTW when I was back on Sarge I think, I could switch into it from Windows 98 without rebooting the entire machine, via 'Linload - ?'. I've lost that several machines and system upgrades later. Is there still a way to start Linux from Windows without dropping the entire machine, and even vice-versa, which never was possible before?

I also downloaded compiled Flock browser a while ago but there's no indication of where everything should go except that from the scripts it looks as if it should be split up and wants some libraries containing ~.so different from the Debian layout.
 
Old 02-23-2009, 10:22 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,837

Rep: Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986Reputation: 1986
I'm going to guess that you're mounting the drive with the old NTFS kernel driver, which is not safe for writing and is thus generally set to read-only. For write support you need to use the fuse/ntfs-3g driver.


If you don't have any specific reason to run XP alone, such as for games, you might look into setting up a virtual machine so you can run it from within Linux. It would be more convenient and secure that way.
 
Old 02-24-2009, 07:19 AM   #3
JanVYW
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 16
Thank you So, new driver, and from fuse not Debian. I rmember seeing something about ntfs write being unsafe ages ago when I wasn't using it. I have wasted a lot of disk giving half to each system because there isn't much that I use XP for any more. A few 'games' like virtual worlds need it (and are telling me now that 1G RAM isn't good enough) and some streaming and Realplayer aren't converted to 64-bit and one chatroom only works with IE but I can't pretend to spend a lot of time there. That is mainly why I want to write to it, just to list new bookmarks and the like as text to copy into browsers and to sort anything out that blows up since I cant re-install XP without losing the MBR and Grub (or can I - I remember there was DOS facility for saving MBR - but I don't know what else XP might interfer with)

In fact, if a SLAX CD is happy to write ntfs then it probably has the driver I need somewhere...
 
Old 02-24-2009, 04:27 PM   #4
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675
Blog Entries: 11

Rep: Reputation: 36
Maybe if you're still interested in writing to ntfs you should type the following as root:
Code:
aptitude install ntfs-3g
I think that will install all the fuse stuff, so that you can mount the partition with a command like:
Code:
ntfs-3g /dev/hda1 mountpoint
(or)
mount -t ntfs-3g /dev/hda1 mountpoint
Of course you have to specify the mount point, and the partition (/dev/hda1) has to be correct for your system. I think you also have to unmount the partition if it's already mounted "read-only" somewhere else. I hope this works for you. If you want more info on ntfs-3g, type "man ntfs-3g" of course. If all of this is something you already know, disregard this post.

Last edited by radiodee1; 02-24-2009 at 04:28 PM.
 
Old 02-24-2009, 05:44 PM   #5
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
Fuse in in the kernel if you have Debian Etch or Lenny. And I'm pretty sure NTFS-3g is installed by default in both. If not, it is easily obtainable from the Debian repository. I've never had to install anything additional that I can recall.
 
Old 02-25-2009, 08:18 AM   #6
JanVYW
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 16
Got it from Debian but have not tested it since a restart. It didn't work immediately after installation but that could be that boot checks which driver is in use. What was a little sorrying was when I wanted to check for a file I got prompted to run apt-file update. That's fine until it asks for my original Etch CD and statrs looking for an index I can't remember that isn't on there and as fas I know never has been. I expect it is on a later version but it's just recognising I started with an Etch installation. All told, minor problembut one that might hint at problems to come.
 
Old 02-25-2009, 05:19 PM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809
Blog Entries: 58

Rep: Reputation: Disabled
Comment out (put a # in front of) the CD entries in /etc/apt/sources.list, that will stop it asking for the CD.
 
Old 02-25-2009, 07:25 PM   #8
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
How did you install Debian? And what version?
 
Old 02-26-2009, 08:54 AM   #9
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,243
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Yes I'm confused as well..

you said the issue didn't exist in etch, then later stated that apt asked for the etch CD.. is your sources list correct ?
Did your update to lenny actually complete with conflicting entried in the sources list ? (assuming that is what you did)
 
Old 02-27-2009, 12:05 AM   #10
JanVYW
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 16
I could write to NTFS in Etch. I've installed the new driver but haven't had the nerve to test it as root because I wanted a rest in case it doesn't work, from chasing all over. It can read now and that is the important thing. It jus happened that I wanted to able to write and delete in case Windows fouled up so badly that I couldn't use it - I've just been sorting somebody else out with exactly that kind of problem left by a Zlob virus that even after re-installation of Windows and IE7 still replaces the 'active X' warning with sdvice to download 'anti-virus 360'. I told them to use Firefox instead - for 50 what do they expect?

The reference to Etch CD is just that my original installation was Etch and occasionally upgrades go back to wanting the first CD. It happens that this one (for apt upgrade) wanted to check some file that isn't on the Etch CD and probably belongs to a later version. Anyway, somebody suggested how to cut that CD check out. No doubt it's only checking back to Etch because it's recorded that's where I started but as time goes on, individual routines are more likely to want stuff that isn't on there. I don't see why it should need the original CD at all, probably some security thing that I just haven't turned off.

It's no big deal because I was using a nice pretty KDE front end and if it keeps playing up I'll just have to drop under it and monkey about with aptitude head on.
 
Old 02-27-2009, 11:22 PM   #11
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,243
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
to get rid of the etch cd you can edit the /etc/apt/sources.list file and comment out the line for the etch CDROM. you really should do that ASAP then update and upgrade again...

aptitude update && aptitude safe-upgrade

With the CDROM entry still in there it could possibly have prevented some packages from upgrading properly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing system and mysql naicker82 Arch 1 03-20-2006 05:18 AM
accessing file system of MMC jogurt666 Linux - Hardware 0 05-11-2005 03:07 PM
accessing system variables in c++ gearoid Programming 4 05-13-2004 05:55 AM
accessing system calls information netwizio Programming 4 02-18-2004 12:53 AM
Accessing harddrive in dual boot system Retnart Linux - Newbie 6 04-26-2002 06:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration