LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-16-2006, 08:12 AM   #1
darsu
LQ Newbie
 
Registered: Sep 2005
Location: Helsinki
Distribution: Kubuntu 5.10
Posts: 3

Rep: Reputation: 0
A nasty package dependency problem


Using Sarge/Stable here. I'm trying to install libgtk2.0-dev:

The following packages have unmet dependencies:
libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.6.4-3.1) but 2.6.8-1 is installed.
Depends: libpango1.0-dev (>= 1.4.0-3) but it is not installable
Depends: libatk1.0-dev (>= 1.6.1-2) but it is not installable

The first item seems incomprehensible - I'm using stable, so what can explain such an absurd version requirement and mismatch? libfontconfig1 and its dev package (required by libpango) have a similar discrepancy. What to do?

Last edited by darsu; 03-16-2006 at 08:13 AM.
 
Old 03-16-2006, 08:32 AM   #2
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
Makes perfect since libgtk2.0-dev depends on libgtk2.0 v2.6.4-3.1, you have v2.6.8-1. Where did you get it? The current version available in the security updates is 2.6.4-3.1. You have installed it from some other source.
 
Old 03-16-2006, 09:12 AM   #3
darsu
LQ Newbie
 
Registered: Sep 2005
Location: Helsinki
Distribution: Kubuntu 5.10
Posts: 3

Original Poster
Rep: Reputation: 0
Ah, I suppose those might be leftovers from my pre-Sarge unstable setup. Downgrading the problem packages by hand did it. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wierd dependency problem with openldap-server package Akhran Fedora 1 02-15-2006 07:38 AM
RHEL 4 RPM package dependency problem tekhed21 Linux - Enterprise 2 01-06-2006 01:18 PM
Nvu package dependency kermit Linux - Software 5 01-11-2005 09:45 AM
There was a package dependency problem Kensai Fedora 3 02-15-2004 06:02 PM
Package dependency problem (glibc) jizlobber Linux - Newbie 1 10-08-2003 02:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration