LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-03-2007, 06:34 AM   #1
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
4GB on 32-bit Debian?


Hi all,

I've got Debian Etch (32 bit). I have recently upgraded my RAM to 4GB.
However, it only recognises 3.2 GB. In BIOS it recognises full
4gig and states that they are 'fully usable' so everything seems
ok there.

I've read somewhere that it's a problem of a 32-bit version of a kernel
on Debian, and that 64-bit version would solve the problem. Is it true?

thanks
 
Old 07-03-2007, 07:05 AM   #2
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Do you have the large memory (bigmem) kernel installed? I think that for that much ram, you would need it. Do a 'uname -r' to find out your current kernel, and then try "aptitude search linux-image" to see if you can find the appropriate bigmem version.
 
Old 07-03-2007, 07:24 AM   #3
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,686

Rep: Reputation: 124Reputation: 124
Keep in mind that the kernel sees 1 kb as 1024 byte, whereas any vendor sees 1 kb as 1000 byte. That means that 1 GB is actually 1,073,741,824 bytes and not 1,000,000,000 bytes. Do the rest of the math yourself
 
Old 07-03-2007, 08:20 AM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
Quote:
Do you have the large memory (bigmem) kernel installed?
Thanks for the replies, Yes, I've definitely got the Big mem option enabled in the kernel. I checked the config file. Anyway If it wasn't, it would only recognise up to 1GB. Btw, it's 2.6.18.4-686 kernel

As to the maths issue, I'm not a mathematician, but that would suggest that I should have around 3.8Gb recognised by the kernel, not 3.2 (btw, my graphics has separate memory, so it doesn't use the main ram)

thanks
 
Old 07-03-2007, 10:56 AM   #5
lycan
Member
 
Registered: Jul 2007
Location: Kolkata, INDIA
Distribution: Debian Lenny
Posts: 51

Rep: Reputation: 15
Quote:
Originally Posted by sycamorex
Hi all,

I've got Debian Etch (32 bit). I have recently upgraded my RAM to 4GB.
However, it only recognises 3.2 GB. In BIOS it recognises full
4gig and states that they are 'fully usable' so everything seems
ok there.

I've read somewhere that it's a problem of a 32-bit version of a kernel
on Debian, and that 64-bit version would solve the problem. Is it true?

thanks
You guessed right. You cannot use 4GB RAM on a 32 bit system. The system always recognizes around 3-3.2 GB, not 4GB. Its a restriction of 32 bit OS regardless of windows and *nix systems. You have only two options.

1. Install a 64bit version of debian.

2. Recompile the 32 bit kernel with extended memory support or whatever it called( I can't remember the phrase exactly ).
 
Old 07-03-2007, 11:44 AM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
Thank lycan,

I'll try to recompile the kernel. does anyone know the exact name of the parameter in the kernel?

regards
 
Old 07-03-2007, 12:52 PM   #7
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,592

Rep: Reputation: 96
Quote:
Originally Posted by sycamorex
Thank lycan,

I'll try to recompile the kernel. does anyone know the exact name of the parameter in the kernel?

regards
Recompiling will make no difference it is a hard limit of 32bit and the way the memory is mapped using the options in your BIOS, PAE and the space reserved for your PCI devices/video card. In other words you getting all you can right now unless you use a 64bit install addressing the memory with 64bit mode enabled in your BIOS then you will see it all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Running 32-bit Applications on 64-bit Debian GNU/Linux LXer Syndicated Linux News 2 01-06-2010 01:26 PM
Debian - how do I downgrade to a 32 bit kernel? alizard Linux - Software 10 12-19-2006 04:37 PM
Cannot set bit rate in Debian piampri Linux - Networking 7 02-28-2005 03:59 PM
4GB RAM: 64-bit Opteron Problems deviance99 Linux - Hardware 6 06-22-2004 09:24 PM
Is Debian a 64 bit OS Asad Debian 3 12-01-2003 12:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration