-   Debian (
-   -   [Error] Kernel Module : No kernel module build environment (

saman007uk 07-18-2005 01:51 PM

[Error] Kernel Module : No kernel module build environment
I've been trying to install the official ATI driver for my graphics card,
but I get the following error:

[Error] Kernel Module : No kernel module build environment

The strange think is that the installation works fine in the 2.4.x kernel,
but in the 2.6.8-2-686 kernel it give the above error. I'm using Sarge and
i have the kernel sources and headers for 2.6.8-2-686 installed.

what other package do I need to install? Where am I going wrong?

ruddigger 07-18-2005 09:28 PM

did you try downloading the kernel-build-2.6xxxx package? can that have anything to do w/it?

saman007uk 07-19-2005 02:05 AM

Yes - but no such pacakge exists for i386, it's all for powerpc, sparc, etc.

Pirate Steve 09-08-2006 07:25 PM

:confused: I have the same error but I'm using the 2.4 sarge kernel. I'm
super new to Linux so I'm hoping it's something simple! I read that the
software requirements are POSIX, glibc 2.2 or 2.3, Linux Kernel 2.4 or
higher, and XFree86 4.3. I don't know about POSIX, that's a total
mystery to me, but Debian sarge should use glibc 2.3, and XFree86 I have
installed is 4.3. As I mentioned I am using the 2.4 Kernel

About POSIX and glibc, are those packages I need to specify? Hep! I'm
surfing the web in w3m!!

saman007uk 09-09-2006 03:59 AM

What I don when installing ATI drivers is convert the RPM dpackage to .DEB packages using a program called "alien". You can search for it using apt-get.

Afterwards, installing the DEB is easy (although you need to use the --overwrite-all feature).

Pirate Steve 09-09-2006 09:27 AM

It said "Unknown type of package".

I used apt-get install alien

then I navigated to the directory where the ATI driver installer lives
and typed

Is there another set of drivers I should use?
Did neglect a dependency with alien? It says in the man that it needs
rpm so I tried to install it but it was already current.

saman007uk 09-09-2006 05:36 PM

That's not an RPM package. An RPM package ends in .rpm and not in .run. You can doenload the RPM from the ATI website.

Pirate Steve 09-09-2006 06:34 PM

I got it figured out.

All times are GMT -5. The time now is 03:18 PM.