-   Debian (
-   -   [Debian Testing] Apt pinning, Google Earth, Pulseaudio problems (

Keessince1988 02-20-2010 03:58 AM

[Debian Testing] Apt pinning, Google Earth, Pulseaudio problems

I just reinstalled my Debian desktop machine. Some problems have risen which I didn't experienced before.
1) Lamaresh repository (Wine) doesn't update/upgrade/install anything
2) Pidgin is not installable
3) Google Earth is not showing a globe, the window stays black
4) The correct Pulseaudio channel can't be manipulated with the keyboard media keys

The details

1) The Wine repository worked perfectly before, so I don't know what is causing it. The error:

W: Failed to fetch  Hash Sum mismatch

E: Some index files failed to download, they have been ignored, or old ones used instead.

The GPG key is installed successfully, my sources.list:

###  Wine Repository  ###
deb squeeze main
# wget -O - | apt-key add -

2) I had to install my nvidia-kernel-source from the unstable branch, I guess some packages were installed which conflict with the pidgin dependencies now. I've pined my sources to testing by doing: echo 'APT::Default-Release "testing";' >/etc/apt/apt.conf.d/00defaultrelease. So testing and unstable aren't conflicting inherently.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  pidgin: Depends: libpurple0 (>= 2.6.0) but it is not going to be installed
E: Broken packages

A solution could be to install Pidgin from the unstable branch, but I don't want that. Is there a way to bypass this?

3) I installed Google Earth the googleearth-package, make-googleearth-package way. I successfully installed it and I also installed ia32-libs-gtk and lib32nss-mdns because I use amd64. But when I startup Google Earth there is no globe, it just stays black. It also stays black when I try to switch to the Mars or Sky view.

4) I installed Pulseaudio with all the necessary dependencies and configurations. But the channel which works (Digital Stereo Duplex (IEC958)) can't be manipulated with my volume control pad on my keyboard. It does however manipulate the Analog Stereo Duplex channel, but that one is mute. How can I force the gnome-volume-control or Pulseaudio to use the Digital Stereo Duplex (IEC958) channel instead of the mute one? The alsa-mixer is set to Pulseaudio. I configured /etc/asounc.conf and /etc/libao.conf to use Pulseaudio. Any thoughts?

The first two problems are probably due to my apt pinning configuration. First I used: # echo 'APT::Default-Release "testing";' >/etc/apt/apt.conf.d/00defaultrelease. To set the default release, but that doesn't work anymore. So I followed this tutorial. And I removed my previous apt pinning and created a new one in /etc/apt/preferences. Bellow is my configuration.


Package: *
Pin: release a=squeeze
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 690

Package: *
Pin: release a=unstable
Pin-Priority: 680

Package: *
Pin: origin
Pin-Priority: 670

Package: *
Pin: origin
Pin-Priority: 660

Package: *
Pin: origin
Pin-Priority: 650

System specs:
Creative Audigy 4
Repository up to date

AlucardZero 02-20-2010 09:26 AM

Post the entire contents of sources.list

Did you apt-get update?

craigevil 02-20-2010 10:17 AM

Squeeze is testing. Shames repo hasnt been maintained for over a year.

You might take a look at:
Howto: Set up and Maintain a Mixed Testing/Unstable System -

Keessince1988 02-22-2010 02:52 AM

@ Craigevil
That's true, but the squeeze repository of lamaresh is uptodate. The Testing repro was just version 1.

I also reinstalled my laptop. After that installation I added my custom sources.list en did an update first. Then I added my GPG keys. Now it works just fine, with the same pinning settings, etc.
I removed my GPG keys from my desktop, did an update, added them again, solved.

Now the only problems that remains are the Google Earth and the Pulseaudio problems. Anyone?

All times are GMT -5. The time now is 04:55 PM.