LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   DamnSmallLinux (https://www.linuxquestions.org/questions/damnsmalllinux-42/)
-   -   Would like to boot DSL by way of Grub the way I'm booting various PL OSs... (https://www.linuxquestions.org/questions/damnsmalllinux-42/would-like-to-boot-dsl-by-way-of-grub-the-way-im-booting-various-pl-oss-890645/)

Benny7440 07-08-2011 02:24 PM

Would like to boot DSL by way of Grub the way I'm booting various PL OSs...
 
1 Attachment(s)
I tried yesterday to boot DSL using the same scheme I'm using via Grub but it didn't work. After reading a thread here about the same issue I'm a little discouraged to try it again, at least not soon. Here it's what I have at the bootable folder (see attachment):

My menu.lst file has the following:
Quote:

# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Sun Jul 3 04:15:57 2011
#
# Start GRUB global section
timeout 20
color light-gray/blue black/light-gray
# End GRUB global section
# Other bootable partition config begins
# title Windows (on /dev/sda1)
# rootnoverify (hd0,0)
# makeactive
# chainloader +1
# Other bootable partition config ends
# Linux bootable partition config begins
title Puppy Linux 511 frugal in sda2 dir puppy511
rootnoverify (hd0,1)
kernel /puppy511/vmlinuz pmedia=atahd psubdir=puppy511
initrd /puppy511/initrd.gz
# Linux bootable partition config ends
# Linux bootable partition config begins
title Puppy Linux 525 frugal in sda2 dir puppy525
rootnoverify (hd0,1)
kernel /puppy525/vmlinuz pmedia=atahd psubdir=puppy525
initrd /puppy525/initrd.gz
# Linux bootable partition config ends
# Linux bootable partition config begins
title Puppy Studio frugal in sda2 dir puppystudio
rootnoverify (hd0,1)
kernel /puppystudio/vmlinuz pmedia=atahd psubdir=puppystudio
initrd /puppystudio/initrd.gz
# Linux bootable partition config ends
# Linux bootable partition config begins
title DSL frugal in sda2 dir dsl
rootnoverify (hd0,1)
kernel /dsl/linux24 pmedia=atahd psubdir=dsl/boot/isolinux
initrd /dsl/boot/isolinux/minirt24.gz
# Linux bootable partition config ends
# title Install GRUB to floppy disk (on /dev/fd0)
# pause Insert a formatted floppy disk and press enter.
# root (hd0,1)
# setup (fd0)
# pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/sda2)
root (hd0,1)
setup (hd0,1)
# pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)
Could it be associated with some file permissions? Location of DSL folder in relation to root?

Thanks in advanced for any help/hint provided!

linus72 07-09-2011 06:53 AM

your problems are:

1) put the kernel and initrd directly under / of the partition its in.
so grub menu.lst would be kernel "/linux24" etc

2) you have the wrong cheatcodes at the kernel line "pmedia=atahd psubdir=dsl/boot/isolinux" those are "Puppy" codes
Try:
Code:

kernel /linux24 ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=791 initrd=/minirt24.gz nomce noapic quiet BOOT_IMAGE=knoppix
initrd /minirt24.gz

see here
http://www.damnsmalllinux.org/wiki/i...hp/Cheat_Codes

Benny7440 07-10-2011 11:35 AM

Thank you, linus72. for your post! I changed the menu.lst file according to your info. All that awaits is testing it as soon as I'm done reading some emails & the Schumann Piano Concerto I'm hearing ends.

I'll post below the outcome of it, hopefully from DSL itself...

Benny7440 07-10-2011 01:40 PM

After trying what you suggested above DSL started to boot. I saw 2 penguins at the upper left corner of the screen & a few lines of text filling in the screen. After some secs there appears a note saying that the usb device isn't accepting new addrss's. Shortly after that it stops completely. The only way out of it is by pressing the Power button for a few secs for forcing the machine to restart.

It might have been useful to you to know how a got these DSL files. Many years ago I had a 64 MB MuVO MP3 Player from Creative, since it was holding just a few MP3 songs I regarded it as an amusement more than an MP3 Player gadget, so I decided to reformat it for testing a small linux distro (like DSL). I found somewhere in the web the iso file, extracted from an XP laptop the files within & transferred them to the device. After it booted up I started to play with it for a while &, probably, made some config changes to it (don't remember what).
The files I'm using now are taken from that device as they are. I must add to all this that with this notebook (VAIO VGN AR250G), even though according to some of its BIOS specs, it should support booting up from a usb device (& I know that in the original VAIO which I used to create it it booted up ok as well as in an eBuddy laptop --defuncted now) it starts to boot but never ends. Think I've used many options at boot time for facilitating it to boot but to no avail with this machine (with this BIOS, at least).

Since it refused to boot (1st time), I restarted PL 511 & from there moved all the files within isolinux folder to root & gave it another chance: with the same result (it said that there was a missing file). Then I decided to put the MuVo in the usb drive for it to be available to the booting process in case it was looking in a usb drive any file that now should be in the hdd @ root. It didn't work, either. The message at this trial was somehow different, but I'm having a problem with my screen that is putting me at a corner: a few months ago it appeared a black vertical field (about 1/6 of the width of the screen starting right at the center & to the right. About 4-5 days ago another field the same width appeared beside that one to the left of it. Both are covering from top to bottom the screen, although the last one isn't black; it's a dark milk + coffee color with a white narrow strip almost at its left side. I think that the screen is getting to its end of useful life. I've tried a "known" good crt screen as a 2nd monitor attached to a proper port but, even with the Power Button staying 'Green' (indicating info flowing from notebook to the screen) there appears nothing but blackness in the screen. I mention all this because I'm not able to see all the messages that appear at the screen while booting up, so can't even, sometimes, select with accuracy some alternatives with some menus.

From the above, I think that my most pressing issue now is obtaining a way of having a full screen, it doesn't matter if it's a 4:3 or 16:9; all that I need is a reasonable coverage of the useful info in the display. Sorry that the original issue branched to another in this way.

Benny7440 07-10-2011 02:17 PM

After inspecting the root of the booting device I noticed that there was a config file & deleted it & tried again with the same results. This time, though, I tried what appeared to be a nonworking shell & it worked. Only that this notebook has a problem with its keyboard & I've been using it with a usb Gateway keyboard & mouse (don't like the pads). The 1st times nothing got echoed to the screen if the Gateway keyboard is used, but the onboard keyboard 'works', somehow.

There it says the following:
"Can't find knoppix file system. Dropping you to a (very limited) shell. Press reset button to quit."

Only a few commands are available: lsmod, mount, etc..

What the "Can't find..." message means I don't know. Is it something related to the file system I'm using for the sda2 partition (ext3)?
What else that I can do & haven't done might be useful?


All times are GMT -5. The time now is 08:53 PM.