-   DamnSmallLinux (
-   -   kernel 2.6.21 in DSL 3.3 (

mhykgyver 05-10-2007 09:32 AM

kernel 2.6.21 in DSL 3.3
Hi ya' all...

First and foremost I do apologize for being too stubborn as I've read stuffs regarding DSL 3.3 and kernel 2.6's and should one insist in using 2.6 kernel in DSL just opt for DSL-N and all those stuff...the thing is, I love using DSL 3.3 and the fact that I can compile in DSL and not in DSL-N...most recently though, I've wanted to start toying with Solaris,NetBSD and OpenBSD using vmware but it says in DSL 3.3 that it can't compile the vmware module as the kernel was compiled using gcc 2.59.x and the current gcc dsl's 3.x...and so I decided to just upgrade the kernel, here was what I did:

1. downloaded and untarred kernel 2.6.21
2. patched kernel 2.6.21 for reiser4 support c"j) (so I could install Gentoo with reiser4 yet never made it to work, Gentoo in reiser4 i.e.)
3. compiled kernel using dsl-config (mod some of the choices for the modules et al though, no error)
4. renamed modules.conf to modules.conf.bak and did update-modules
5. booted machine (ok!)
a. first boot - looked for modules.dep
--deleted modules.conf, did update-modules and rebooted
b. second boot - no more errors but it froze after logging in
*after 2nd boot system freezed intermittently
I do know that what I did may be unsupported yet I do ask help to those who managed to get through the 2.6.21 compile and managed to make everything work without breaking the system...

BTW,after the 2.6.21 I re-installed DSL 3.3 and upgraded the kernel to 2.4.34 and never had any issues, everything worked flawless...but still, I have quite some sleepless nights trying to google my way through the internet searching for suitable answers to my 2.6.21 kernel upgrade issue and I give up and this is the last stop for me (for now though, after I finish LFS 6.2 I'll get back to it, equipped with more Linux internal knowledge....hehehehehe)

Oh, going back to my original vmware issue, after the 2.4.34 upgrade, I tried installing vmware and it still had the same issue, kernel was compiled using gcc 2.59.x and I gave up and opted to just study and use Xen or Qemu...

mhykgyver 05-14-2007 01:29 AM

Hi all...

Managed to make 2.6.20 work with DSL...just used the ubuntu kernel and voila! it worked, no issues at all after compiling it et al...Here was what I did...

1. booted xubuntu livecd, then ran apt-get install linux-source-2.6.20
2. copied linux-source-2.6.20.tar.bz2 from /usr/src to a spare partition (/dev/hda3)
3. booted DSL
4. extracted linux-source.tar.bz2 to /usr/src
-- mount /dev/hda3; tar -jxvpf /dev/hda3/linux-source-2.6.20.tar.bz2 -C /usr/src
5. ran 'menuconfig' and modified kernel entries
--cd /usr/src/linux-source-2.6.20; make menuconfig
*BTW, before running menuconfig make sure that ggc1-with-libs.dsl is loaded
6. ran 'make && make modules_install'
--copied bzImage and to /boot
--cp arch/i386/boot/bzImage /boot/kernel-2.6.20-DSL; cp /boot/
--cd /boot; rm; ln -s
7. updated system et al
--ldconfig; depmod -a; update-modules
8. rebooted system and voila!
*do have the same recurring issue though but system's fine nonetheless
--pcilib: cannot open /sys/bus/pci/devices
--module hit not found
--module mousedev not found
my next challenge is to make the apt system work...managed to make it work the first time, even updated libc6 and glibc without breaking the system...just copied update-rc.d into /sbin and added 'APT::Force-LoopBreak "true";' to /etc/apt/apt.conf yet couldn't do it the 2nd time...did everything from scratch then apt just can't detect APT::Force-Loopbreak in apt.conf...any ideas?


P.S. FYI, I also added the reiser4patch and compiled the system with reiser4 support, formatted one partition as reiser4 (compressed) and copied whole partition to it, modified /etc/fstab in the new partition,compiled new grub with reiser4 and DSL was running in reiser4...for details please refer to this excellent website for further details: ...

johnhamiltion 08-28-2007 10:01 PM

It has solved a few of my problems and I have learnt a lot.

Originally Posted by mhykgyver (Post 2747729)
...for details please refer to this excellent website for further details: ...

Thanks for pointing me to the really excellent website:

It has solved a few of my problems and I have learnt a lot.

East 02-26-2008 12:59 AM

No make found in DSL for kernel upgrade
hi all

I have downloaded the kernel and ihave DSL-N in my system. when i was trying to untar the kernel source. it is untarred fine but the size of the linux-kernel folder is just 560Bytes. I dont know why it is coming like this and when i typed make mrproper for kernel upgrade saying error as no make command found. I have seen in document that DSl-N uses gcc. But when i search for gcc in DSL, it is not found. I have installed DSL-N in SATA HDD using frugal-Grubinstall using LiveCD. should i install gcc package?

avangel 11-28-2011 05:52 AM

Experiences, updated instructions
I needed a (damn) small VM to install a proprietary java program, and then back up the whole VM, so I picked DSL.
First everything seemed OK, but when I run the program I got "FATAL: kernel too old" messages during running the Java program. I tried to fall back to an earlier Java version in the hope that it might solve the problem, but at least Java 5 was required, and I got the same problem even with JRE 1.5.0, so I needed to change to 2.6 kernel.
Then I found this thread about using DSL with 2.6 kernel. mhykgyver's instructions were detailed enough, so I started to follow that - with some alterations though.
I grabbed the latest 2.6 kernel ( from in the hope that it will also work. I was too naive! I ran into multiple problems trying to use that kernel, and through various sources I concluded that there are some changes in 2.6.23, which cause various problems with DSL.
Namely, the following problems:
- the kernel didn't even compile with the gcc that I downloaded for DSL (see later), (see ). The solution was, according to the tread, to disable the relocatable option: in "make menuconfig", "Processor type and features" -> at around the end of the list there is "Build a relocatable kernel".
- then when I finally managed to build it, it was not compatible with the grub in DSL. ("No setup signature found..."). It was mentioned at that it appears at upgrading to 2.6.23.
- after upgrading to grub2, it still did not work, had some trouble with, and it also appears at 2.6.23 (I have no link for this info, sorry).
So I downloaded kernel 2.6.22, and finally I could make it work.

Here are the updated instructions:

- If using DSL in VM it's worth to create a snapshot here (e.g. if something goes wrong or if you don't want to keep gcc on the filesystem). I also created and mounted another virtual disk for the temporary files (to download stuff there, to compile the kernel there, so my first virtual hard disk will not be bloated (I want to export that after the end to a .ova file). This should be done independent (not included in the snapshot, I am using VMware ESXi for virtualization). Or maybe it could be a network mount (didn't try that).
- Install gcc to DSL. I got problems using MyDSL (see the icon on the desktop) behind a HTTP proxy, but I found a DSL forum post ( and I was able to download the required .dsl packages manually:
- go to,
- download gcc1.dsl or gcc1-with-libs.dsl (I chose the latter, it was only a bit bigger, but the former should be also OK for compiling the kernel, according to the descrtiption) and gnu-utils.dsl
- install them (I don't know where I found this tip):
sudo mydsl-load gnu-utils.dsl
sudo mydsl-load gcc1-with-libs.dsl
- download linux-2.6.22.tar.bz2 from
- uncompress it (I just used: tar -jxvpf /dev/hda3/linux-source-2.6.22.tar.bz2)
- cd linux-2.6.22
- Then basically follow the kernel README:
- make mrproper (I guess it's not needed for the first run)
- make menuinstall (here I left everything on the default)
- make
- At this stage you may revert the VM to the snapshot to undo the GCC installation (if you don't need that anymore). You may want to create another snapshot before doing this. Actually I didn't try it yet.
- make modules_install
- make install (I didn't understand why mhykgyver did this manually.)
- Edit /boot/grub/menu.lst. Here I just copied the entry "DSL" changed the title to "DSL with kernel 2.6.22" and changed the kernel from "/boot/linux24" to "/boot/vmlinuz-2.6.22"
- Reboot and have fun using the new kernel.

All times are GMT -5. The time now is 09:49 PM.