-   DamnSmallLinux (
-   -   GRUB text is the only thing I see after installing to HD (

tgp1994 11-21-2009 09:21 AM

GRUB text is the only thing I see after installing to HD
Hi there everyone. I've been having a heck of a time since DSL has apparently taken extreme and unnecessary measures to keep spammers out, so I hope there are some people here who can help.

Here is some information before I go further into my problem:
  • Running DSL in: VMWare Workstation
  • Host OS: Windows XP Home SP3
  • Installing to: Virtual IDE Hard drive in VMWare

If you need any more info, please ask.

So here's what happened:

I managed to format the drive correctly, (it turns out that SATA does not work very well), and it ran the automated install procedure, and got everything copied over. I then had it install GRUB, with no problems accounted for, then it said I needed to reboot my computer to finish the changed. I assumed that I should have the drive being booted from first, so I set it to first priority in the BIOS, then booted. I wait, the word GRUB appears, then that's it. It just sits there, with GRUB on the screen.

If anyone has any explanation for how to fix this, than that would be great.



linus72 11-21-2009 10:21 AM

I would say there is no menu.lst in /boot/grub
have a lokk and see if its there?

tgp1994 11-21-2009 11:10 AM


Originally Posted by linus72 (Post 3764993)
I would say there is no menu.lst in /boot/grub
have a lokk and see if its there?

Thank you very much for your reply. There actually is a menu.lst in the place you specified, and it seems to be formatted ok. Any other ideas?

tgp1994 11-21-2009 12:20 PM

Ok, now I'm having another problem. I'm following this installation guide to the letter, but when I try to create a swap file on the hda1 swap partition I made, it comes back with an error saying "/dev/hda1/: Not a directory." Any ideas?

linus72 11-21-2009 12:59 PM

It may be that you need to install a newer version of Grub to the MBR of your setup
Many of my DSL installs went awry due to DSL using an older Grub

Try running a new Linux Livecd/usb and re-install new Grub to MBR and see what happens?

tgp1994 11-21-2009 02:13 PM

It actually turns out that I was not formatting it right. I tried using a differnt LiveCD with a gui partitioner, and not being sure what table format or w/e I should use for the virtual hd, I went with something other that msdos. So I set it to MSDOS, did what I needed to do, and everything worked fine. THEN, I ran into issues with perl not being up to date, so I tried to remove perl-base, and that pretty much screwed me over big time.

My conclusion here is to use something else, particularly something that has an active community.

Thank you anyways for your help.

P.S. What would be another good linux distro that is fairly small? Maybe <100 MB?

linus72 11-21-2009 02:37 PM

You mean in a virtual environs?

I always wanted to make one that would run as fast as DSL full install to vhd
but haven't seen one yet...

I would say a Debian minimal install or Slack 13 maybe?

However; I'm guessing you mean a "frugal" type install
like DSL at 50MB?

Maybe a puppy?

tgp1994 11-21-2009 06:55 PM

Ya, I'm actually giving puppy a try right now. You wouldn't happen to know if there are alternate terminals for it, would you? I don't like the one it comes with.

All times are GMT -5. The time now is 12:41 PM.