LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > DamnSmallLinux
User Name
Password
DamnSmallLinux This forum is for the discussion of DamnSmallLinux.

Notices


Reply
  Search this Thread
Old 05-08-2006, 06:13 PM   #1
Adamant1988
Member
 
Registered: Apr 2006
Distribution: Suse 10.2, Ubuntu Feisty Fawn
Posts: 74

Rep: Reputation: 15
Cannot find CD in DSL


I installed DSL to my old laptops hard drive, and I'd like to take a picture off of a CD but it's telling me I don't ahve access to the files...
I did 'su root' but it didn't give me access
 
Old 05-09-2006, 10:58 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
if you wish to get root rights, you just do

Code:
su
without any specific username (well, I'm not sure if it matters, actually). if you wish to run a command as root, instead, just run

Code:
su commandname
and put the command you want to run in place of commandname in the above example. after you run that command, "su" asks for your own password to run the command. an example:

Code:
su mount /dev/cdrom /mnt/cdrom
Password:
would mount a cd, after you gave your password, if you had a directory /mnt/cdrom created and the cd device file was /dev/cdrom.

if you mount some device (a cdrom) as root, you probably can only access it as root, because it's mounted with root privileges only. an option is to change the permissions so normal users can use the device too, or then mount as a normal user. both need you to alter some configurations, maybe; either add some user to a group that has access to the mount command (usually the group is called mount) or then edit the fstab file (where the mountable filesystems are configured) and add there usermask.

To add the usermask: open /etc/fstab as root, locate the line where it says something about your cdrom (the line probably starts with /dev/cdrom or something similar) and at the 4th column, where the options are, add a dot and "umask=0222"; an example: if the line would be

/dev/cdrom /mnt/cdrom auto defaults 0 0

then you would change it to this:

/dev/cdrom /mnt/cdrom auto defaults,umask=0222 0 0

and it should work. another way around is to try and add your user to the mount-group:

Code:
sudo useradd -G mount
and then re-try to mount the cdrom:

Code:
mount /mnt/cdrom
(if your cdrom is mounted into some other place than /mnt/cdrom, change that accordingly)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Loaded DSL - unable to boot DSL, only win98 freykatt Linux - Newbie 3 04-10-2007 09:00 PM
D-Link DSL-200 Rev B DSL modem -- success!! ludeKing Linux - Hardware 1 03-11-2007 06:32 PM
Dsl Modem Installation -- Aztech Dsl Turbo 100 psganesh Linux - Networking 0 07-01-2004 02:04 AM
DHCP cannot find D-Link DSL-300G+ reclusivemonkey Linux - Networking 25 10-24-2003 12:25 PM
DSL/ Linksys DSL Router/ Linux cant see the network... Robert0380 Linux - Networking 9 04-03-2002 04:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > DamnSmallLinux

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration