-   DamnSmallLinux (
-   -   Asus eee pc 900a WiFi/Ethernet (

a10112 12-02-2008 08:41 PM

Asus eee pc 900a WiFi/Ethernet
i'm trying to connect DSL to my password protected WiFi connection but i don't know how. i have a LinkSys WRT54G2 54mbps.

any ideas ?

on a side note: anyone know how to make an Asus Eee pc 900a boot from a flash drive by default or by option ?

pwc101 12-04-2008 05:22 AM

If memory serves, to connect to a wireless network, you need to select the Internet tab, then there should be an icon called Wireless Networks, click on this, and then search for the appropriate access point (your wireless router), then click connect. It'll ask you for the passphrase the first time you connect; enter this, and then you should be away.

Changing the boot order requires you to enter the BIOS (Basic Input/Output System) and change the boot order to have USB before the internal SSDs (Solid State Disks, or Flash drives as they're often called). See here for instructions on booting from an SD card (as opposed to a USB flash drive); the part on changing the boot order is what you want to look into.

a10112 12-04-2008 08:46 PM

i can't seem to find a 'internet' tab... i found a 'net' tab... but it didn't have what you described.
i will be trying to configure BIOS soon, if not now.

pwc101 12-05-2008 03:55 AM

Your EeePC should look like this when you turn it on:

As you can see, it's open on the Internet tab, and there is an icon called Wireless Networks. At least there was on mine, until I installed eeebuntu on it.

a10112 12-05-2008 04:15 PM

unfortunately, i've dropped the Xandros-like OS. it has a faulty eeebuntu copy on the SSD thing. trying to boot from DSL atm. any ideas if i can edit BIOS from within DSLinux or go to BIOS ?

a10112 12-06-2008 01:06 PM

ok, i've gotten into BIOS by hittin F2 when the asus splash screen comes up. anybody have a screeny of what the bios should look like when booting from a USB device ?

pwc101 12-06-2008 02:35 PM

Here's mine set to boot from USB disk:

a10112 12-07-2008 07:10 PM

odd... you must have a different Asus eee computer than mine. i'm not getting the 'atapi CD-ROM' option. i get my 'geek squad usb device' as an option so i replaced the CD-ROM one with it but it still attempts to boot from SSD.

pwc101 12-08-2008 04:36 AM

Are you sure your USB stick is bootable? It might be trying to boot from it, but isn't able to do so, so it carries on through the boot options. Try booting another machine off the USB stick, if you have one available.

To be honest, I've never managed to boot anything from USB, be it an SD card or a USB stick. It must be possible though! ;)

bcostacurta 12-10-2008 07:09 AM

Concerning the Asus Eee 900 the BIOS indicates 'Removable Dev' (as a picture posted in this thread shows) which is quite unprecise : is it USB-HDD, UDB-FDD or USB-Zip ?

Same problem here : I never achieve any boot from any USB key on my Asus Eee 900 and I suspect USB-xxx not compatible with the different live keys I tried.
My DSL Live Key boots fine on my IBM Lenovo with BIOS set to 'USB-HDD'

Maybe worth to mention that the Debian Eee image boots fine from an USB key build via a command dd.
More on this on


dunbar 05-16-2009 08:14 PM

Asus EeePC 900A
I also had a bit of difficulty with my Linux based 4Gb SSD EeePC 900A. The EeePC 900A BIOS settings screen uses unconventional information messages. I am using (and talking about) BIOS version 0703. This might not sound very clear, read it a few times before getting upset at me.

I have ultimately learned that in order to boot the EeePC 900A from anything other than the internal SSD, you have to do one thing in the BIOS AND a second thing later.

Here is why I say this. when the EeePC 900A BIOS setup screen says "removable devices", it REALLY should be saying "allow user to activate a menu of known bootable devices when booting".

That will set you up so you can be allowed to activate a popup menu which shows (any currently inserted) (bootable) removable devices; the BIOS tells you this by saying to "Press ESC to display BBS popup". So, to boot a removable device, press the ESC key when you see the BIOS screen! KEEP READING! You have to press the ESC key during boot and THEN you select from devices which were already inserted. Yes, pressing the ESC key gives you a menu to decide WHICH removable device (USB, SD card, etc.), but before the system can use any device, it must have been inserted before the BIOS started. Meaning you need to insert the boot device before turning on the EeePC 900A system.

Summary: In this order:
The BIOS is set to boot removable devices (press F2 when booting, modify: boot -> boot device -> boot device priority so you boot removable devices first, save the new BIOS settings);
The system is not already booting or rebooting;
The bootable removable device is inserted (best practice: insert a bootable removable device before pressing your power button);
As it boots, you press ESC to see the 'BBS popup' menu;
In that popup menu you will see any devices which the BIOS thinks it can boot from, including the internal drive.
If you do not see your bootable device which you know is bootable, leave it inserted and press ctrl-alt-delete to try once more. If that doesn't show the device, sorry, This is where everything I've tried has always booted, if it was really bootable. I just tested, I am sure that quiet boot and quick boot settings makes no difference for ME.


All times are GMT -5. The time now is 09:57 AM.