LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   DamnSmallLinux (https://www.linuxquestions.org/questions/damnsmalllinux-42/)
-   -   [DSL] USB-Drive not mounting and Keyboard has no special characters (https://www.linuxquestions.org/questions/damnsmalllinux-42/%5Bdsl%5D-usb-drive-not-mounting-and-keyboard-has-no-special-characters-537903/)

polemon 03-15-2007 11:47 PM

[DSL] USB-Drive not mounting and Keyboard has no special characters
 
Hi!

I got my hands on an old 1998 Laptop.
This Toshiba Satellite 310CDS features a 200MHz Intel P2 chip and 32MB RAM.

I installed DSL on the 5.5GB harddrive of this Machine, and it works well for most of the time...

Yet two things are bothering me:

1. I can't mount USB-Sticks, even though the required modules are loaded, ldusb shows up the correct device.

the info that dmesg yields looks promising it:
Code:

hub.c: new USB device 00:0b.0-1 assigned address 2
usb.c: USB device 2 (vend/prod 0xea0/0x2168) is not claimed by any active driver.
Initializing USB Mass Storage driver...
usb.c: registering new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
  Vendor: USB      Model: Flash Disk        Rev: 2.00
  Type:  Direct-Accrdd                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
sda: Unit Not Ready, sense:
Current 00:00: sns = 70  6
ASC=28 ASCQ= 0
Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x28 0x00 0x00 0x00 0x00 0x00
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Current sd00:00: sns =70  6
ASC=28 ASCQ= 8
Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x28 0x00 0x00 0x00 0x00 0x00
sda : block size assumed to be 512 bytes, disk size 1GB.
 sda: sda1 sda2 sda3 sda4
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.
scsi singledevice 1 0 0 1
scsi singledevice 1 0 0 2
scsi singledevice 1 0 0 3
scsi singledevice 1 0 0 4
scsi singledevice 1 0 0 5
scsi singledevice 1 0 0 6


Yet, i can't mount is using mount /dev/sda1 /mnt/sda1.

when i issue the command, i get a
'mount: /dev/sda1 is not a calid block device' error.

could anyone help?

The other annoying thing, is my non-funktional keyboard -layout, but i think i can fix that with xmodmap.

please help

--polemon

polemon 03-17-2007 10:54 PM

I fixed the keyboard problem, by selecting the de-latin1 keymap.

So now I've got my back, but my USB-Drive is still not mounting...

Jon Briggs 03-24-2007 07:08 PM

I too want to install DSL on a flash drive, mainly for recovering peoples data and running hardware diagnostics.

Anyway i followed the guide in the DSL wiki:-

http://www.damnsmalllinux.org/wiki/i...SB_Flash_Drive

I decided to try it form windows as it seemed more straight forward. I formatted my flash drive to fat32 using FORMAT G: /fs:FAT32 and ran the DSL boot installer \win32\syslinux.exe g: to create a mbr. It then says to download the DSL embedded.zip file and extract it to the flash drive.

So i did all that but it still doesn't boot? My pc can boot to usb flash drives it has the options in the bios and i have booted to my flash drive before when formatted in DOS. So what am i doing wrong?

polemon 04-01-2007 09:21 PM

Hmm, that was not exactly what I ment, but I got it working afterall.
This is what I did:

All that needs to be done, is loading the usb-storage module.
Code:

# modprobe usb-storage
And it works fine.

Well, not exactly _perfect_ but it works fine, in the sense, you can mount those devices quite easily.

I've tested it not only with my USB-Stick but also my portable MP3-Player, both work.

However, one thing still remains a mystery: I added that modules into /etc/modules, but the system does not load that module anyway...

Seems the Koppix-esque autoconfiguration borked the standard directives...

Cheers,

--polemon


All times are GMT -5. The time now is 12:07 PM.