LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS
User Name
Password
CentOS This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices


Reply
  Search this Thread
Old 10-11-2017, 08:25 PM   #1
jrgilmer@yahoo.com
LQ Newbie
 
Registered: Oct 2017
Posts: 2

Rep: Reputation: Disabled
Question Yum update gives lib conflicts for libX11 and libxcb


I'm running yum update and get conflicts with libs. System is running fine, I just want to get it updating with no errors

Background:
-Production db server
-Not a VM
-Repos are on spacewalk server

See below output what I have tried so far.

Here is the output:
[root@xxxxprddb3 tmp]# yum update
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Update Process
Loading mirror speeds from cached hostfile
* base: mirrors.vpsie.com
* extras: mirror.compevo.com
* updates: repos.forethought.net
Resolving Dependencies
--> Running transaction check
---> Package cpp.x86_64 0:4.4.7-11.el6 will be updated
---> Package cpp.x86_64 0:4.4.7-18.el6 will be an update
---> Package gcc.x86_64 0:4.4.7-11.el6 will be updated
---> Package gcc.x86_64 0:4.4.7-18.el6 will be an update
---> Package gcc-c++.x86_64 0:4.4.7-11.el6 will be updated
---> Package gcc-c++.x86_64 0:4.4.7-18.el6 will be an update
---> Package gcc-gfortran.x86_64 0:4.4.7-11.el6 will be updated
---> Package gcc-gfortran.x86_64 0:4.4.7-18.el6 will be an update
---> Package glibc.x86_64 0:2.12-1.149.el6_6.9 will be updated
---> Package glibc.x86_64 0:2.12-1.209.el6_9.2 will be an update
---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.9 will be updated
--> Processing Dependency: glibc-common = 2.12-1.149.el6_6.9 for package: glibc-2.12-1.149.el6_6.9.i686
---> Package glibc-common.x86_64 0:2.12-1.209.el6_9.2 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.9 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.209.el6_9.2 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.9 will be updated
--> Processing Dependency: glibc-headers = 2.12-1.149.el6_6.9 for package: glibc-devel-2.12-1.149.el6_6.9.i686
---> Package glibc-headers.x86_64 0:2.12-1.209.el6_9.2 will be an update
---> Package jasper-libs.x86_64 0:1.900.1-16.el6_6.3 will be updated
---> Package jasper-libs.x86_64 0:1.900.1-21.el6_9 will be an update
---> Package libX11.x86_64 0:1.6.0-2.2.el6 will be updated
---> Package libX11.x86_64 0:1.6.4-3.el6 will be an update
---> Package libX11-common.noarch 0:1.6.0-2.2.el6 will be updated
--> Processing Dependency: libX11-common = 1.6.0-2.2.el6 for package: libX11-1.6.0-2.2.el6.i686
---> Package libX11-common.noarch 0:1.6.4-3.el6 will be an update
---> Package libXext.x86_64 0:1.3.2-2.1.el6 will be updated
---> Package libXext.x86_64 0:1.3.3-1.el6 will be an update
---> Package libXfixes.x86_64 0:5.0.1-2.1.el6 will be updated
---> Package libXfixes.x86_64 0:5.0.3-1.el6 will be an update
---> Package libXft.x86_64 0:2.3.1-2.el6 will be updated
---> Package libXft.x86_64 0:2.3.2-1.el6 will be an update
---> Package libXi.x86_64 0:1.7.2-2.2.el6 will be updated
---> Package libXi.x86_64 0:1.7.8-1.el6 will be an update
---> Package libXrandr.x86_64 0:1.4.1-2.1.el6 will be updated
---> Package libXrandr.x86_64 0:1.5.1-1.el6 will be an update
---> Package libXrender.x86_64 0:0.9.8-2.1.el6 will be updated
---> Package libXrender.x86_64 0:0.9.10-1.el6 will be an update
---> Package libXtst.x86_64 0:1.2.2-2.1.el6 will be updated
---> Package libXtst.x86_64 0:1.2.3-1.el6 will be an update
---> Package libgcc.x86_64 0:4.4.7-11.el6 will be updated
---> Package libgcc.x86_64 0:4.4.7-18.el6 will be an update
---> Package libgfortran.x86_64 0:4.4.7-11.el6 will be updated
---> Package libgfortran.x86_64 0:4.4.7-18.el6 will be an update
---> Package libgomp.x86_64 0:4.4.7-11.el6 will be updated
---> Package libgomp.x86_64 0:4.4.7-18.el6 will be an update
---> Package libstdc++.x86_64 0:4.4.7-11.el6 will be updated
---> Package libstdc++.x86_64 0:4.4.7-18.el6 will be an update
---> Package libstdc++-devel.x86_64 0:4.4.7-11.el6 will be updated
---> Package libstdc++-devel.x86_64 0:4.4.7-18.el6 will be an update
---> Package libxcb.x86_64 0:1.9.1-2.el6 will be updated
---> Package libxcb.x86_64 0:1.12-4.el6 will be an update
---> Package nscd.x86_64 0:2.12-1.149.el6_6.9 will be updated
---> Package nscd.x86_64 0:2.12-1.209.el6_9.2 will be an update
--> Processing Conflict: libX11-1.6.4-3.el6.x86_64 conflicts libxcb < 1.9.1-3
--> Finished Dependency Resolution
Error: Package: libX11-1.6.0-2.2.el6.i686 (installed)
Requires: libX11-common = 1.6.0-2.2.el6
Removing: libX11-common-1.6.0-2.2.el6.noarch (@base)
libX11-common = 1.6.0-2.2.el6
Updated By: libX11-common-1.6.4-3.el6.noarch (base)
libX11-common = 1.6.4-3.el6
Available: libX11-common-1.6.3-2.el6.noarch (xxxx_centos6_base)
libX11-common = 1.6.3-2.el6
Error: libX11 conflicts with libxcb-1.9.1-2.el6.i686
Error: Package: glibc-2.12-1.149.el6_6.9.i686 (installed)
Requires: glibc-common = 2.12-1.149.el6_6.9
Removing: glibc-common-2.12-1.149.el6_6.9.x86_64 (@updates)
glibc-common = 2.12-1.149.el6_6.9
Updated By: glibc-common-2.12-1.209.el6_9.2.x86_64 (updates)
glibc-common = 2.12-1.209.el6_9.2
Available: glibc-common-2.12-1.192.el6.x86_64 (xxxx_centos6_base)
glibc-common = 2.12-1.192.el6
Available: glibc-common-2.12-1.209.el6.x86_64 (base)
glibc-common = 2.12-1.209.el6
Available: glibc-common-2.12-1.209.el6_9.1.x86_64 (updates)
glibc-common = 2.12-1.209.el6_9.1
Error: Package: glibc-devel-2.12-1.149.el6_6.9.i686 (installed)
Requires: glibc-headers = 2.12-1.149.el6_6.9
Removing: glibc-headers-2.12-1.149.el6_6.9.x86_64 (@updates)
glibc-headers = 2.12-1.149.el6_6.9
Updated By: glibc-headers-2.12-1.209.el6_9.2.x86_64 (updates)
glibc-headers = 2.12-1.209.el6_9.2
Available: glibc-headers-2.12-1.192.el6.x86_64 (xxxx_centos6_base)
glibc-headers = 2.12-1.192.el6
Available: glibc-headers-2.12-1.209.el6.x86_64 (base)
glibc-headers = 2.12-1.209.el6
Available: glibc-headers-2.12-1.209.el6_9.1.x86_64 (updates)
glibc-headers = 2.12-1.209.el6_9.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Here is what I have tried:
-I have done a yum clean all, rerun, same result

-I tried the skip-broken... as expected, didn't work

-rpm -Va --nofiles --nodigest (gave no output)

-I ran the package-cleanup:
[root@xxxxprddb3 tmp]# rpm -qa |grep yum-utils
yum-utils-1.1.30-40.el6.noarch

[root@xxxxprddb3 tmp]# package-cleanup --problems
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
No Problems Found

[root@xxxxprddb3 tmp]# package-cleanup --dupes
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.

[root@xxxxprddb3 tmp]# package-cleanup --cleandupes
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
No duplicates to remove
-I made sure /etc/yum.conf had exactarch=1, it already did

-I tried downgrading:
[root@xxxxprddb3 tmp]# yum downgrade libX11.i686 libX11.x86_64
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Downgrade Process
Loading mirror speeds from cached hostfile
* base: mirrors.vpsie.com
* extras: mirror.compevo.com
* updates: mirror.steadfast.net
Only Upgrade available on package: libX11-1.6.3-2.el6.x86_64
Nothing to do
-If I ask yum to remove either libX11 or libxcb, they have tons of dependent packages... if I narrow to a specific arch, it lowers the dependencies... but I'm not feeling warm and fuzzy doing this in prod...since it isn't a vm... can't rollback as easy

-I have considered pairing down spacewalk repos, in case the conflict is because of this, but would prefer to leave as is.

I have scoured google and nothing suggested has resolved it.

Any help would be appreciated.

Last edited by jrgilmer@yahoo.com; 10-11-2017 at 08:27 PM. Reason: Add info
 
Old 10-11-2017, 10:50 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 14,614
Blog Entries: 24

Rep: Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051Reputation: 4051
This thread might be relevant: https://www.linuxquestions.org/quest...rs-4175614800/
 
Old 10-11-2017, 10:52 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,421

Rep: Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590
Quote:
This system is receiving updates from RHN Classic or Red Hat Satellite.
and you have CentOS repo installed

you CAN NOT DO THAT

"xxxx_centos6_base" is INCOMPATIBLE with the redhat repos

cent uses version numbers that ARE LARGER!!!! than the redhat versions
-- for a reason

to allow migration from a UNregistered rhel install to a CentOS install

remove / uninstall EVERYTHING installed from the cent repo
( might be near impossible to do )

what you have is a "Frankenstein'ed install "
bits of two OS's installed and MIXED

the easiest and fastest fix is to reinstall the OS
and PAY for the required redhat license ( there is a $49/year self support license )
or install CentOS 7.4 ( unless you MUST use the older CentOS 6.9

Last edited by John VV; 10-11-2017 at 10:57 PM.
 
Old 10-12-2017, 01:08 PM   #4
jrgilmer@yahoo.com
LQ Newbie
 
Registered: Oct 2017
Posts: 2

Original Poster
Rep: Reputation: Disabled
Very much appreciate you guys jumping in and replying so quick.
-In the other thread, they removed libgpod and all was well... I don't have that installed. As I mentioned, I have contemplated removing packages, but wanted to see if I can resolve without doing so as the dependencies are long.

-This is not a redhat install, it is a CentOS 6 install

[root@xxxxprddb3 ~]# uname -a
Linux xxxxprddb3.xxxxxxxxx.com 2.6.32-696.13.2.el6.x86_64 #1 SMP Thu Oct 5 21:22:16 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@xxxxprddb3 ~]# cat /etc/centos-release
CentOS release 6.9 (Final)

The reason it states "or Red Hat Satellite." is due to the spacewalk server usage... spacewalk being the free version of satellite .. they don't change the text.


Quote:
Originally Posted by John VV View Post
and you have CentOS repo installed

you CAN NOT DO THAT

"xxxx_centos6_base" is INCOMPATIBLE with the redhat repos

cent uses version numbers that ARE LARGER!!!! than the redhat versions
-- for a reason

to allow migration from a UNregistered rhel install to a CentOS install

remove / uninstall EVERYTHING installed from the cent repo
( might be near impossible to do )

what you have is a "Frankenstein'ed install "
bits of two OS's installed and MIXED

the easiest and fastest fix is to reinstall the OS
and PAY for the required redhat license ( there is a $49/year self support license )
or install CentOS 7.4 ( unless you MUST use the older CentOS 6.9
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum update conflicts when there is both i386 and x86_64 rpm packages installed. zimon Fedora 2 10-09-2008 06:30 AM
/usr/X11R6/lib/libX11.so: undefined reference to `__ctype_toupper mathimca05 Linux - Newbie 1 12-17-2007 04:16 AM
yum update problem with file /usr/lib/libpcsclite.so.1.0.0 admir330 Linux - Newbie 3 01-11-2007 04:55 PM
yum update, error: kernel conflicts with udev branque Fedora 6 02-23-2006 02:12 PM
FC3, 64-bit multilib, with many yum update conflicts sgl Fedora 2 06-04-2005 09:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS

All times are GMT -5. The time now is 01:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration