LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS
User Name
Password
CentOS This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices


Reply
  Search this Thread
Old 01-10-2017, 09:53 AM   #1
jwpaine
LQ Newbie
 
Registered: Oct 2011
Posts: 6

Rep: Reputation: Disabled
Incorrect dependencies in epel when installing package


Hello. I am running CentOS release 6.8

Attempting to install the package 'x2goserver' but the package manager complains about incorrect dependencies found. Do I have the wrong epel? How would I be able to best resolve this conflict?

Thank you!

Quote:
sudo yum install x2goserver

results in....

Error: Package: nxagent-3.5.0.32-3.el6.x86_64 (epel)
Requires: libXcompshad.so.3()(64bit)
Available: libXcompshad-3.5.0.32-3.el6.x86_64 (epel)
libXcompshad.so.3()(64bit)
Available: libXcompshad3-3.5.0.32-0.0x2go1.1.git20161216.734.main.el6.x86_64 (x2go-release-epel)
libXcompshad.so.3()(64bit)
Available: nx-3.5.0-2.1.el6.centos.x86_64 (C6.6-extras)
libXcompshad.so.3()(64bit)
Available: nx-3.5.0-2.2.el6.centos.x86_64 (C6.6-extras)
libXcompshad.so.3()(64bit)
Error: Package: nxagent-3.5.0.32-3.el6.x86_64 (epel)
Requires: libXcomp.so.3()(64bit)
Available: libXcomp-3.5.0.32-3.el6.x86_64 (epel)
libXcomp.so.3()(64bit)
Available: libXcomp3-3.5.0.32-0.0x2go1.1.git20161216.734.main.el6.x86_64 (x2go-release-epel)
libXcomp.so.3()(64bit)
Available: nx-3.5.0-2.1.el6.centos.x86_64 (C6.6-extras)
libXcomp.so.3()(64bit)
Available: nx-3.5.0-2.2.el6.centos.x86_64 (C6.6-extras)
libXcomp.so.3()(64bit)
Error: Package: nxagent-3.5.0.32-3.el6.x86_64 (epel)
Requires: libXcompext.so.3()(64bit)
Available: libXcompext-3.5.0.32-3.el6.x86_64 (epel)
libXcompext.so.3()(64bit)
Available: libXcompext3-3.5.0.32-0.0x2go1.1.git20161216.734.main.el6.x86_64 (x2go-release-epel)
libXcompext.so.3()(64bit)
Available: nx-3.5.0-2.1.el6.centos.x86_64 (C6.6-extras)
libXcompext.so.3()(64bit)
Available: nx-3.5.0-2.2.el6.centos.x86_64 (C6.6-extras)
libXcompext.so.3()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
 
Old 01-10-2017, 01:03 PM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,585
Blog Entries: 15

Rep: Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537Reputation: 1537
It appears to be saying you're missing dependencies that are found in a repository called C6.6-extras rather than epel itself. Do you have that C6.6-extras repository configured in addition to EPEL?
 
Old 01-10-2017, 02:39 PM   #3
jwpaine
LQ Newbie
 
Registered: Oct 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Disabling The C6.6-extras repo fixed the issue. Apparently the packages that I needed were in more than one repo and it was taking one over the other -- why yum couldn't figure this out on is own is beyond me

Last edited by jwpaine; 01-10-2017 at 02:57 PM.
 
1 members found this post helpful.
Old 01-10-2017, 05:11 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,412

Rep: Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589Reputation: 2589
yum could not figure it out because YOU set it so that it could not

i am guessing that the 6.6 is the OLD unsupported cent 6.6 extra updates that have not been updated in years

also for cent6 you really DO NEED to have "yum-priorites" installed and CONFIGURED
please see the cent wiki
https://wiki.centos.org/AdditionalRe...s/Repositories

there is a link to the Priorities plugin on that page
https://wiki.centos.org/PackageManag...Yum/Priorities
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adcli rpm package not available for centos6 from epel-release repository rahul.buragohain Linux - Software 8 05-23-2016 12:00 PM
package not found(while installing these dependencies in ubuntu gail-3.0,autopoint) ahmed12345 Ubuntu 11 11-21-2012 06:34 AM
Solaris installing package dependencies check? LinuxLover Solaris / OpenSolaris 2 02-22-2009 05:51 PM
Failed dependencies /bin/sh, libc.so.6... when installing rpm package Vilenjak Linux - Newbie 4 03-19-2007 07:08 PM
installing package without dependencies check noir-gel Linux - General 2 03-03-2003 09:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS

All times are GMT -5. The time now is 04:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration