LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS
User Name
Password
CentOS This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices


Reply
  Search this Thread
Old 09-18-2018, 02:01 PM   #1
bpb21
LQ Newbie
 
Registered: Jul 2018
Distribution: Debian, CentOS, Slackware, Ubuntu
Posts: 5

Rep: Reputation: Disabled
CentOS 7 XenServer 7.6 performing post-installation setup tasks...


I'm trying to install the latest CentOS 7 (1804 build) on the latest XenServer 7.6 hypervisor.
I'm selecting the minimal install, no security policy, I mean bare minimum. It installs fairly quickly but at the end it hangs on "performing post-installation setup tasks).
The install doesn't exactly "hang" per se; I can see the CPUs assigned to the VM fluctuating around 50%. Network usage is pretty low and disk usage is pretty low. The CentOS install screen graphics are still functioning (the cursor wheel thing is spinning).

What are these post-installation tasks?! They've been running for an hour on my latest attempt with no slacking off in sight. I can't ssh into the installation. I've tried rebooting at this point, but upon reboot it claims to have booted from hard disk and then stops.

Is there another module I need to select during installation to get this to complete? I've tried the CentOS 7 1804 Minimal install iso and the NetInstall iso and both have produced the same results.

I've also got CentOS 7 running on a couple XenServer 7.6 servers, so I konw it's possible.

Anyone else run into this issue?
 
Old 09-18-2018, 03:04 PM   #2
bpb21
LQ Newbie
 
Registered: Jul 2018
Distribution: Debian, CentOS, Slackware, Ubuntu
Posts: 5

Original Poster
Rep: Reputation: Disabled
Finally finished...

It finally finished about at least an hour and a half. I'm curious why performance is so poor, at least initially, but I don't know how far I'll get investigating that as long as it works normally from here on out.
If anyone has any insight into the initial installation, or tuning it afterwards, feel free to post.
Otherwise, I'm going to say this was solved by just sticking it out!
 
Old 11-20-2018, 12:53 AM   #3
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Rep: Reputation: 22
I didn't know Xen is still around. I thought I was the only one who messed with it or even heard of it.

Maybe time to consider OpenStack though.

Look around in /var/log/anaconda .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware “Clean Upgrade” (with pre- and post-installation tasks) Lufbery Slackware 8 01-16-2013 03:59 AM
Slack+Fluxbox - Post Installation Tasks? Dr.Paneas Slackware 9 06-01-2011 11:51 PM
performing tasks on a list of IPs dnoy Programming 4 03-25-2011 12:32 PM
LXer: Performing Basic Tasks with MySQL 4.1 and Above, using mysqli with ... LXer Syndicated Linux News 0 07-02-2006 09:33 PM
performing tasks as root curos Linux - Newbie 1 08-06-2003 03:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS

All times are GMT -5. The time now is 10:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration