LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS
User Name
Password
CentOS This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices


Reply
  Search this Thread
Old 09-09-2016, 09:53 AM   #1
pedromclima
LQ Newbie
 
Registered: Sep 2016
Posts: 3

Rep: Reputation: Disabled
CentOS 7 - Boots every 95 minutes - 2 servers


hi!

I've got 2 CentOS servers, freshly installed in SUN leftover servers in my company. After minimal installation I've updated via yum and installed the following packets: corosync, pcs and pacemakar in order to build a cluster.

Cluster worked fine with Squid software.

HOWEVER both machines keeps booting every 95 minutes. I've removed the corosync, pcs and pacemaker packets and the servers keeps booting. I'm using grub2, and there's no mention of ACPI there.

This is the log that comes up when the boot begins:

Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd-logind: Power key pressed.
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd-logind: Powering Off...
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd-logind: System is powering down.
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd: Stopped Stop Read-Ahead Data Collection 10s After Completed Startup.
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd: Stopping Stop Read-Ahead Data Collection 10s After Completed Startup.
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd: Stopping LVM2 PV scan on device 8:2...
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd: Stopping Session 7 of user noc.
Sep 9 10:01:03 BRSPOM2ISP-PROXY-1 systemd: Deactivating swap /dev/mapper/centos-swap...


I've tried editing the /etc/systemd/logind.conf file, and setting IGNORE on "HandleSuspendKey" and "HandleLidSwitch". But the servers keep booting without generating the log above.

Can someone help? I need to get this server up and running.

obviously no one is pressing the power button. I've literally stood in front of the servers for 2 hours to make sure the button wasn't pressed.
 
Old 09-10-2016, 03:49 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,508

Rep: Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744
I'd put a (not so) small bet on STONITH.
 
Old 09-12-2016, 07:48 AM   #3
pedromclima
LQ Newbie
 
Registered: Sep 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
I'd put a (not so) small bet on STONITH.
Thanks for the sugestion, but STONITH (pacemaker, heartbeat and corocync) isnt's installed at this point. Just checked that, and still rebooting.

Last edited by pedromclima; 09-12-2016 at 09:08 AM.
 
Old 09-21-2016, 11:01 AM   #4
angryfirelord
Member
 
Registered: Dec 2005
Distribution: Fedora, CentOS
Posts: 515

Rep: Reputation: 66
Try booting with systemd.confirm_spawn=true. I haven't used it myself, but it should ask you for each service that wants to be run. It might be helpful in seeing what's running and potentially causing a problem.
 
Old 09-27-2016, 11:08 AM   #5
pedromclima
LQ Newbie
 
Registered: Sep 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
Solved it!!!

It was de IPMI Watch Dog, that for some reason was configured to power cycle at 95 minutes.

Thanks for all the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Clock 4 minutes behind actual time on CentOS 6.4 virtualn00b Linux - Distributions 6 09-12-2013 11:10 AM
Centos (RHEL) 6.3 boots into blank screen apollon Red Hat 2 08-15-2013 12:37 PM
CENTOS Crashes after around ten minutes everytime JBJ1962 Linux - Hardware 3 01-02-2013 10:45 PM
[SOLVED] CentOS 5.5 boots up to grub> prompt x81kilo Linux - Software 4 06-06-2010 04:40 AM
Unifying permissions between two servers (CentOS + Webmin/CentOs +Cpanel) and rsync d60eba Linux - Server 1 01-01-2010 01:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS

All times are GMT -5. The time now is 05:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration