-   cAos (
-   -   ALT+B, ALT+F key combinations in xterm don't work (

nIMBVS 04-01-2005 01:07 PM

ALT+B, ALT+F key combinations in xterm don't work
Hello. I have a problem with my recently installed CentOS 4.

The key combinations Alt+B, Alt+F, Alt+S (in mc) etc., don't work in xterm, instead they show
some diacritics characters from other language... I tried changing the settings in .inputrc and I
managed to make xterm not show the diacritics characters (by turning convert-meta to on), but the key
combinations don't do what they're supposed to do, in fact they don't do anything (I press Alt+B and nothing happens).

The key combinations are quite useful in bash so I really need to fix this
problem... Anyone has any idea how to fix it?

nIMBVS 04-03-2005 05:17 PM

Hello again.

I've solved it! I'm so happy.

This is what I did: I put


xterm*eightBitInput: false
in my .Xresources file.

I hope it comes in handy for anyone who wants the old behavior of xterm back.

Molly 01-30-2008 11:43 PM

hey this has been extremely helpful for me as well!
much thanks!

i dropped your line into my ~/.Xdefaults file and the xterm + irssi keybindings problem I was also having is now fixed.


slaecker 04-26-2009 02:16 PM

Very helpful here too, thanks!

Foxbat1155 12-15-2011 01:52 AM

Very helpful to me, the Xdefault but not the Xresources, that didnt work. =)

All times are GMT -5. The time now is 11:16 PM.