LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 09-24-2014, 11:41 PM   #1
mwstroberg
LQ Newbie
 
Registered: Sep 2014
Distribution: Bodhi
Posts: 2

Rep: Reputation: Disabled
Volume Levels Set With alsamixer Don't Persist On Reboot


Hello,

I am not quite a Linux Newbie but am quite new to Bodhi.

I am able to set audio volume levels with alsamixer, but when I reboot all the settings are lost, and the setting are restored to where they were when I first logged in after installation. If someone could help me figure out how to make audio volume level persist on a reboot, I would appreciate it.

Thanks in advance.

Mark
 
Old 09-26-2014, 10:04 AM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,280

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
As root, once you have the volume set as you wish, run the command 'alsactl store' ( without the quotes ) should store the current value. See the man page for more details.
 
Old 09-27-2014, 07:19 AM   #3
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 8,955
Blog Entries: 5

Rep: Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179
small correction:
Quote:
Originally Posted by camorri View Post
once you have the volume set as you wish, run the command 'alsactl store' ( without the quotes ) as root.
meaning:
Code:
sudo alsactl store
 
Old 09-27-2014, 10:23 PM   #4
mwstroberg
LQ Newbie
 
Registered: Sep 2014
Distribution: Bodhi
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ondoho View Post
small correction:meaning:
Code:
sudo alsactl store
Thanks, but it didn't work. Neither sudo nor actually logging in as root and saving settings worked. When I rebooted the same totally weird setting were in place, rather than the ones I wanted.

May I ask a question: Why aren't volume setting a per-user thing, and why aren't they automatically saved and restored on logging in and out?

I don't know what I am doing wrong, but just can't seem to get this to work.
 
Old 09-28-2014, 06:55 AM   #5
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,280

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
Quote:
why aren't they automatically saved and restored on logging in and out?
They are on my system. This is just a guess, I was wondering if Bodhi uses Pulse Audio? If yes, your problems probably lie there.

If not, there is something wrong wrong with your permissions, or groups your user belongs to. I don't run Bodhi, so I can not tell you what groups you need to belong to. To find out what groups your user belongs to, run the command 'groups' ( without quotes ) and you should get a list of the groups your user belongs to. Another guess, add yourself to the audio group, if you do not belong to it.

There is usually only one active audio device at one time. Multiple users logging in with different settings would be havoc.
 
Old 09-28-2014, 08:25 AM   #6
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,984

Rep: Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553
I had a similar problem after doing a regular update on my PCLinux with KDE. If I changed the settings and logged out or logged back in the volume was at 100% which was pretty annoying. I used alsamixer and it only showed two options: Master and PCM which was a little odd. The Kmix front end didn't save any changes either so I had an option in the control center to disable pulseaudio which I did and it works. The first thing I would suggest is to look for an option to disable it. The first link below explains removing it completely which might be a little drastic and the second link shows commands to remove, update and reinstall. I did an online search for "disable pulseaudio in Bodhi" and all I got were ways to remove. You might have better luck trying it.


http://www.hecticgeek.com/2012/01/ho...-ubuntu-linux/
http://forums.bodhilinux.com/index.p...ng-pulseaudio/
 
Old 09-28-2014, 08:57 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 8,955
Blog Entries: 5

Rep: Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179Reputation: 2179
1) i'm not sure what's going on because i don't have the problem
2) if it's pulseaudio related, i'm even more lost because i don't use it
3) bodhi linux does have its own forum

that said, looking at
Code:
man alsactl
i'm having a few ideas:

a) make sure that your system doesn't run "alsactl init" at startup or login
b) try a manual "alsactl (n)restore", does it help?
c) have a look at /var/lib/alsa/asound.state (nausea warning) - maybe you can find some clues
d) try saving and restoring settings to a different file with the "-f" option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Volume Control: Intel 82801DB-ICH4 (Alsa mixer) won't save volume levels. cayspekko Linux - Newbie 2 01-31-2008 12:17 AM
Can't change volume levels corbis_demon Linux - Newbie 0 10-11-2004 02:34 AM
Volume Levels lower by themselves! cuco76 Fedora 1 05-20-2004 12:26 AM
alsamixer changes emu10k1 levels everytime xmms changes songs sulzla Linux - Software 0 06-29-2003 11:05 PM
Restoring Volume Levels after reboot MasterC Slackware 16 09-22-2002 01:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration