LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 09-08-2019, 06:08 AM   #1
Rosika
Member
 
Registered: Apr 2017
Distribution: Lubuntu 64 bit
Posts: 228

Rep: Reputation: Disabled
terminal has problems with cyrillic letters


Hi altogether,

I use Bodhi Linux in a VM and it is up-do-date.
Yet thereīs one thing which strikes me as odd:

When I use the terminal ("terminology" in bodhi linux) I donīt get the correct representation of cyrillic letters.

I noticed this when using translate-shell (https://www.soimort.org/translate-shell/ ) and wanted to use
Code:
trans -shell de:ru [...]
, which is a translation from German to Russian.

I even installed language-pack-ru on my system, which was of no avail.

So I looked up https://wiki.ubuntuusers.de/Spracheinstellungen/ , which provides a reference to the command
Code:
sudo dpkg-reconfigure console-setup
for setting things right in the virtual console. I thought maybe this would work for my
terminal as well. But alas it didnīt.

Now that Iīve run out of ideas: is anyone here in the forum who might be able to help me?

Thanks a lot in advance.

Gretings.
Rosika
 
Old 09-08-2019, 06:42 AM   #2
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 533

Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Hello there

Firstly try this and select your layout in the wizard:
sudo dpkg-reconfigure tzdata

If do not help, try loading keyboard module and add ru layout.

Feel free to ask

Stefan
 
1 members found this post helpful.
Old 09-08-2019, 07:08 AM   #3
Rosika
Member
 
Registered: Apr 2017
Distribution: Lubuntu 64 bit
Posts: 228

Original Poster
Rep: Reputation: Disabled
@the_waiter:

Hi Stefan and thanks for your suggestion.

Code:
sudo dpkg-reconfigure tzdata
didnīt help. It gave me just the setting-options for gegraphical location (Europe in my case) and time-zones (Berlin in my case).

Quote:
try loading keyboard module and add ru layout.
Sorry, but Iīm not quite sure how to do this. Itīs been a while......

Greetings.
Rosika
 
Old 09-08-2019, 08:04 AM   #4
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 533

Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
terminal has problems with cyrillic letters

menu-settings-modules and load keyboard module. An icon with question mark will appear on the shelf and you can add as many layouts as you wish and you can switch among them. I will provide a screenshot for you when I get home.
 
1 members found this post helpful.
Old 09-08-2019, 08:18 AM   #5
Rosika
Member
 
Registered: Apr 2017
Distribution: Lubuntu 64 bit
Posts: 228

Original Poster
Rep: Reputation: Disabled
Hi Stefan,

thanks a lot for your help.
I think I could manage it now. I digged a bit deeper plus according to your previous guidance I added the Russian layout.

But the real trick seemed to be this one: In the terminal I chose "Einstellungen" (settings) and selected "Ubuntu Mono (regular)".
This is perfectly able the display cyrillic letters without any fault.

I just had to make the font a little bigger by using the slider.

So thanks again for your help.

Have a nice Sunday.
Many greetings.

Rosika
 
Old 09-08-2019, 10:47 AM   #6
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 533

Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Fantastic

Enjoy the beauty and speed of Bodhi Linux



Stefan
 
Old 09-08-2019, 11:02 AM   #7
Rosika
Member
 
Registered: Apr 2017
Distribution: Lubuntu 64 bit
Posts: 228

Original Poster
Rep: Reputation: Disabled
Hi again,

yes, indeed.
Itīs particularly the speed of Bodhi Linux and its lightweight nature which Iīm very pleased with.
Iīm running it in a VM at the moment with minimal specs (just 1 GB virtual RAM) and itīs still a pleasure to deal with
and very responsive.

Greetings
Rosika
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
to grep 100 letters out of 500 letters on certain criteria l_ravi69 Programming 3 10-13-2013 11:37 AM
Can't stop fast typing double letters from "skipping" one of the letters. Lola Kews Ubuntu 3 04-20-2013 03:21 PM
Cyrillic letters in Wine danker Linux - Software 1 03-06-2007 12:09 PM
Cyrillic letters on Western-based XFCE mjjzf Slackware 2 06-02-2005 02:50 AM
Problems with cyrillic encoding in Mandrake 9.2 buboleck Mandriva 1 12-31-2003 09:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 08:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration