LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 08-07-2018, 01:25 PM   #1
svshyam91
LQ Newbie
 
Registered: Aug 2018
Posts: 3

Rep: Reputation: Disabled
Tap To Click Not Working (Touchpad)


I have installed bodhi 5.0 (Standard Release) but after successful installation tap to click is not working.
For clicking I have to press the touchpad button.
I have also not found any setting in the setting panel so that I can enable it. I think tap to click is disabled now.
Please help me to solve the problem since it is very annoying to press the button every time for clicking.

Last edited by svshyam91; 08-07-2018 at 01:26 PM.
 
Old 08-07-2018, 02:08 PM   #2
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, LFS, Haiku, Quirky on Rpi and many others
Posts: 864
Blog Entries: 2

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Check the output of
Code:
synclient
What is the value of TouchpadOff?
 
Old 08-07-2018, 02:17 PM   #3
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Fedora, Arch, & KDE Neon
Posts: 2,781

Rep: Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799Reputation: 799
Not familiar with Bodhi linux, so do you happen to know if it's using the synaptics driver or the libinput driver for touchpad control?
 
Old 08-07-2018, 02:35 PM   #4
svshyam91
LQ Newbie
 
Registered: Aug 2018
Posts: 3

Original Poster
Rep: Reputation: Disabled
Output of synaptics

After installing xserver-xorg-input-synaptics
output of synclient command:

Couldn't find synaptics properties. No synaptics drivers loaded?

I have found a solution to temporarily enable it using xinput set-prop command but as I shutdown or logout my system, the settings are erased.
 
Old 08-15-2018, 01:57 PM   #5
rrashkin
LQ Newbie
 
Registered: Aug 2018
Posts: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by svshyam91 View Post
After installing xserver-xorg-input-synaptics
output of synclient command:

Couldn't find synaptics properties. No synaptics drivers loaded?

I have found a solution to temporarily enable it using xinput set-prop command but as I shutdown or logout my system, the settings are erased.
I had the same problem with BL5 RC2 but I didn't know how to use xinput. In case there are others with who encounter the same problem and share my ignorance, this is what I found out:

>install xinput: sudo apt install xinput
>list the devices to find pointer: xinput --list

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ VGA Webcam: VGA Webcam id=10 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
↳ Acer WMI hotkeys id=13 [slave keyboard (3)]

[note the ID number, 12]
>list the properties of the pointer: xinput --list-props 12
Device 'SynPS/2 Synaptics TouchPad':
Device Enabled (142): 1
Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (277): 0
libinput Tapping Enabled Default (278): 0
libinput Tapping Drag Enabled (279): 1
. . .
[there are a bunch more. note the property, 277]
>enable tapping: xinput --set-prop 12 277 1

Last edited by rrashkin; 08-15-2018 at 01:59 PM.
 
Old 08-15-2018, 02:22 PM   #6
svshyam91
LQ Newbie
 
Registered: Aug 2018
Posts: 3

Original Poster
Rep: Reputation: Disabled
I have already tried this solution and it works but the problem is as I restart the system the setting is not actuve. I have to re-execute this command to make the things back to normal.
This is not a permanent solution.
Please give any permanent solution.
 
Old 08-15-2018, 03:02 PM   #7
rrashkin
LQ Newbie
 
Registered: Aug 2018
Posts: 5

Rep: Reputation: Disabled
I don't know what to do but did you try Tapping Enabled Default [278]?

Anyway, I was glad to see any solution. I had just about convinced myself I could live with clicking instead of tapping. When I saw your post I had to figure out the details. I'm pretty sure I can live with setting it each time I log on.
 
Old 08-15-2018, 05:06 PM   #8
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, LFS, Haiku, Quirky on Rpi and many others
Posts: 864
Blog Entries: 2

Rep: Reputation: 314Reputation: 314Reputation: 314Reputation: 314
Quote:
Originally Posted by svshyam91 View Post
I have already tried this solution and it works but the problem is as I restart the system the setting is not actuve. I have to re-execute this command to make the things back to normal.
This is not a permanent solution.
Please give any permanent solution.
Most desktop environments have an autostart feature that allows you to run any command at start-up.

It might also be possible to add that command to your ~/.bashrc file.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Manjaro Touchpad Tap to Click llewellen Linux - Laptop and Netbook 6 11-06-2016 11:33 AM
how to disable tap to click with touchpad Knightron Slackware 4 02-11-2012 01:14 AM
how to enable touchpad tap click Xfce fastestOS Slackware 4 08-30-2009 04:27 AM
how to disable touchpad's tap click? fastestOS Slackware 3 08-26-2008 01:59 AM
Touchpad won't tap-click Detour Linux - Laptop and Netbook 3 11-08-2004 08:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration