LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Sound Not Working (USB External Audio Interface) (https://www.linuxquestions.org/questions/bodhi-92/sound-not-working-usb-external-audio-interface-4175682529/)

michael diemer 09-22-2020 03:16 PM

Sound Not Working (USB External Audio Interface)
 
The one thing I can't get working on my new Bodhi 4.5 install. I have a Steinberg UR22 external audio interface. Bodhi recognizes it, but the controls don't work. The controls do work for the onboard sound.

This is no problem on other Linux distros, it always works out of the box. For some reason it doesn't on Bodhi.

I have tried installing all Pulse downloads for Ubuntu with Synaptic, but it didn't help. also tried installing some Alsa apps with same results.

Anyone have any ideas? I much prefer the sound from my pro interface, and I pipe it upstairs to our stereo for our morning music.This would be more difficult with the jacks in back of the computer.

lucmove 09-23-2020 02:51 AM

More information is needed.

How do you know that the system recognizes the external audio interface, and what do you mean by "the controls don't work"? What controls? Why do you think they don't work? What do you expect them to do that is not happening?

Try running alsamixer and pressing F6 to check all the levels of that specific audio card.

michael diemer 09-23-2020 12:27 PM

Quote:

Originally Posted by lucmove (Post 6168789)
More information is needed.

How do you know that the system recognizes the external audio interface, and what do you mean by "the controls don't work"? What controls? Why do you think they don't work? What do you expect them to do that is not happening?

Try running alsamixer and pressing F6 to check all the levels of that specific audio card.

Thank you for your reply. To answer your questions, when I open the audio app and hit the settings icon, I see both the onboard sound and the Steinberg Ur22 listed as options. You can adjust the volume on the onboard sound, but the controls don't move on the Steinberg option, it just appears "dead."

I am on Ubuntu at the moment so I will try your suggestion later today.

michael diemer 09-23-2020 05:08 PM

Unfortunately, another problem has occurred. I can't boot Bodhi at the moment. Will resume working on sound problem when I figure out how to boot again. I have some repair discs to try, should get up and running again soon.

michael diemer 09-28-2020 09:45 AM

Update: I had to give up on Bodhi 4.5, but I tried Bodhi 5 again, and so far it's working. I thought I would have to use Nvidia driver 304, which can't be installed in Bodhi 5 (uless you install the older 4.4 kernel, which I will try if I need to). But the open source drivers are performing well so far. I will try the external audio interface in a moment but I have to shut down now as I don't know how to safely eject my WD Passport (keep getting told I don't have permission).

michael diemer 09-28-2020 10:03 AM

OK, good news! Sound is working on my Steinberg UR-22. Not sure why I couldn't get it working on Bodhi 4.5, but that stopped booting anyway. Hopefully Bodhi 5 will continue working well. So far midori has not crashed, so I'm holding off on installing vivaldi, which may be too heavy for my on-board graphics. I'll use midori happily if it means I can use Bodhi 5!

cordx 09-28-2020 06:50 PM

as thewaiter pointed out here, it might be a good idea to try a browser other than midori if you haven't already done so :)

michael diemer 09-28-2020 11:53 PM

Quote:

Originally Posted by cordx (Post 6170609)
as thewaiter pointed out here, it might be a good idea to try a browser other than midori if you haven't already done so :)

I did, I have vivaldi up and running. At first, just as I figured, there was screen tearing, and I had a hard time disabling acceleration. But I eventually tracked down the correct checkbox. As soon as I disabled it, vivaldi took off running and hasn't stopped since.


All times are GMT -5. The time now is 07:20 PM.