LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Shelf clock doesn't update correctly after screen blank (https://www.linuxquestions.org/questions/bodhi-92/shelf-clock-doesnt-update-correctly-after-screen-blank-4175657571/)

enigma9o7 07-17-2019 02:31 PM

Shelf clock doesn't update correctly after screen blank
 
The screen automatically blanks due to inactivity by default. When I press a key to resume, the clock on the shelf shows the time and date from when it first blanked.

What happens from that point is that it does start changing time, but only the digits that actually change since after I unblanked. For example, when I unblanked just now, it showed 1:10pm on tuesday 16 july. (That's yesterday btw). In the last few minutes, the last digit changed to 3 then 4 now 5, so it shows 1:15pm tues 16 july. In another few minutes the tens digit will start being accurate and it'll show 1:30pm, and in less than an hour the hour will start to be accurate when it switches to 12:00pm; also when I pass noon (or midnight) the am/pm will start to be accurate , but the date won't be accurate til after midnight. Unless of course I idle again and it blanks.

I've had this problem forever. I hadn't noticed it in a while cuz I'd switched on 'presentation mode', but recently reset all my moksha settings (so presentation mode no longer set) and was reminded of this. I would actually like to be able to use the screen blanker, so if anyone has any ideas...

This is on bodhi 5, 64-bit, with nvidia-340 video driver.

p.s.
My theory, is that my video driver is too slow to resume or something, maybe moksha tries to set the clock before video is ready, so there needs to be some delay or some check before it writes that clock the first time. Note that I am not ever suspending/shutting down, this computer is on 24/7...

Of course I'd like this to not happen anymore, but as a workaround, if i reset moksha with ctrl-alt-end then it redraws the shelf with accurate clock.

the_waiter 07-18-2019 11:44 AM

Hello

One guy (not you?) was complaining about the clock value in the past. The culprit was compton compositor in his case. Do you use a compositor?

Stefan

enigma9o7 07-18-2019 12:47 PM

Ah ok. Probably was me. I forgot this only happens with compton.

hemlocktree 07-18-2019 12:53 PM

nice catch stefan. i too forgot about that thread.

the_waiter 07-18-2019 01:05 PM

...and I thought my memory is in bad condition :) (Hi Robert! :))

enigma9o7 07-18-2019 01:14 PM

So nothing I can do about it, right?

Now that you remind me about the composter stuff, I remember I already tried to find another compositor since compton isn't being updated but the others I tried did the same thign.

the_waiter 07-18-2019 01:17 PM

If I remember the clock issue I had too here but after some seconds the value was corrected by itself. Maybe we should compare our compton.conf setting. It could be related. There are many examples on web. Probably yours is not clock friendly...

Stefan

EDIT: my compton.conf
https://pastebin.com/stYf8Ahz

enigma9o7 07-18-2019 01:34 PM

I never changed anything from default. Don't even know where that file is (although I'll search now).

the_waiter 07-18-2019 01:35 PM

hidden folder .config

/home/user/.config/compton.conf

enigma9o7 07-18-2019 01:41 PM

Not there. I'll try putting yours there tho.

the_waiter 07-18-2019 01:46 PM

Hmm, do you have compton running after start?

enigma9o7 07-18-2019 01:48 PM

Yep, in e startup commands. I just put your config file in, going to reboot to be sure it's taken affect, then will see what happens when my screen blanks later today.

the_waiter 07-18-2019 01:49 PM

Good luck ;)

enigma9o7 07-19-2019 01:06 PM

I think it worked; I haven't seen this reoccur. Some setting in your conf that's different than default solved the problem. Thanks much.

hemlocktree 07-19-2019 01:14 PM

way to go stefan!


All times are GMT -5. The time now is 10:17 AM.