LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 01-29-2019, 04:58 AM   #1
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 157
Blog Entries: 12

Rep: Reputation: 26
Setting default displays


One last issue, and then I will stop bothering you.

In other Ubuntu-based distros, when I want my laptop dispoay off and my large screen TV used as my monitor, I just have to go to Displays and set it. It remains set.

In Bodhi, the only way I can set this is using Applications - Preferences - ARandR (don't know what that means), and when I set it and reboot the setting has to be redone each time. There is a button to save the file, but apparently doesn't save it in the right place or doesn't bother to read it.

Help, please?

I woould like to say that Bodhi looks better than ever, and it looks like I may be able to get it (and keep it) working on my system for the first time (see previous comments on earlier versions).
 
Old 01-30-2019, 05:07 PM   #2
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 176

Rep: Reputation: 25
i believe ARandR is a gui version of xrandr. i don't know enough about either to be able to help with a specific command, but once you have the xrandr command you should be able to add it to startup commands through the swami control panel.
 
Old 01-31-2019, 12:41 PM   #3
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 10,763
Blog Entries: 7

Rep: Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694
arandr is good.

Quote:
Originally Posted by zaivala View Post
In Bodhi, the only way I can set this is using Applications - Preferences - ARandR (don't know what that means), and when I set it and reboot the setting has to be redone each time. There is a button to save the file, but apparently doesn't save it in the right place or doesn't bother to read it.
it saves your configuration as an executable script.
you then have to add this script to your autostart facility (a.k.a. startup applications).
the good thing is, by default arandr always saves to the same script, so you have to add it only once and your screen res will change after log out/in.
 
1 members found this post helpful.
Old 01-31-2019, 02:50 PM   #4
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 157

Original Poster
Blog Entries: 12

Rep: Reputation: 26
OK, using my extremely finite knowledge and abilities, I added ARandR to my Startup.

I now boot to nothing but wallpaper. I don't know how to fix this other than reinstall.
 
Old 01-31-2019, 05:48 PM   #5
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 176

Rep: Reputation: 25
Quote:
Originally Posted by zaivala View Post
OK, using my extremely finite knowledge and abilities, I added ARandR to my Startup.
can you give some more specific details about what you did?
 
Old 02-01-2019, 02:01 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 10,763
Blog Entries: 7

Rep: Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694
Quote:
Originally Posted by zaivala View Post
OK, using my extremely finite knowledge and abilities, I added ARandR to my Startup.
that is not what i said.
you should add the script that arandr saves (if you tell it to).

Quote:
I now boot to nothing but wallpaper. I don't know how to fix this other than reinstall.
"something went wrong". this should not happen.
i wonder what exactly you added to which startup exactly.

be precise when telling other people about your problems, how else are they going to help you?
 
1 members found this post helpful.
Old 02-01-2019, 05:19 AM   #7
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 157

Original Poster
Blog Entries: 12

Rep: Reputation: 26
I was as specific as I know how to be. Basically, I could not find how to just add the script. I did see that ARandR was available to add to the Startup, and did so. This was the mistake. However, after an attempt to reinstall, I am NOT having as good a time, as for some reason I can't get PolicyKit-1 to load and run. I added it as shown in the other thread, but it does not show up in my Startup batch (no PolicyKit Application whatsit to select). I may have to do yet another install; might use the lighter installation.

I was not aware that Bodhi was the project of only two developers. If I can manage to be of any help, I will.
 
1 members found this post helpful.
Old 02-01-2019, 08:47 AM   #8
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 176

Rep: Reputation: 25
Quote:
Originally Posted by zaivala View Post
I was as specific as I know how to be.
we all do the best we know how to do here. feel free to continue to ask questions. answers are not always immediate or even guaranteed, but i believe the site is linuxquestions for a reason
 
1 members found this post helpful.
Old 02-02-2019, 03:46 AM   #9
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 157

Original Poster
Blog Entries: 12

Rep: Reputation: 26
So I need more information on how to add the SCRIPT to my startup batch. Not finding it yet. Thanks for listening.
 
1 members found this post helpful.
Old 02-02-2019, 05:01 AM   #10
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 176

Rep: Reputation: 25
do you already have the script?
 
Old 02-03-2019, 04:33 AM   #11
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 157

Original Poster
Blog Entries: 12

Rep: Reputation: 26
I assume I do, as I saved it. I may have to do some looking to see where it was saved to.
 
Old 02-03-2019, 04:58 AM   #12
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 157

Original Poster
Blog Entries: 12

Rep: Reputation: 26
Quote:
Originally Posted by cordx View Post
do you already have the script?
Yes. yes I do.

/home/zaivala/.screenlayout/default.sh
 
1 members found this post helpful.
Old 02-03-2019, 05:15 PM   #13
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 176

Rep: Reputation: 25
Quote:
Originally Posted by zaivala View Post
OK, using my extremely finite knowledge and abilities
i also have to clain finite knowledge on this one. unfortunately i didn't come across the exact fix i think you are looking for. i tried two methods. i opened my default_display.sh file and got the xrandr command. i added that to the startup commands through the swami control panel, but it failed to adjust my display on reboot. i added the .sh file itself with (what i think is) the command to run it:

Code:
sudo ./path/to/file/default_display.sh
that also failed to change anything on reboot.

however, when opening (by double click) the .sh file to get the xrandr code out, i noticed that one of the options was to execute the file. the first time i chose open. out of curiosity another time i chose execute and it did indeed change my resolution instantly. i know it isn't the autorun i think you would prefer, but it seems to me that if you keep that file in an easy to reach location (like move it out of .screenlayout and just put it in /home) it might be a tiny bit quicker to execute than having to open arandr, choose the settings you want and then apply those settings.

when i was researching how to autolaunch a different program, i came across some information that certain programs need a delay in order to allow other programs to load before them. i don't know if that is the reason my autolaunch did not work in this instance. i just wanted to add that in case you decide to tinker with the command and it might help.
 
1 members found this post helpful.
Old 02-04-2019, 02:24 AM   #14
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 10,763
Blog Entries: 7

Rep: Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694Reputation: 2694
^ that command does not need sudo. that's potentially harmful.
___________________________

OK, i finally installed bodhi in a vm yesterday (*).

then i spent a long time trying to figure out how to add a command to startup applications, logging out/in many times to see if it worked.
not sure what i was doing wrong, but i never succeeded (**).
I succeeded in creating the appropriate .desktop file (that works when i doubleclick it).
i even manually copied that .desktop file to ~/.config/autostart, but it seems moksha does not execute the programs therein.

then finally i had a look at the hidden files in $HOME, and lo and behold, there it is:
open $HOME/.e/e/applications/startup/startupcommands with epad, and add the line
Code:
/home/zaivala/.screenlayout/default.sh
log out/in - voilá, new resolution applied!

(*) it also took me a trip to the wiki to even find the installer.
(**) that settings panel is unintuitive to the extreme, and i suspect also buggy (like when i Add something and it then doesn't show up on the list).
 
1 members found this post helpful.
Old 02-04-2019, 07:30 AM   #15
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 176

Rep: Reputation: 25
Quote:
Originally Posted by ondoho View Post
^ that command does not need sudo. that's potentially harmful.
how so?
 
  


Reply

Tags
bodhi, display


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Iceweasel displays Firefox logo on default home page edwardp Debian 7 10-03-2014 08:05 PM
[SOLVED] less displays binary but cat displays ascii? ahtoot Linux - Newbie 3 01-25-2011 09:38 PM
Need help setting up 3 displays on 2 GPUs nightshade_1977 Linux - Hardware 0 05-16-2010 04:17 PM
Dual monitors, separate X displays; want firefox in both displays bforbes Linux - Desktop 7 10-15-2008 10:26 PM
Setting Internal vs. External Displays bluueknigh7 Linux - Laptop and Netbook 0 09-21-2006 03:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 09:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration