LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   SD Card in Expresscard Adapter - Not always seen after reboot. (https://www.linuxquestions.org/questions/bodhi-92/sd-card-in-expresscard-adapter-not-always-seen-after-reboot-4175657637/)

enigma9o7 07-18-2019 02:28 PM

SD Card in Expresscard Adapter - Not always seen after reboot.
 
I doubt anyone is going to be able to help, I spent hours and hours searching and trying things yesterday to no avail. But maybe someone has an idea.

I have an older Sony Laptop (VPCF115FM) with an expresscard slot. I wanted to add some more storage but the built in SD card slot only takes SDHC up to 32GB, so I bought a Maxell UHS-1 SDHC/SDXC Expresscard Adapter and a 400GB Sandisk Ulta SDXC Card.

Hotplugged and it was instantly recognized. Removed exfat partition, created f2fs partition, created fstab entry.

Here's the problem. Sometimes when I reboot, it's not recognized. I can confirm this by ls /dev/sd* and if there's no sdb and sdb1, then I can't mount it. It seems, at least in the times I've tried in the past day since I've got this thing, that it always works after power cycle.

In my searches online for similar problems, I never found someone with the exact same problem. I found many people who had hotplug issues, but they always reported that reboots were fine; even so I tried applying several of their solutions which either didn't work right or didn't help. Several involved modprobe which never seemed to work right, perhaps that's something old?

(At one point I thought adding 'pciehp_force=1 pciehp_poll_mode=1"' to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub fixed it, but then I realized it isn't consistent, some reboots work, some dont...)

BW-userx 07-18-2019 03:28 PM

that is that little card slot on the side of your laptop. have you tried popping it out then pushing it back in to reestablish the connection? BIOS always on setting maybe. just a thought(s).

enigma9o7 07-18-2019 03:35 PM

No settings at all related to it in bios, other than boot order. My bios has very limited configuration settings at all in fact.

Yes I've tried remove/reinsert, that works fine. No hotplug issues.

The reason that doesn't easily work as a workaround is that I want to store video files on their that are indexed by plex server, which starts at boot. If the drives not there, it removes them from index... then when I reinsert, it re-indexes them, but waste of resources.

I intend to leave this in all the time, although I guess technically android should be able to read f2fs too if I ever wanted to.

BW-userx 07-18-2019 04:22 PM

well there isn't much I can tell you, it looks to be hardware limitations as to how that card works.

enigma9o7 07-18-2019 05:21 PM

To eliminate that as an issue, I tested it in windows, three reboots in a row it was seen. can't do the same in linux.


All times are GMT -5. The time now is 07:47 AM.